Closed Bug 747681 Opened 8 years ago Closed 7 years ago

Rotation breaks content window with targetSdkVersion=14

Categories

(Firefox for Android :: General, defect, blocker)

ARM
Android
defect
Not set
blocker

Tracking

()

RESOLVED FIXED
Firefox 14
Tracking Status
blocking-fennec1.0 --- beta+

People

(Reporter: aaronmt, Assigned: joe)

References

Details

(Keywords: regression, reproducible, Whiteboard: [ICS])

Attachments

(1 file)

Rotations from portrait to landscape kill Gecko on ICS with the Galaxy SII

See video: http://www.youtube.com/watch?v=34v8dZvU7G8&hd=1

There's nothing too useful in the log.

Nominating because ICS is being pushed to the SII as of last week.

--
Nightly (04/21)
Samsung Galaxy SII (Android 4.0.3)
blocking-fennec1.0: --- → ?
Chris/Kats, happy to take a debug build with log output for testing like last time this happened
Whiteboard: [ICS]
Severity: critical → blocker
Happens on the Galaxy Nexus too.
Summary: Rotation kills Gecko with ICS on the Galaxy SII → Rotation kills Gecko
Regression from bug 732016?
Blocks: 732016
(Not really killing Gecko, but entire content area for each page is completely white with no way to recover. Things like the Tab Menu icon are removed, browser becomes unusable).
I backed out bug 732016 and it didn't fix this bug. I'll keep looking into it.
Assignee: nobody → joe
No longer blocks: 732016
blocking-fennec1.0: ? → beta+
The first bad revision is:
changeset:   91988:7ecd07342540
user:        Matt Brubeck <mbrubeck@mozilla.com>
date:        Thu Apr 19 12:28:13 2012 -0700
summary:     Bug 746703 - Set targetSdkVersion to 14 in AndroidManifest.xml to disable legacy menu button [r=blassey, a=blocking-fennec]

Gonna test a build with this backed out.
Blocks: 746703
Yup: https://hg.mozilla.org/integration/mozilla-inbound/rev/9daee30907ea
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Summary: Rotation kills Gecko → Rotation breaks content window due to hardware acceleration enabled by default (target SDK 14)
Duplicate of this bug: 747799
Target Milestone: --- → Firefox 14
Verified/fixed on:
Nightly Fennec 15.0a1 (2012-04-25)
Device: Galaxy Nexus (Android 4.0.2), HTC Desire Z (Android 2.3.3)
Status: RESOLVED → VERIFIED
The build above in comment #10 specifying hardwareAccelerated with false is not valid overrode with the forced declaration of targetSDK 14 as it reintroduces this bug.

Tested with a Galaxy Nexus (Android 4.0.4)
As far as I can tell this is not caused by hardware acceleration; see bug 746703 comment 23 for details.
Summary: Rotation breaks content window due to hardware acceleration enabled by default (target SDK 14) → Rotation breaks content window with targetSdkVersion=14
(In reply to Joe Drew (:JOEDREW!) from comment #7)
> Yup: https://hg.mozilla.org/integration/mozilla-inbound/rev/9daee30907ea

That backout didn't stick but is listed as the fix here. http://hg.mozilla.org/releases/mozilla-aurora/file/bac25b8ea4e7/mobile/android/base/AndroidManifest.xml.in#l13 and http://hg.mozilla.org/mozilla-central/file/f2b2b99108a2/mobile/android/base/AndroidManifest.xml.in#l13 still have 14 set as the version.

https://crash-stats.mozilla.com/report/list?signature=libdvm.so%400x50a4e&version=FennecAndroid%3A14.0b1 is pretty high up on the topcrash list of 14.0b1 and is listed as one signatures of the dupe-to-here bug 747799, so we need to be clear on what's up with that.

Joe, Matt, can you clear up what's going on here?
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #13)
> (In reply to Joe Drew (:JOEDREW!) from comment #7)
> > Yup: https://hg.mozilla.org/integration/mozilla-inbound/rev/9daee30907ea
> 
> That backout didn't stick but is listed as the fix here.

This was ultimately fixed by adding "screenSize" to android:configChanges 
(bug 746703 comment 24) before re-landing bug 746703:
http://hg.mozilla.org/mozilla-central/rev/b89b6430e4bf
https://hg.mozilla.org/releases/mozilla-aurora/rev/88982d73f135

> https://crash-stats.mozilla.com/report/list?signature=libdvm.
> so%400x50a4e&version=FennecAndroid%3A14.0b1 is pretty high up on the
> topcrash list of 14.0b1 and is listed as one signatures of the dupe-to-here
> bug 747799, so we need to be clear on what's up with that.

That bug should not be duped to this one.  This bug was not a crash.
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.