Last Comment Bug 747743 - Mojibake in context menus on the chat conversation
: Mojibake in context menus on the chat conversation
Status: RESOLVED FIXED
: jp-critical
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: 13 Branch
: x86 Windows 7
: -- normal (vote)
: Thunderbird 14.0
Assigned To: Florian Quèze [:florian] [:flo]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-22 06:36 PDT by Masahiko Imanaka [:marsf]
Modified: 2012-04-23 13:30 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
mojibake in chat context menu (8.88 KB, image/png)
2012-04-22 06:36 PDT, Masahiko Imanaka [:marsf]
no flags Details
Fix (957 bytes, patch)
2012-04-23 06:27 PDT, Florian Quèze [:florian] [:flo]
clokep: review+
mozilla: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Masahiko Imanaka [:marsf] 2012-04-22 06:36:09 PDT
Created attachment 617314 [details]
mojibake in chat context menu

User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; ja; rv:1.9.2.28) Gecko/20120306 Firefox/3.6.28
Build ID: 20120306064154

Steps to reproduce:

1. Open chat tab.
2. Connect twitter account.
3. Right click individual tweet to show its context menu.


Actual results:

Only the menus of twitter actions (retweet, reply, follow, ... ) has mojibake.
It seems that the localized UTF-8 strings are not properly handled.
Comment 1 Florian Quèze [:florian] [:flo] 2012-04-23 03:13:05 PDT
I'm a bit confused by this bug report, as:
- I've tried to replace the en-US strings with strings containing UTF8 characters in my debug build, and these strings were displayed correctly.
- I've tried to find the ja translation of these strings, but http://hg.mozilla.org/l10n-central/ja/file/tip/chat/twitter.properties doesn't exist (I've checked the URL with the French locale, and http://hg.mozilla.org/l10n-central/fr/file/tip/chat/twitter.properties#l20 does exist).
Comment 2 Masahiko Imanaka [:marsf] 2012-04-23 06:06:29 PDT
I've tested on Aurora build. (We haven't updated l10n-central.)
Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20120422 Thunderbird/13.0a2

http://hg.mozilla.org/releases/l10n/mozilla-aurora/ja/file/47eeb04b0b3c/chat/twitter.properties

Tooltips and options are displayed correctly.
Comment 3 Florian Quèze [:florian] [:flo] 2012-04-23 06:27:36 PDT
Created attachment 617456 [details] [diff] [review]
Fix

I couldn't reproduce with a string containing French non ASCII characters, but I can reproduce using the strings in the ja localized file.

It's caused by a trivial type error in the idl interface.

Thanks for reporting this!
Comment 4 Patrick Cloke [:clokep] 2012-04-23 06:52:12 PDT
Comment on attachment 617456 [details] [diff] [review]
Fix

This change looks fine, thanks for fixing it Florian.
Comment 5 Florian Quèze [:florian] [:flo] 2012-04-23 07:36:06 PDT
http://hg.mozilla.org/comm-central/rev/9869097a829e
Comment 6 Mike Conley (:mconley) - (Needinfo me!) 2012-04-23 08:17:22 PDT
Drive-by comment here - should the UUID for that IDL have been changed?
Comment 7 David :Bienvenu 2012-04-23 08:22:56 PDT
(In reply to Mike Conley (:mconley) from comment #6)
> Drive-by comment here - should the UUID for that IDL have been changed?

I don't think Thunderbird cares since we haven't turned this on, but Instantbird might...
Comment 8 Florian Quèze [:florian] [:flo] 2012-04-23 08:33:02 PDT
(In reply to David :Bienvenu from comment #7)
> (In reply to Mike Conley (:mconley) from comment #6)
> > Drive-by comment here - should the UUID for that IDL have been changed?
> 
> I don't think Thunderbird cares since we haven't turned this on, but
> Instantbird might...

I've never applied that rule for Instantbird as I'm not aware of any binary add-on using our xpcom interfaces.
Comment 9 Mark Banner (:standard8) (afk until 26th July) 2012-04-23 13:30:11 PDT
Looks like this was pushed to aurora earlier today:

http://hg.mozilla.org/releases/comm-aurora/rev/88ca33153d6a

Note You need to log in before you can comment on or make changes to this bug.