Closed Bug 747784 Opened 8 years ago Closed 7 years ago

Add support for a Windows 8 app bar

Categories

(Core :: Widget: Win32, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 756438

People

(Reporter: bbondy, Unassigned)

Details

Attachments

(5 files)

Attached image App bar 1
Add support for a Windows 8 Metro app bar in Firefox/Fennec.

Functionality:
- Right clicking should bring up the app bar. 
- Swiping from the bottom edge should also bring up the app bar.
- Clicking on the content should dismiss the app bar. 
- The app bar should overlay on top of the content and not change the size of (nor reflow) the content.

UI:
- On the left: Settings, pin site, zoom out, zoom in
- On the right: Downloads, plugins, 3 bar icon for a menu with more options
- See the attached mockups

I think it would initially be easiest to use a XAML app bar overlay control initially for this task.
Attached image App bar 2
Attached image App bar 3
Assignee: nobody → netzen
Summary: Add support for a Windows 8 app bar. → Add support for a Windows 8 app bar
Attached file App Bar Commands v1
Demonstrating how the app bar should behave on the start page, web page, bookmark, history, and download page.

The location and sequence of the icons are decided based on Metro design guidelines and user scenarios. 

Still need visual design help on designing some icons.
Nice! 

Please attach the icons separately whenever you get them as PNGs (or whatever type is most appropriate).

Thanks.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 756438
Assignee: netzen → nobody
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.