nsWBContentListener should go away

VERIFIED FIXED in mozilla0.9

Status

defect
VERIFIED FIXED
19 years ago
3 months ago

People

(Reporter: jud, Assigned: jud)

Tracking

({memory-footprint})

Trunk
mozilla0.9
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Assignee

Description

19 years ago
Currently nsWebBrowser uses an intermediary nsIURIContentListener to hook up the
embeddor w/ the underlying nsIURIContentListener chain. This layer is extraneous
as the embeddor can be hooked directly up to the underlying
nsIURIContentListener (currently nsDSContentListener). The existing
nsWBContentListener is doing nothing more than fowarding the exact same calls
that the underlying nsDSContentListener is forwarding. The existing
nsWBContentListener was added due to a regression last summer and the regression
has since been fixed.
Assignee

Updated

19 years ago
Blocks: 64833
Keywords: footprint
Target Milestone: --- → mozilla0.9
Assignee

Updated

19 years ago
Keywords: patch
r/sr=blizzard
Assignee: valeski → adamlock
oops
Assignee: adamlock → valeski
Good. The WBURIContentListener is, in most methods that it impls, just dead
wood. Except in IsPreferred(), where it actually does something it does the
wrong thing (says it's not preferred for text/plain) r=ccarlen
Assignee

Comment 5

19 years ago
fix is in. thanks all.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
There are some lingering bugs from this checkin.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The call down to the docshell has to get a GetInterface, not a QueryInterface. 
Because of that the call can return nsnull so it doesn't require an assertion. 
In the case where the GetInterface() to the docshell returns null the setter
will return NS_ERROR_FAILURE.  Maybe it should return NS_ERROR_NO_INTERFACE?
Assignee

Comment 11

19 years ago
n, I like the NS_ERROR_FAILURE return. NO_INTERFACE in these methods, to me, is
more info than the caller should see.

*thanks* for finding this.

r=valeski
Assignee

Comment 12

18 years ago
I went ahead and checked this in. thanks blizzard.
Status: REOPENED → RESOLVED
Closed: 19 years ago18 years ago
Resolution: --- → FIXED
No problem.
*** Bug 75101 has been marked as a duplicate of this bug. ***

Comment 15

18 years ago
Correction: Changing QA contact for the Embed API bugs to David Epstein.
QA Contact: mdunn → depstein

Comment 16

18 years ago
no trace of nsWBContentListener or WBURIContentListener in lxr.mozilla.org. 
Status: RESOLVED → VERIFIED

Updated

18 years ago
No longer blocks: 64833

Updated

3 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.