Delete model not being updated until restart of Mozilla.

VERIFIED DUPLICATE of bug 60031

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 60031
17 years ago
13 years ago

People

(Reporter: stephend@netscape.com (gone - use stephen.donner@gmail.com instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({regression})

Trunk
Future
regression

Firefox Tracking Flags

(Not tracked)

Details

Build ID: 2001-04-04 (all OSs) IMAP (haven't tried pop yet)

Summary: Delete model not being updated until reboot.

Steps to Reproduce:

1.  Send yourself a test message.
2.  Have your delete model to "move it to trash" upon delete.
3.  Press OK.  
4.  Delete a message, we do this part correctly.
5.  Go back, change the pref to "mark it as deleted".

Expected Results:

The delete model should be updated in real-time after closing the pref window
(message should be marked with a red X, but not cleared from the thread pane
until you compact the folder).

Actual results:

When I change the message delete model pref from "move it to the trash folder"
to "mark it as deleted" on linux, win32 and mac (today's builds) the message is
removed from the pane immediately.

Note: Upon reboot, this pref works fine.
Keywords: nsbeta1, regression

Updated

17 years ago
QA Contact: esther → huang

Comment 1

17 years ago
marking nsbeta1-
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → Future
Summary: Delete model not being updated until reboot. → Delete model not being updated until restart of Mozilla.
*** Bug 82057 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 60031 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Actually, this bug is a dup of bug 94660 where this problem was finally fixed.

Comment 5

17 years ago
I already verified the fix on bug 60031/bug 94660. 
Marking as verified for Stephend.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.