Last Comment Bug 748161 - Improve visible tab indication in tab list menu
: Improve visible tab indication in tab list menu
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 15
Assigned To: Frank Yan (:fryn)
:
: Dão Gottwald [:dao]
Mentors:
: 839756 (view as bug list)
Depends on:
Blocks: 626903
  Show dependency treegraph
 
Reported: 2012-04-23 16:18 PDT by Olli Pettay [:smaug]
Modified: 2013-11-13 02:20 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.51 KB, patch)
2012-04-24 12:36 PDT, Frank Yan (:fryn)
dao+bmo: review+
Details | Diff | Splinter Review
screenshot of patch (35.91 KB, image/png)
2012-04-24 12:37 PDT, Frank Yan (:fryn)
no flags Details
Gray stripe down right side (79.68 KB, image/jpeg)
2012-05-01 04:34 PDT, Jim Jeffery not reading bug-mail 1/2/11
no flags Details

Description Olli Pettay [:smaug] 2012-04-23 16:18:46 PDT
If one has enough tabs to get the down arrow to open tab list, the styling of those
items in the list which are hidden in the tab bar have strange white-ish styling on
linux (Fedora 15, Gnome 3, default theme).
Looks very unpolished and nothing like anything else in the OS.
Comment 1 Frank Yan (:fryn) 2012-04-24 12:32:30 PDT
(In reply to Olli Pettay [:smaug] from comment #0)
> If one has enough tabs to get the down arrow to open tab list, the styling
> of those
> items in the list which are hidden in the tab bar have strange white-ish
> styling on
> linux

It's the visible tabs that have the modified styling.
The hidden tabs have the native styling, AIUI.
Comment 2 Frank Yan (:fryn) 2012-04-24 12:36:41 PDT
Created attachment 617993 [details] [diff] [review]
patch
Comment 3 Frank Yan (:fryn) 2012-04-24 12:37:11 PDT
Created attachment 617994 [details]
screenshot of patch
Comment 4 Dão Gottwald [:dao] 2012-04-24 12:51:27 PDT
Comment on attachment 617993 [details] [diff] [review]
patch

DarkGray may be too close to the native menu color with some Linux and Windows themes. Can we use ThreeDShadow or something like that?
Comment 5 Frank Yan (:fryn) 2012-04-24 12:55:37 PDT
(In reply to Dão Gottwald [:dao] from comment #4)
> Comment on attachment 617993 [details] [diff] [review]
> patch
> 
> DarkGray may be too close to the native menu color with some Linux and
> Windows themes. Can we use ThreeDShadow or something like that?

Absolutely. I just tried it, and it works fine. Could you review the patch assuming that I replace DarkGray with ThreeDShadow?
Comment 6 Olli Pettay [:smaug] 2012-04-24 22:22:49 PDT
(In reply to Frank Yan (:fryn) from comment #1)
> It's the visible tabs that have the modified styling.
> The hidden tabs have the native styling, AIUI.
Ah, that is possible. Anyway the current setup is visually quite disturbing, and something that
I don't see elsewhere in Gnome, nor in Firefox itself.
Comment 7 Frank Yan (:fryn) 2012-04-24 22:27:34 PDT
(In reply to Olli Pettay [:smaug] from comment #6)
> Anyway the current setup is visually quite disturbing,
> and something that
> I don't see elsewhere in Gnome, nor in Firefox itself.

It's definitely not pretty, but we didn't think of a better way to indicate it at the time given the restrictions of menuitem styling.
I don't think it has to match something else in the product. That's not a requirement at all and is only something that gets brought up when people don't like how something looks.
I've thought of something prettier and less jarring now, and I wrote a patch for it above.
Comment 8 Dão Gottwald [:dao] 2012-04-26 06:27:43 PDT
Comment on attachment 617993 [details] [diff] [review]
patch

r=me with ThreeDShadow instead of DarkGray
Comment 9 Frank Yan (:fryn) 2012-04-26 13:24:57 PDT
Comment on attachment 617994 [details]
screenshot of patch

Got ui-review+ from shorlander in-person.
This solution isn't great, but it's better than what we have now, and the metaphor of a scrollbar-like bar representing the current position might come across.
Comment 11 Tim Taubert [:ttaubert] 2012-04-27 05:54:27 PDT
https://hg.mozilla.org/mozilla-central/rev/313ba4818662
Comment 12 Jim Jeffery not reading bug-mail 1/2/11 2012-04-27 08:19:33 PDT
This change has now caused the over-flow arrow to appear when its not needed, pressing the over-flow arrow only scrolls in a 'blank' glass area on Win7 in the tab-strip.

This with 8 tabs open, where before the same number of tabs did not trigger the tab-strip over-flow arrow.
Comment 13 Jim Jeffery not reading bug-mail 1/2/11 2012-04-27 08:21:05 PDT
Ewww, another side affect I just noticed.  Refreshing the page causes the tab strip to drop the over-flow arrow, then once page is loaded, the tab-strip shrinks tab-width to redisplay the over-flow arrow.  Visually annoying.
Comment 14 Jim Jeffery not reading bug-mail 1/2/11 2012-04-27 08:23:16 PDT
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #13)
> Ewww, another side affect I just noticed.  Refreshing the page causes the
> tab strip to drop the over-flow arrow, then once page is loaded, the
> tab-strip shrinks tab-width to redisplay the over-flow arrow.  Visually
> annoying.

Hm, sorry for spam, only see that happening after posting a comment to the bug and hitting submit, other pages that I refresh do not cause the tab strip to change.
Comment 15 Jim Jeffery not reading bug-mail 1/2/11 2012-04-27 08:29:41 PDT
Never-mind my above comments. went back to an older hourly and the tab strip is still behaving strangely.
Comment 16 Alex Keybl [:akeybl] 2012-04-30 16:25:09 PDT
What do we believe this is a regression from? Bug 626903?
Comment 17 Frank Yan (:fryn) 2012-04-30 16:41:27 PDT
Reason for removing tracking flag:
It's not a functionality regression. The complaint is just that the indication made the menu uglier, which is a valid complaint.
I made it prettier now, but there's no hurry to get this onto aurora just for Firefox 14. It's a visual fix for secondary UI, and no functionality is really being affected. To use a cliché: we have bigger fish to fry.
Comment 18 Olli Pettay [:smaug] 2012-05-01 02:27:55 PDT
Well, UI is what users see. Bugs there are as bad as bugs in the functionality.
(Btw, on trunk the styling looks good. All the items in the list have the same styling.)
Comment 19 Jim Jeffery not reading bug-mail 1/2/11 2012-05-01 04:34:50 PDT
Created attachment 619896 [details]
Gray stripe down right side

The 'gray-stripe' down the right side looks bad.  Is that supposed to be there ?
It looks like a psuedo-slider of sorts, but we know the list is limited so it can't be a slider.
Comment 20 :Ehsan Akhgari 2012-05-02 13:26:37 PDT
This patch was in a range which caused a Ts regression, so I backed out the whole range:

https://hg.mozilla.org/mozilla-central/rev/24a6a53c714a

Please reland after investigating and fixing the regression.
Comment 21 Frank Yan (:fryn) 2012-05-07 12:42:51 PDT
Relanded:
https://hg.mozilla.org/integration/fx-team/rev/e2d386af93fa
Comment 22 Tim Taubert [:ttaubert] 2012-05-07 23:56:50 PDT
https://hg.mozilla.org/mozilla-central/rev/e2d386af93fa
Comment 23 Sean Smith 2012-05-08 06:49:34 PDT
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #19)
> Created attachment 619896 [details]
> Gray stripe down right side
> 
> The 'gray-stripe' down the right side looks bad.  Is that supposed to be
> there ?
> It looks like a psuedo-slider of sorts, but we know the list is limited so
> it can't be a slider.

The gray stripe is the indicator that those are the tabs that are visible in the tab strip.  The tabs outside of the gray stripe are the ones that are not in the tab strip view due to the overflow mode.
Comment 24 Mehmet 2013-02-09 04:54:45 PST
*** Bug 839756 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.