The default bug view has changed. See this FAQ.

xulrunner builds broken by "webapprt: No such file or directory"

RESOLVED FIXED

Status

Firefox Graveyard
Webapp Runtime
RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: myk, Unassigned)

Tracking

unspecified
Bug Flags:
in-moztrap -

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Mac and Windows xulrunner builds are broken with the error "webapprt: No such file or directory":

<https://tbpl.mozilla.org/?rev=21da3f655b30&noignore=1>:

/bin/sh: line 0: cd: universal/xulrunner/XUL.framework/Versions/Current/webapprt: No such file or directory
- <https://tbpl.mozilla.org/php/getParsedLog.php?id=11150844&tree=Firefox&full=1#error0>

/bin/sh: line 0: cd: xulrunner/webapprt: No such file or directory
- <https://tbpl.mozilla.org/php/getParsedLog.php?id=11151235&tree=Firefox&full=1#error0>
(Reporter)

Comment 1

5 years ago
Created attachment 618053 [details] [diff] [review]
patch v1: only enable the runtime for Firefox

1. configure.in enables the runtime for Windows and Mac by defining MOZ_WEBAPP_RUNTIME for those target OSes;

    case "${target}" in
    *darwin*)
        ACCESSIBILITY=
        MOZ_WEBAPP_RUNTIME=1
        ;;
    *)
        ACCESSIBILITY=1
        ;;
    esac
    
    case "$target_os" in
        mingw*)
            NS_ENABLE_TSF=1
            AC_DEFINE(NS_ENABLE_TSF)
            MOZ_WEBAPP_RUNTIME=1
            ;;
    esac

2. only Firefox builds webapprt/ (via its browser/build.mk);

    ifdef MOZ_WEBAPP_RUNTIME
    tier_app_dirs += webapprt
    endif

3. toolkit/mozapps/installer/packager.mk tries to package the runtime if MOZ_WEBAPP_RUNTIME is defined, regardless of what was built;

4. `make package` fails for XULRunner because webapprt/ wasn't built.


The solution seems obvious: only enable the runtime for Firefox.  We could test for MOZ_BUILD_APP=browser in configure.in, but project-specific defines are what confvars.sh is for.  Here's a patch.  Tryserver run:

https://tbpl.mozilla.org/?tree=Try&noignore=1&rev=cd8a979582d2


Dave: the changes are in configure.in and browser/confvars.sh.  Are you ok to review this, or should I get a Build Config peer like bsmedberg to review it?
Attachment #618053 - Flags: review?(dtownsend+bugmail)

Updated

5 years ago
Whiteboard: [marketplace-beta-]
Comment on attachment 618053 [details] [diff] [review]
patch v1: only enable the runtime for Firefox

I don't think anyone else needs to look at this.
Attachment #618053 - Flags: review?(dtownsend+bugmail) → review+
(Reporter)

Updated

5 years ago
Keywords: checkin-needed
(Reporter)

Comment 3

5 years ago
Comment on attachment 618053 [details] [diff] [review]
patch v1: only enable the runtime for Firefox

https://hg.mozilla.org/integration/mozilla-inbound/rev/cd0ea13a52bb
(Reporter)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/cd0ea13a52bb
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 5

5 years ago
Can this be merged to Aurora?
Assignee: myk → nobody
Component: Desktop Runtime → XULRunner
Product: Web Apps → Toolkit
QA Contact: desktop-runtime → xulrunner
Comment on attachment 618053 [details] [diff] [review]
patch v1: only enable the runtime for Firefox

[Approval Request Comment]
Regression caused by (bug #): Bug 746156
User impact if declined: No XULRunner builds on OSX and Windows for XULRunner 14
Testing completed (on m-c, etc.): On m-c for a few days, builds complete successfully
Risk to taking this patch (and alternatives if risky): None I think
String changes made by this patch: None
Attachment #618053 - Flags: approval-mozilla-aurora?
Component: XULRunner → Desktop Runtime
Flags: approval-mozilla-aurora?
Product: Toolkit → Web Apps
QA Contact: xulrunner → desktop-runtime
approval-mozilla-aurora+=me 
low/no known risk, and getting xulrunner builds for 14 seems pretty useful.
fixed on aurora: https://hg.mozilla.org/releases/mozilla-aurora/rev/ef9cb1276f4c

Updated

5 years ago
Whiteboard: [marketplace-beta-]
Myk - Trying to figure out what I need to verify here - Could you clarify?
Whiteboard: [qa?]
(Reporter)

Comment 10

5 years ago
I don't think there's anything to verify here, except possibly that XULRunner nightly builds are no longer busted (at least not for this reason):

https://tbpl.mozilla.org/?noignore=1&rev=ac968ff4fe41

Updated

5 years ago
Whiteboard: [qa?] → [qa-]
(Assignee)

Updated

5 years ago
Component: Desktop Runtime → Webapp Runtime
Product: Web Apps → Firefox

Updated

5 years ago
Flags: in-moztrap-

Updated

5 years ago
QA Contact: desktop-runtime → jsmith
(Assignee)

Updated

a year ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.