Status

()

Core
Layout
VERIFIED DUPLICATE of bug 74017
17 years ago
17 years ago

People

(Reporter: Gagan, Assigned: Stuart Parmenter)

Tracking

({crash})

Trunk
mozilla0.9
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
This is a test page that generates curved borders using varying table widths. It 
crashes last night's build (2001040504). I don't have a debug build to confirm 
where it is but giving to layout as a possible area...
(Reporter)

Updated

17 years ago
Keywords: crash

Comment 1

17 years ago
I'm getting an assertion and then the following crash. Reassigning to attinasi 
and CCing pavlov.

nsImageFrame::Paint(nsImageFrame * const 0x00dedda0, nsIPresContext * 
0x03221ee0, nsIRenderingContext & {...}, const nsRect & {x=0 y=0 width=15 
height=15}, nsFramePaintLayer eFramePaintLayer_Underlay) line 985 + 53 bytes
nsContainerFrame::PaintChild(nsIPresContext * 0x03221ee0, nsIRenderingContext & 
{...}, const nsRect & {x=0 y=0 width=135 height=15}, nsIFrame * 0x00dedda0, 
nsFramePaintLayer eFramePaintLayer_Underlay) line 208
nsBlockFrame::PaintChildren(nsIPresContext * 0x03221ee0, nsIRenderingContext & 
{...}, const nsRect & {x=0 y=0 width=135 height=15}, nsFramePaintLayer 
eFramePaintLayer_Underlay) line 6594
nsBlockFrame::Paint(nsBlockFrame * const 0x00dedd54, nsIPresContext * 
0x03221ee0, nsIRenderingContext & {...}, const nsRect & {x=0 y=0 width=135 
height=15}, nsFramePaintLayer eFramePaintLayer_Underlay) line 6472
nsContainerFrame::PaintChild(nsIPresContext * 0x03221ee0, nsIRenderingContext & 
{...}, const nsRect & {x=0 y=0 width=135 height=15}, nsIFrame * 0x00dedd54, 
nsFramePaintLayer eFramePaintLayer_Underlay) line 208
nsContainerFrame::PaintChildren(nsIPresContext * 0x03221ee0, nsIRenderingContext 
& {...}, const nsRect & {x=0 y=0 width=135 height=15}, nsFramePaintLayer 
eFramePaintLayer_Underlay) line 152
nsTableCellFrame::Paint(nsTableCellFrame * const 0x00dedcf8, nsIPresContext * 
0x03221ee0, nsIRenderingContext & {...}, const nsRect & {x=0 y=0 width=135 
height=15}, nsFramePaintLayer eFramePaintLayer_Underlay) line 329
nsTableRowFrame::PaintChildren(nsIPresContext * 0x03221ee0, nsIRenderingContext 
& {...}, const nsRect & {x=0 y=0 width=285 height=435}, nsFramePaintLayer 
eFramePaintLayer_Underlay) line 547
nsTableRowFrame::Paint(nsTableRowFrame * const 0x00dedc08, nsIPresContext * 
0x03221ee0, nsIRenderingContext & {...}, const nsRect & {x=0 y=0 width=285 
height=435}, nsFramePaintLayer eFramePaintLayer_Underlay) line 500
nsTableRowGroupFrame::PaintChildren(nsIPresContext * 0x03221ee0, 
nsIRenderingContext & {...}, const nsRect & {x=0 y=0 width=285 height=435}, 
nsFramePaintLayer eFramePaintLayer_Underlay) line 278
nsTableRowGroupFrame::Paint(nsTableRowGroupFrame * const 0x00e96e3c, 
nsIPresContext * 0x03221ee0, nsIRenderingContext & {...}, const nsRect & {x=0 
y=0 width=285 height=435}, nsFramePaintLayer eFramePaintLayer_Underlay) line 232
nsContainerFrame::PaintChild(nsIPresContext * 0x03221ee0, nsIRenderingContext & 
{...}, const nsRect & {x=0 y=0 width=285 height=435}, nsIFrame * 0x00e96e3c, 
nsFramePaintLayer eFramePaintLayer_Underlay) line 208
nsContainerFrame::PaintChildren(nsIPresContext * 0x03221ee0, nsIRenderingContext 
& {...}, const nsRect & {x=0 y=0 width=285 height=435}, nsFramePaintLayer 
eFramePaintLayer_Underlay) line 152
nsTableFrame::Paint(nsTableFrame * const 0x00e96dd4, nsIPresContext * 
0x03221ee0, nsIRenderingContext & {...}, const nsRect & {x=0 y=0 width=285 
height=435}, nsFramePaintLayer eFramePaintLayer_Underlay) line 1468
nsContainerFrame::PaintChild(nsIPresContext * 0x03221ee0, nsIRenderingContext & 
{...}, const nsRect & {x=0 y=0 width=285 height=435}, nsIFrame * 0x00e96dd4, 
nsFramePaintLayer eFramePaintLayer_Underlay) line 208
nsTableOuterFrame::Paint(nsTableOuterFrame * const 0x00e96d88, nsIPresContext * 
0x03221ee0, nsIRenderingContext & {...}, const nsRect & {x=0 y=0 width=285 
height=435}, nsFramePaintLayer eFramePaintLayer_Underlay) line 370
nsContainerFrame::PaintChild(nsIPresContext * 0x03221ee0, nsIRenderingContext & 
{...}, const nsRect & {x=0 y=0 width=8940 height=435}, nsIFrame * 0x00e96d88, 
nsFramePaintLayer eFramePaintLayer_Underlay) line 208
nsBlockFrame::PaintChildren(nsIPresContext * 0x03221ee0, nsIRenderingContext & 
{...}, const nsRect & {x=0 y=0 width=8940 height=435}, nsFramePaintLayer 
eFramePaintLayer_Underlay) line 6594
nsBlockFrame::Paint(nsBlockFrame * const 0x00e96cb0, nsIPresContext * 
0x03221ee0, nsIRenderingContext & {...}, const nsRect & {x=0 y=0 width=8940 
height=435}, nsFramePaintLayer eFramePaintLayer_Underlay) line 6472
nsContainerFrame::PaintChild(nsIPresContext * 0x03221ee0, nsIRenderingContext & 
{...}, const nsRect & {x=119 y=119 width=8956 height=451}, nsIFrame * 
0x00e96cb0, nsFramePaintLayer eFramePaintLayer_Underlay) line 208
nsBlockFrame::PaintChildren(nsIPresContext * 0x03221ee0, nsIRenderingContext & 
{...}, const nsRect & {x=119 y=119 width=8956 height=451}, nsFramePaintLayer 
eFramePaintLayer_Underlay) line 6594
nsBlockFrame::Paint(nsBlockFrame * const 0x00e96c28, nsIPresContext * 
0x03221ee0, nsIRenderingContext & {...}, const nsRect & {x=119 y=119 width=8956 
height=451}, nsFramePaintLayer eFramePaintLayer_Underlay) line 6472
nsContainerFrame::PaintChild(nsIPresContext * 0x03221ee0, nsIRenderingContext & 
{...}, const nsRect & {x=119 y=119 width=8956 height=451}, nsIFrame * 
0x00e96c28, nsFramePaintLayer eFramePaintLayer_Underlay) line 208
nsContainerFrame::PaintChildren(nsIPresContext * 0x03221ee0, nsIRenderingContext 
& {...}, const nsRect & {x=119 y=119 width=8956 height=451}, nsFramePaintLayer 
eFramePaintLayer_Underlay) line 152
nsHTMLContainerFrame::Paint(nsHTMLContainerFrame * const 0x00e95ec4, 
nsIPresContext * 0x03221ee0, nsIRenderingContext & {...}, const nsRect & {x=119 
y=119 width=8956 height=451}, nsFramePaintLayer eFramePaintLayer_Underlay) line 
109
PresShell::Paint(PresShell * const 0x02a0d0e4, nsIView * 0x02aacee0, 
nsIRenderingContext & {...}, const nsRect & {x=119 y=119 width=8956 height=451}) 
line 4932 + 34 bytes
nsView::Paint(nsView * const 0x02aacee0, nsIRenderingContext & {...}, const 
nsRect & {x=119 y=119 width=8956 height=451}, unsigned int 128, int & 2456789) 
line 277
nsViewManager::RenderDisplayListElement(DisplayListElement2 * 0x03250830, 
nsIRenderingContext & {...}) line 1394
nsViewManager::RenderViews(nsIView * 0x02aad9f0, nsIRenderingContext & {...}, 
const nsRect & {x=119 y=119 width=8956 height=451}, int & 0) line 1319
nsViewManager::Refresh(nsIView * 0x02aad9f0, nsIRenderingContext * 0x03250920, 
const nsRect * 0x0012f938 {x=119 y=119 width=8956 height=451}, unsigned int 1) 
line 885
nsViewManager::DispatchEvent(nsViewManager * const 0x02a0fe80, nsGUIEvent * 
0x0012fa78, nsEventStatus * 0x0012f97c) line 1909
HandleEvent(nsGUIEvent * 0x0012fa78) line 68
nsWindow::DispatchEvent(nsWindow * const 0x02aafad4, nsGUIEvent * 0x0012fa78, 
nsEventStatus & nsEventStatus_eIgnore) line 695 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fa78, nsEventStatus & 
nsEventStatus_eIgnore) line 721
nsWindow::OnPaint() line 3825 + 28 bytes
nsWindow::ProcessMessage(unsigned int 15, unsigned int 0, long 0, long * 
0x0012fe58) line 2832 + 17 bytes
nsWindow::WindowProc(HWND__ * 0x23840468, unsigned int 15, unsigned int 0, long 
0) line 950 + 27 bytes
USER32! 77e719d0()
USER32! 77e71982()
Assignee: karnaze → attinasi
Target Milestone: --- → mozilla0.9

Comment 2

17 years ago
Same stack as bug 75417 - probably a dup. Pav, can you check it out when you
check out bug 75417? Thanks.
Assignee: attinasi → pavlov
dupping.

*** This bug has been marked as a duplicate of 74017 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Verifications.  Tests (if necessary) were done with 2001052504 on Windows 2000.

Please forgive the spam.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.