Last Comment Bug 748924 - PDF viewer: New interface + Mochitest controls
: PDF viewer: New interface + Mochitest controls
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: PDF Viewer (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: Firefox 15
Assigned To: Artur Adib
:
Mentors:
Depends on: 760804 770409
Blocks: 742099 748923 748928
  Show dependency treegraph
 
Reported: 2012-04-25 13:11 PDT by Artur Adib
Modified: 2012-07-02 22:40 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Mochitests for PDF.js controls, using new UI (470.99 KB, patch)
2012-05-03 07:19 PDT, Artur Adib
no flags Details | Diff | Splinter Review
new UI, new Mochitests (1.64 MB, patch)
2012-05-07 07:50 PDT, Artur Adib
no flags Details | Diff | Splinter Review
new UI, new Mochitests (1.62 MB, patch)
2012-05-07 12:47 PDT, Artur Adib
no flags Details | Diff | Splinter Review
new UI, new Mochitests (1.62 MB, patch)
2012-05-07 12:56 PDT, Artur Adib
no flags Details | Diff | Splinter Review
new UI (1.61 MB, patch)
2012-05-07 14:08 PDT, Artur Adib
no flags Details | Diff | Splinter Review
tests for new UI (4.67 KB, patch)
2012-05-07 14:09 PDT, Artur Adib
no flags Details | Diff | Splinter Review
new UI (1.61 MB, patch)
2012-05-08 09:19 PDT, Artur Adib
no flags Details | Diff | Splinter Review
tests for new UI (25.03 KB, patch)
2012-05-08 10:05 PDT, Artur Adib
no flags Details | Diff | Splinter Review
new UI (1.62 MB, patch)
2012-05-08 10:06 PDT, Artur Adib
dtownsend: review+
Details | Diff | Splinter Review
tests for new UI (25.44 KB, patch)
2012-05-08 10:12 PDT, Artur Adib
cmtalbert: review+
Details | Diff | Splinter Review
tests for new UI (25.94 KB, patch)
2012-05-18 10:36 PDT, Artur Adib
no flags Details | Diff | Splinter Review
new UI (1.65 MB, patch)
2012-05-18 10:37 PDT, Artur Adib
dtownsend: review+
Details | Diff | Splinter Review
new UI (1.67 MB, patch)
2012-05-22 16:13 PDT, Artur Adib
dtownsend: review+
Details | Diff | Splinter Review
tests for new UI (26.15 KB, patch)
2012-05-22 16:16 PDT, Artur Adib
cmtalbert: review+
Details | Diff | Splinter Review
tests for new UI (19.20 KB, patch)
2012-05-29 06:37 PDT, Artur Adib
cmtalbert: review+
Details | Diff | Splinter Review

Description Artur Adib 2012-04-25 13:11:18 PDT
The UI controls should be tested for responsiveness via Mochitest
Comment 1 Artur Adib 2012-05-03 07:19:14 PDT
Created attachment 620692 [details] [diff] [review]
Mochitests for PDF.js controls, using new UI
Comment 2 Mozilla RelEng Bot 2012-05-04 12:07:46 PDT
Autoland Patchset:
	Patches: 620692
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=7d3f04ffbc67
Try run started, revision 7d3f04ffbc67. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=7d3f04ffbc67
Comment 3 Artur Adib 2012-05-07 07:50:44 PDT
Created attachment 621598 [details] [diff] [review]
new UI, new Mochitests
Comment 4 Artur Adib 2012-05-07 12:47:20 PDT
Created attachment 621691 [details] [diff] [review]
new UI, new Mochitests
Comment 5 Artur Adib 2012-05-07 12:56:16 PDT
Created attachment 621696 [details] [diff] [review]
new UI, new Mochitests
Comment 6 Artur Adib 2012-05-07 14:08:16 PDT
Created attachment 621729 [details] [diff] [review]
new UI
Comment 7 Artur Adib 2012-05-07 14:09:49 PDT
Created attachment 621730 [details] [diff] [review]
tests for new UI
Comment 8 Brendan Dahl [:bdahl] 2012-05-07 15:03:44 PDT
Release Notes:
#1500 Use Title - Filename as document.title
#1531 API refactoring
#1547 fix for opera DSK-354448: onclick fired on disabled nodes with opaque co...
#1548 Bump version to 0.3 because of new API
#1550 Error on jbig2.  Add 'RL' abbreviation for run length decode.
#1553 Fix extension comment nits.
#1551 Fix the operator list deallocation
#1569 Fixes page-width mode
#1504 Rebuilding invalid OS/2 table
#1568 Fixes annotations; adds text annotation icon
#1573 Handle junk at the end of postscript functions.
#1526 Fix keyboardbindings
#1598 Fixes broken metadata
#1599 Guessing pdf char size based on the CMap numbers
#1611 Add mailto protocol to whitelist - #1608
#1600 Don't check gen number for free entry; don't index objects twice
#1628 Updates jpgjs libary to the latest: component order fix
#1537 New UI - work in progress
#1640 Fixes tab order and focus highlight
#1653 Addressing accessibility aspects
#1636 Using webL10n library to localize the pdf.js
Comment 9 Artur Adib 2012-05-08 07:33:06 PDT
hi Clint, 

we are gearing up for our Aurora uplift, and we wanted to make sure we are covering tests of our user interface controls. I have added several new tests here for that purpose.

would you mind reviewing the small patch to see if we're doing things right?

thanks!
Comment 10 Artur Adib 2012-05-08 09:19:10 PDT
Created attachment 622005 [details] [diff] [review]
new UI
Comment 11 Artur Adib 2012-05-08 10:05:57 PDT
Created attachment 622022 [details] [diff] [review]
tests for new UI
Comment 12 Artur Adib 2012-05-08 10:06:29 PDT
Created attachment 622023 [details] [diff] [review]
new UI
Comment 13 Artur Adib 2012-05-08 10:12:25 PDT
Created attachment 622027 [details] [diff] [review]
tests for new UI
Comment 14 Artur Adib 2012-05-10 08:39:55 PDT
Try server results seem to be OK:

https://tbpl.mozilla.org/?tree=Try&rev=dd4c2b77d619
Comment 15 Dave Townsend [:mossop] 2012-05-10 10:29:59 PDT
We're all these changes already reviewed before landing in git?
Comment 16 cmtalbert 2012-05-10 15:54:50 PDT
Comment on attachment 622027 [details] [diff] [review]
tests for new UI

Review of attachment 622027 [details] [diff] [review]:
-----------------------------------------------------------------

My main comment is to move the waitForElement into simpletest so that other tests can use that functionality outside of pdf.js tests. I don't think this test is getting too long, but I would caution that for the next test for pdf.js you may want to start a new file. The reason for that is that as the test files get longer, they get harder to debug (and if one of these checks turns the test intermittently orange, the entire test will be rendered invalid). I don't think you're in any danger of that on this one, but it's something to keep in mind for the next one.

r+ with the change to waitForElement and fixing the comment in the zooming section.

::: browser/app/profile/extensions/uriloader@pdf.js/test/browser_pdfjs_main.js
@@ +24,5 @@
> +      clearInterval(checkEl);
> +      if (callback) callback(true);
> +    }
> +  }, interval);
> +}

This seems like a good, general purpose call that could be used from SimpleTest. Why not hang this off the SimpleTest object in mochitest so that other tests have this available?

We'd have to document that the callback accepts a boolean value to indicate whether the wait timed out or not.

@@ +124,5 @@
> +      // Zoom out
> +      var oldWidth = document.querySelector('canvas#page1').width;
> +      zoomOut.click();
> +      var newWidth = document.querySelector('canvas#page1').width;
> +      ok(oldWidth > newWidth, 'zooming out increases page width (old: '+oldWidth+', new: '+newWidth+')');

according to your code, zooming out *decreases* page width (your comment is wrong). i.e. oldwidth > newwidth.  

Is that true?  Logically, as I'm thinking about it, it would seem that zooming in would decrease page width and zooming out would increase page width.  But I have to admit I haven't deeply investigated how we handle page zoom.
Comment 17 Mozilla RelEng Bot 2012-05-10 16:44:58 PDT
Autoland Patchset:
	Patches: 622023, 622027
	Branch: mozilla-central => try
An error occurred while cloning https://hg.mozilla.org/mozilla-central.
Comment 18 Mozilla RelEng Bot 2012-05-11 11:54:08 PDT
Autoland Patchset:
	Patches: 622023, 622027
	Branch: mozilla-central => try
An error occurred while cloning https://hg.mozilla.org/mozilla-central.
Comment 19 Mozilla RelEng Bot 2012-05-11 15:21:41 PDT
Autoland Patchset:
	Patches: 620692
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=5ca9466d3490
Try run started, revision 5ca9466d3490. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=5ca9466d3490
Comment 20 Mozilla RelEng Bot 2012-05-11 15:47:14 PDT
Autoland Patchset:
	Patches: 621691
	Branch: mozilla-central => try
Patch 621691 could not be applied to mozilla-central.
patching file browser/app/profile/extensions/uriloader@pdf.js/README.mozilla
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/README.mozilla.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/content/web/debugger.js
Hunk #1 FAILED at 162
Hunk #2 FAILED at 192
Hunk #3 FAILED at 204
Hunk #4 FAILED at 255
Hunk #5 FAILED at 277
Hunk #6 FAILED at 422
6 out of 6 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/debugger.js.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-check.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-check.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-comment.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-comment.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-text.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-text.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/bookmark.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/bookmark.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/check.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/check.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/comment.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/comment.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/document-print.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/document-print.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/download.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/download.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/go-down.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/go-down.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/go-up.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/go-up.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/nav-outline.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/nav-outline.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/nav-thumbs.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/nav-thumbs.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/pin-down.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/pin-down.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/pin-up.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/pin-up.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/zoom-in.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/zoom-in.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/zoom-out.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/zoom-out.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/l10n.js' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/l10n.js.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer-snippet-firefox-extension.html already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer-snippet-firefox-extension.html.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.css
Hunk #1 FAILED at 0
Hunk #2 FAILED at 664
Hunk #3 FAILED at 746
Hunk #4 FAILED at 806
Hunk #5 FAILED at 841
Hunk #6 FAILED at 873
6 out of 6 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.css.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.html
Hunk #1 FAILED at 0
Hunk #2 FAILED at 21
Hunk #3 FAILED at 89
Hunk #4 FAILED at 124
Hunk #5 FAILED at 135
Hunk #6 FAILED at 157
Hunk #7 FAILED at 178
Hunk #8 FAILED at 214
Hunk #9 FAILED at 233
Hunk #10 FAILED at 310
Hunk #11 FAILED at 320
Hunk #12 FAILED at 327
Hunk #13 FAILED at 366
Hunk #14 FAILED at 427
Hunk #15 FAILED at 437
Hunk #16 FAILED at 451
Hunk #17 FAILED at 465
Hunk #18 FAILED at 486
Hunk #19 FAILED at 593
Hunk #20 FAILED at 674
Hunk #21 FAILED at 683
Hunk #22 FAILED at 858
Hunk #23 FAILED at 880
Hunk #24 FAILED at 896
Hunk #25 FAILED at 931
Hunk #26 FAILED at 1897
Hunk #27 succeeded at 22645 with fuzz 2 (offset 19742 lines).
Hunk #28 FAILED at 2939
Hunk #29 FAILED at 3205
Hunk #30 FAILED at 3266
Hunk #31 FAILED at 3426
Hunk #32 FAILED at 3449
Hunk #33 FAILED at 3482
Hunk #34 FAILED at 3501
Hunk #35 FAILED at 3716
Hunk #36 FAILED at 4555
Hunk #37 FAILED at 4594
Hunk #38 FAILED at 4700
Hunk #39 FAILED at 11634
Hunk #40 succeeded at 31800 with fuzz 2 (offset 19630 lines).
Hunk #41 FAILED at 12763
Hunk #42 FAILED at 12919
Hunk #43 FAILED at 13233
Hunk #44 FAILED at 13247
Hunk #45 FAILED at 13303
Hunk #46 FAILED at 13393
Hunk #47 FAILED at 13614
Hunk #48 FAILED at 13635
Hunk #49 FAILED at 13678
Hunk #50 FAILED at 14447
Hunk #51 FAILED at 14470
Hunk #52 FAILED at 15408
Hunk #53 FAILED at 15425
Hunk #54 FAILED at 15443
Hunk #55 FAILED at 15460
Hunk #56 FAILED at 15474
Hunk #57 FAILED at 15758
Hunk #58 FAILED at 16202
Hunk #59 FAILED at 18362
Hunk #60 FAILED at 22575
Hunk #61 FAILED at 22593
Hunk #62 FAILED at 22951
Hunk #63 FAILED at 25899
Hunk #64 FAILED at 26151
Hunk #65 FAILED at 26542
Hunk #66 FAILED at 26655
Hunk #67 FAILED at 26846
Hunk #68 FAILED at 29141
Hunk #69 FAILED at 29229
Hunk #70 FAILED at 29303
Hunk #71 FAILED at 29321
Hunk #72 FAILED at 29371
Hunk #73 FAILED at 30011
Hunk #74 FAILED at 30029
Hunk #75 FAILED at 30038
Hunk #76 FAILED at 30107
Hunk #77 FAILED at 30286
Hunk #78 FAILED at 32149
Hunk #79 FAILED at 32582
Hunk #80 FAILED at 32679
78 out of 80 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.html.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.js
Hunk #1 FAILED at 14
Hunk #2 FAILED at 33
Hunk #3 FAILED at 63
Hunk #4 FAILED at 218
Hunk #5 FAILED at 256
Hunk #6 FAILED at 340
Hunk #7 FAILED at 382
Hunk #8 FAILED at 461
Hunk #9 FAILED at 492
Hunk #10 FAILED at 513
Hunk #11 FAILED at 546
Hunk #12 succeeded at 639 with fuzz 2 (offset 14 lines).
Hunk #13 FAILED at 682
Hunk #14 FAILED at 778
Hunk #15 FAILED at 796
Hunk #16 FAILED at 820
Hunk #17 FAILED at 844
Hunk #18 FAILED at 858
Hunk #19 FAILED at 885
Hunk #20 FAILED at 901
Hunk #21 FAILED at 960
Hunk #22 FAILED at 970
Hunk #23 FAILED at 1025
Hunk #24 FAILED at 1084
Hunk #25 FAILED at 1092
Hunk #26 FAILED at 1119
Hunk #27 FAILED at 1147
Hunk #28 FAILED at 1177
Hunk #29 FAILED at 1188
Hunk #30 FAILED at 1356
Hunk #31 FAILED at 1376
Hunk #32 FAILED at 1394
Hunk #33 FAILED at 1443
Hunk #34 FAILED at 1475
Hunk #35 FAILED at 1516
Hunk #36 FAILED at 1543
Hunk #37 FAILED at 1576
Hunk #38 FAILED at 1603
Hunk #39 FAILED at 1672
38 out of 39 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.js.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/extension-files
Hunk #1 FAILED at 2
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/extension-files.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/install.rdf.in
Hunk #1 FAILED at 6
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/install.rdf.in.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/test/browser_pdfjs_main.js
Hunk #1 FAILED at 4
Hunk #2 FAILED at 44
2 out of 2 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/test/browser_pdfjs_main.js.rej
patch failed, unable to continue (try -v)
patch failed, rejects left in working dir

Patch 621691 could not be applied to mozilla-central.
patching file browser/app/profile/extensions/uriloader@pdf.js/README.mozilla
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/README.mozilla.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/content/web/debugger.js
Hunk #1 FAILED at 162
Hunk #2 FAILED at 192
Hunk #3 FAILED at 204
Hunk #4 FAILED at 255
Hunk #5 FAILED at 277
Hunk #6 FAILED at 422
6 out of 6 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/debugger.js.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-check.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-check.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-comment.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-comment.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-text.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-text.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/bookmark.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/bookmark.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/check.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/check.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/comment.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/comment.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/document-print.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/document-print.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/download.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/download.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/go-down.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/go-down.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/go-up.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/go-up.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/nav-outline.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/nav-outline.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/nav-thumbs.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/nav-thumbs.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/pin-down.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/pin-down.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/pin-up.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/pin-up.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/zoom-in.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/zoom-in.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/zoom-out.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/zoom-out.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/l10n.js' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/l10n.js.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer-snippet-firefox-extension.html already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer-snippet-firefox-extension.html.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.css
Hunk #1 FAILED at 0
Hunk #2 FAILED at 664
Hunk #3 FAILED at 746
Hunk #4 FAILED at 806
Hunk #5 FAILED at 841
Hunk #6 FAILED at 873
6 out of 6 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.css.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.html
Hunk #1 FAILED at 0
Hunk #2 FAILED at 21
Hunk #3 FAILED at 89
Hunk #4 FAILED at 124
Hunk #5 FAILED at 135
Hunk #6 FAILED at 157
Hunk #7 FAILED at 178
Hunk #8 FAILED at 214
Hunk #9 FAILED at 233
Hunk #10 FAILED at 310
Hunk #11 FAILED at 320
Hunk #12 FAILED at 327
Hunk #13 FAILED at 366
Hunk #14 FAILED at 427
Hunk #15 FAILED at 437
Hunk #16 FAILED at 451
Hunk #17 FAILED at 465
Hunk #18 FAILED at 486
Hunk #19 FAILED at 593
Hunk #20 FAILED at 674
Hunk #21 FAILED at 683
Hunk #22 FAILED at 858
Hunk #23 FAILED at 880
Hunk #24 FAILED at 896
Hunk #25 FAILED at 931
Hunk #26 FAILED at 1897
Hunk #27 FAILED at 2900
Hunk #28 FAILED at 2940
Hunk #29 FAILED at 3206
Hunk #30 FAILED at 3267
Hunk #31 FAILED at 3427
Hunk #32 FAILED at 3450
Hunk #33 FAILED at 3483
Hunk #34 FAILED at 3502
Hunk #35 FAILED at 3717
Hunk #36 FAILED at 4556
Hunk #37 FAILED at 4595
Hunk #38 FAILED at 4701
Hunk #39 FAILED at 11635
Hunk #40 succeeded at 12485 with fuzz 2 (offset 314 lines).
Hunk #41 FAILED at 12764
Hunk #42 FAILED at 12920
Hunk #43 FAILED at 13234
Hunk #44 FAILED at 13248
Hunk #45 FAILED at 13304
Hunk #46 FAILED at 13394
Hunk #47 FAILED at 13615
Hunk #48 FAILED at 13636
Hunk #49 FAILED at 13679
Hunk #50 FAILED at 14448
Hunk #51 FAILED at 14471
Hunk #52 FAILED at 15409
Hunk #53 FAILED at 15426
Hunk #54 FAILED at 15444
Hunk #55 FAILED at 15461
Hunk #56 FAILED at 15475
Hunk #57 FAILED at 15759
Hunk #58 FAILED at 16203
Hunk #59 FAILED at 18363
Hunk #60 FAILED at 22576
Hunk #61 FAILED at 22594
Hunk #62 FAILED at 22952
Hunk #63 FAILED at 25900
Hunk #64 FAILED at 26152
Hunk #65 FAILED at 26543
Hunk #66 FAILED at 26656
Hunk #67 FAILED at 26847
Hunk #68 FAILED at 29142
Hunk #69 FAILED at 29230
Hunk #70 FAILED at 29304
Hunk #71 FAILED at 29322
Hunk #72 FAILED at 29372
Hunk #73 FAILED at 30012
Hunk #74 FAILED at 30030
Hunk #75 FAILED at 30039
Hunk #76 FAILED at 30108
Hunk #77 FAILED at 30287
Hunk #78 FAILED at 32150
Hunk #79 FAILED at 32583
Hunk #80 FAILED at 32680
79 out of 80 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.html.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.js
Hunk #1 FAILED at 14
Hunk #2 FAILED at 33
Hunk #3 FAILED at 63
Hunk #4 FAILED at 218
Hunk #5 FAILED at 256
Hunk #6 FAILED at 340
Hunk #7 FAILED at 382
Hunk #8 FAILED at 461
Hunk #9 FAILED at 492
Hunk #10 FAILED at 513
Hunk #11 FAILED at 546
Hunk #12 succeeded at 367 with fuzz 2 (offset -258 lines).
Hunk #13 FAILED at 682
Hunk #14 FAILED at 778
Hunk #15 FAILED at 796
Hunk #16 FAILED at 820
Hunk #17 FAILED at 844
Hunk #18 FAILED at 858
Hunk #19 FAILED at 885
Hunk #20 FAILED at 901
Hunk #21 FAILED at 960
Hunk #22 FAILED at 970
Hunk #23 FAILED at 1025
Hunk #24 FAILED at 1084
Hunk #25 FAILED at 1092
Hunk #26 FAILED at 1119
Hunk #27 FAILED at 1147
Hunk #28 FAILED at 1177
Hunk #29 FAILED at 1188
Hunk #30 FAILED at 1356
Hunk #31 FAILED at 1376
Hunk #32 FAILED at 1394
Hunk #33 FAILED at 1443
Hunk #34 FAILED at 1475
Hunk #35 FAILED at 1516
Hunk #36 FAILED at 1543
Hunk #37 FAILED at 1576
Hunk #38 FAILED at 1603
Hunk #39 FAILED at 1672
38 out of 39 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.js.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/extension-files
Hunk #1 FAILED at 2
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/extension-files.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/install.rdf.in
Hunk #1 FAILED at 6
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/install.rdf.in.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/test/browser_pdfjs_main.js
Hunk #1 FAILED at 4
Hunk #2 FAILED at 44
2 out of 2 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/test/browser_pdfjs_main.js.rej
patch failed, unable to continue (try -v)
patch failed, rejects left in working dir

Patchset could not be applied and pushed.
Comment 21 Mozilla RelEng Bot 2012-05-11 15:48:19 PDT
Autoland Patchset:
	Patches: 621696
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=24cba0fc07f5
Try run started, revision 24cba0fc07f5. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=24cba0fc07f5
Comment 22 Mozilla RelEng Bot 2012-05-11 15:57:20 PDT
Autoland Patchset:
	Patches: 621729, 621730
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=65b27ec668f5
Try run started, revision 65b27ec668f5. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=65b27ec668f5
Comment 23 Mozilla RelEng Bot 2012-05-11 16:06:10 PDT
Autoland Patchset:
	Patches: 622023, 622027
	Branch: mozilla-central => try
Patch 622027 could not be applied to mozilla-central.
patch failed, unable to continue (try -v)
patch failed, rejects left in working dir

Patch 622023 could not be applied to mozilla-central.
patching file browser/app/profile/extensions/uriloader@pdf.js/README.mozilla
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/README.mozilla.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/components/PdfStreamConverter.js
Hunk #1 succeeded at 63 with fuzz 2 (offset 3 lines).
patching file browser/app/profile/extensions/uriloader@pdf.js/content/web/debugger.js
Hunk #1 FAILED at 162
Hunk #2 FAILED at 192
Hunk #3 FAILED at 204
Hunk #4 FAILED at 255
Hunk #5 FAILED at 277
Hunk #6 FAILED at 422
6 out of 6 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/debugger.js.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-check.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-check.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-comment.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-comment.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-text.svg already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/annotation-text.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/bookmark.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/bookmark.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/check.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/check.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/comment.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/comment.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/document-print.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/document-print.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/download.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/download.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/go-down.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/go-down.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/go-up.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/go-up.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/nav-outline.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/nav-outline.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/nav-thumbs.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/nav-thumbs.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/pin-down.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/pin-down.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/pin-up.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/pin-up.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/texture.png already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/texture.png.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-bookmark.png already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-bookmark.png.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-download.png already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-download.png.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-menuArrows.png already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-menuArrows.png.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-pageDown-rtl.png already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-pageDown-rtl.png.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-pageDown.png already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-pageDown.png.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-pageUp-rtl.png already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-pageUp-rtl.png.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-pageUp.png already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-pageUp.png.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-print.png already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-print.png.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-sidebarToggle.png already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-sidebarToggle.png.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-viewOutline.png already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-viewOutline.png.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-viewThumbnail.png already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-viewThumbnail.png.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-zoomIn.png already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-zoomIn.png.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-zoomOut.png already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/toolbarButton-zoomOut.png.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/zoom-in.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/zoom-in.svg.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/images/zoom-out.svg' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/images/zoom-out.svg.rej
file browser/app/profile/extensions/uriloader@pdf.js/content/web/l10n.js already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/l10n.js.rej
unable to find 'browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer-snippet-firefox-extension.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer-snippet-firefox-extension.html.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.css
Hunk #1 FAILED at 0
Hunk #2 FAILED at 177
Hunk #3 succeeded at 792 with fuzz 1 (offset 535 lines).
Hunk #4 succeeded at 859 with fuzz 2 (offset 541 lines).
Hunk #5 FAILED at 350
Hunk #6 FAILED at 408
4 out of 6 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.css.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.html
Hunk #1 FAILED at 0
Hunk #2 FAILED at 18
Hunk #3 FAILED at 87
Hunk #4 FAILED at 124
Hunk #5 FAILED at 143
Hunk #6 FAILED at 194
Hunk #7 FAILED at 239
Hunk #8 FAILED at 348
Hunk #9 FAILED at 366
Hunk #10 FAILED at 448
Hunk #11 FAILED at 457
Hunk #12 FAILED at 495
Hunk #13 FAILED at 534
Hunk #14 FAILED at 595
Hunk #15 FAILED at 605
Hunk #16 FAILED at 619
Hunk #17 FAILED at 633
Hunk #18 FAILED at 654
Hunk #19 succeeded at 608 with fuzz 1 (offset -395 lines).
Hunk #20 succeeded at 12465 with fuzz 2 (offset 11380 lines).
Hunk #21 succeeded at 772 with fuzz 1 (offset -321 lines).
Hunk #22 FAILED at 1266
Hunk #23 FAILED at 1288
Hunk #24 FAILED at 1303
Hunk #25 FAILED at 1350
Hunk #26 FAILED at 1702
Hunk #27 FAILED at 2722
Hunk #28 FAILED at 2761
Hunk #29 FAILED at 3023
Hunk #30 FAILED at 3084
Hunk #31 FAILED at 3245
Hunk #32 FAILED at 3268
Hunk #33 FAILED at 3301
Hunk #34 succeeded at 3595 with fuzz 2 (offset 274 lines).
Hunk #35 succeeded at 1743 with fuzz 1 (offset -1792 lines).
Hunk #36 FAILED at 4372
Hunk #37 succeeded at 1152 with fuzz 1 (offset -3258 lines).
Hunk #38 succeeded at 1154 with fuzz 2 (offset -3363 lines).
Hunk #39 succeeded at 4798 with fuzz 2 (offset -6653 lines).
Hunk #40 succeeded at 30386 with fuzz 2 (offset 18402 lines).
Hunk #41 succeeded at 30386 with fuzz 1 (offset 17806 lines).
Hunk #42 FAILED at 12734
Hunk #43 FAILED at 13047
Hunk #44 FAILED at 13061
Hunk #45 FAILED at 13117
Hunk #46 FAILED at 13206
Hunk #47 FAILED at 13423
Hunk #48 FAILED at 13443
Hunk #49 succeeded at 12265 with fuzz 1 (offset -1224 lines).
Hunk #50 FAILED at 14256
Hunk #51 FAILED at 14280
Hunk #52 succeeded at 15517 with fuzz 1 (offset 298 lines).
Hunk #53 FAILED at 15234
Hunk #54 FAILED at 15252
Hunk #55 FAILED at 15267
Hunk #56 FAILED at 15281
Hunk #57 succeeded at 15885 with fuzz 2 (offset 306 lines).
Hunk #58 FAILED at 16020
Hunk #59 succeeded at 496 with fuzz 1 (offset -17686 lines).
Hunk #60 succeeded at 4693 with fuzz 2 (offset -17703 lines).
Hunk #61 FAILED at 22411
Hunk #62 succeeded at 2994 with fuzz 1 (offset -19777 lines).
Hunk #63 succeeded at 4802 with fuzz 2 (offset -20918 lines).
Hunk #64 FAILED at 25969
Hunk #65 succeeded at 4803 with fuzz 2 (offset -21557 lines).
Hunk #66 FAILED at 26470
Hunk #67 succeeded at 4804 with fuzz 2 (offset -21860 lines).
Hunk #68 succeeded at 4805 with fuzz 2 (offset -24154 lines).
Hunk #69 FAILED at 29044
Hunk #70 FAILED at 29089
Hunk #71 FAILED at 29107
Hunk #72 succeeded at 29506 with fuzz 2 (offset 345 lines).
Hunk #73 FAILED at 29798
Hunk #74 FAILED at 29813
Hunk #75 FAILED at 29821
Hunk #76 FAILED at 29889
Hunk #77 FAILED at 30069
Hunk #78 succeeded at 32287 with fuzz 2 (offset 353 lines).
Hunk #79 FAILED at 32364
Hunk #80 FAILED at 32440
58 out of 80 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.html.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.js
Hunk #1 succeeded at 19 with fuzz 2 (offset 2 lines).
Hunk #2 FAILED at 33
Hunk #3 succeeded at 71 with fuzz 2 (offset 5 lines).
Hunk #4 FAILED at 218
Hunk #5 FAILED at 249
Hunk #6 FAILED at 322
Hunk #7 FAILED at 364
Hunk #8 FAILED at 441
Hunk #9 FAILED at 460
Hunk #10 FAILED at 480
Hunk #11 FAILED at 518
Hunk #12 FAILED at 562
Hunk #13 FAILED at 622
Hunk #14 FAILED at 715
Hunk #15 FAILED at 736
Hunk #16 FAILED at 752
Hunk #17 FAILED at 762
Hunk #18 FAILED at 774
Hunk #19 FAILED at 797
Hunk #20 FAILED at 813
Hunk #21 FAILED at 872
Hunk #22 FAILED at 882
Hunk #23 FAILED at 938
Hunk #24 FAILED at 982
Hunk #25 FAILED at 990
Hunk #26 FAILED at 1019
Hunk #27 FAILED at 1049
Hunk #28 FAILED at 1070
Hunk #29 succeeded at 1186 with fuzz 1 (offset 105 lines).
Hunk #30 FAILED at 1247
Hunk #31 succeeded at 1381 with fuzz 2 (offset 109 lines).
Hunk #32 FAILED at 1287
Hunk #33 FAILED at 1315
Hunk #34 FAILED at 1345
Hunk #35 FAILED at 1387
Hunk #36 FAILED at 1416
Hunk #37 succeeded at 1585 with fuzz 2 (offset 137 lines).
Hunk #38 FAILED at 1472
Hunk #39 FAILED at 1490
34 out of 39 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/content/web/viewer.js.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/extension-files
Hunk #1 FAILED at 2
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/extension-files.rej
patching file browser/app/profile/extensions/uriloader@pdf.js/install.rdf.in
Hunk #1 FAILED at 6
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/install.rdf.in.rej
file browser/app/profile/extensions/uriloader@pdf.js/l10n/metadata.inc already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/l10n/metadata.inc.rej
file browser/app/profile/extensions/uriloader@pdf.js/l10n/viewer.properties already exists
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/uriloader@pdf.js/l10n/viewer.properties.rej
patch failed, unable to continue (try -v)
patch failed, rejects left in working dir

Patchset could not be applied and pushed.
Comment 24 Artur Adib 2012-05-16 08:38:24 PDT
Thanks, Clint.

I've tried to add a SimpleTest.waitForElement() to the two SimpleTest.js files I found (testing/mochitest/tests/SimpleTest/SimpleTest.js and dom/tests/mochitest/ajax/mochikit/tests/SimpleTest/SimpleTest.js) but it didn't seem to work -- the function waitForElement() doesn't seem to be made available to our tests. 

I also tried adding a global wrapper like what is done for waitForFocus() etc in testing/mochitest/browser-test.js but it didn't seem to help. Any ideas on how to make a new method available in SimpleTest for these chrome tests?

As to the zoom out comment, you're absolutely right -- that comment was copied from zoom in, and I forgot to change from "increases" to "decreases" :)

I'll hold off on updating the patch until I have a better idea of how to add waitForElement() to SimpleTest.

Thanks again!
Comment 25 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-05-16 11:55:42 PDT
I'm not confident that waitForElement is generally useful enough to bother moving it into the test harness. For now you can just land it in a head.js for your test directory, and we can always move it later - I don't think you need to block these patches on doing that.
Comment 26 Dave Townsend [:mossop] 2012-05-17 13:12:33 PDT
Comment on attachment 622023 [details] [diff] [review]
new UI

Waiting on a response to comment 15
Comment 27 Dave Townsend [:mossop] 2012-05-17 13:36:01 PDT
Comment on attachment 622023 [details] [diff] [review]
new UI

Talked on IRC. The UI here has already been reviewed by brendan and yury so I think this is good to land.
Comment 28 Artur Adib 2012-05-18 10:36:48 PDT
Created attachment 625157 [details] [diff] [review]
tests for new UI
Comment 29 Artur Adib 2012-05-18 10:37:31 PDT
Created attachment 625158 [details] [diff] [review]
new UI
Comment 30 Artur Adib 2012-05-18 10:41:46 PDT
Comment on attachment 625157 [details] [diff] [review]
tests for new UI

Clint- I have moved waitForElement() to head.js as per Gavin's suggestion, and patched the increase/decrease comment. Thanks!
Comment 31 Artur Adib 2012-05-18 10:43:17 PDT
Comment on attachment 625158 [details] [diff] [review]
new UI

Dave- Sorry I didn't mean to make this patch obsolete (was supposed to update the tests only) but now that I did I suppose we'll need another r+? Thanks!
Comment 32 Artur Adib 2012-05-22 16:13:54 PDT
Created attachment 626232 [details] [diff] [review]
new UI

The previous patch got rotten due to #740795. Mostly they just moved files around.
Comment 33 Artur Adib 2012-05-22 16:16:18 PDT
Created attachment 626234 [details] [diff] [review]
tests for new UI

The previous patch got rotten due to #740795. Mostly they just moved files around.
Comment 34 cmtalbert 2012-05-23 02:31:02 PDT
Comment on attachment 626234 [details] [diff] [review]
tests for new UI

Sorry I missed the previous comment. I think this is fine. Not sure why the API wasn't available when you added it to the SimpleTest APIs -- that should have worked. But adding it into the head.js is a fine way to handle it. We can look at the Simpletest API addition later if someone needs to re-use the waitFor code. 

Thanks!
Comment 35 Artur Adib 2012-05-25 08:26:48 PDT
Turns out these patches were crashing all debug builds (https://tbpl.mozilla.org/?tree=Try&rev=22715c0806d5). I narrowed this down to the 'pagechange' event handler, and the zoom in/out tests. 

Changing to 'load' events and removing the zoom in/out tests fixed the problem for most debug builds, but apparently not on Windows (https://tbpl.mozilla.org/?tree=Try&rev=47c9a4c7adac).

I'll try to work around this a bit more, but it sounds like our asynchronous tests are not very reliable at the moment.
Comment 36 Artur Adib 2012-05-25 08:27:42 PDT
I should say it was crashing the tests in debug mode, not the debug builds.
Comment 37 Artur Adib 2012-05-29 06:37:45 PDT
Created attachment 627938 [details] [diff] [review]
tests for new UI

As commented before, I had to remove all async tests as they were crashing and/or timing out debug builds. These new tests are OK:

https://tbpl.mozilla.org/?tree=Try&rev=583dfb4d4dc8

After our Aurora uplift in a couple of weeks we'll investigate what was causing this and try to come up with more reliable tests.
Comment 38 cmtalbert 2012-05-29 14:33:28 PDT
Comment on attachment 627938 [details] [diff] [review]
tests for new UI

looks good.

Note You need to log in before you can comment on or make changes to this bug.