Closed Bug 749120 Opened 8 years ago Closed 8 years ago

Tapping on Flash object opens up virtual keyboard

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 15
Tracking Status
firefox14 --- fixed
blocking-fennec1.0 --- beta+

People

(Reporter: martijn.martijn, Assigned: snorp)

References

()

Details

(Keywords: regression, Whiteboard: VKB)

Attachments

(1 file)

I filed this because of discussion in bug 747492.

Chris mentioned this is likely a regression from bug 707353.

Steps to reproduce:
- Tap on any Flash embed you see

Expected result:
- No virtual keyboard comes up (when it's not expected, which it usually is)

Actual result:
- Virtual keyboard appears.

It happens with every Flash embed, not just full page plugins, so this one too:
http://people.mozilla.org/~mwargers/tests/plugins/flash/flashembed.html

Tested on the Samsung Galaxy Nexus and the Samsung Galaxy SII.
I think this should be a release blocker because interacting with any Flash content will open the VKB. The Flash content will still work correctly, so I don't think this bug needs to be a beta blocker.
Keywords: regression
I've got a fix for this coming
Assignee: nobody → snorp
blocking-fennec1.0: ? → beta+
Attachment #618666 - Flags: review?(blassey.bugs) → review+
Comment on attachment 618666 [details] [diff] [review]
Fix hiding the keyboard from Flash on Android

[Approval Request Comment]
Low risk, fixes highly visible bug, mobile only
Attachment #618666 - Flags: approval-mozilla-aurora?
Attachment #618666 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
This is on Aurora and inbound, correct?  Is there a link to the changesets for those?
https://hg.mozilla.org/mozilla-central/rev/7b04b6bc7e4e
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
I am not seeing the issue at http://people.mozilla.org/~mwargers/tests/plugins/flash/flashembed.html. However I am seeing a similar behavior at studio1290.com. I logged Bug 750229 for it. Leaving this issue unverified until it can be determined if the 2 issues are related.
Verified fixed on Nightly 15.0a1 (2012-05-03) using http://people.mozilla.org/~mwargers/tests/plugins/flash/flashembed.html 

Samsung Galaxy SII (Android 2.3.4)
Status: RESOLVED → VERIFIED
This is not fixed on Nightly/Aurora.

Using Aurora (05/08), Nightly (05/08)

STR:

www.hulu.com, activate the main container - see virtual keyboard pop-up.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Nevermind, it's the search box on the top right
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
It still happens on trunk with the url testcase (which is a standalone Flash file).
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Ok, I guess that is bug 747492 and/or bug 750771.
Whiteboard: VKB
Ok, marking fixed, since this was fixed with the urls that this bug was originally about.
The other vkb issues are covered by the bugs I mentioned in comment 13.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.