Closed Bug 749206 Opened 8 years ago Closed 8 years ago

Failure in /testPasswordManager/testPasswordSavedAndDeleted.js | Expression "id("password-save-notification")" returned null. Anonymous == false

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect)

defect
Not set

Tracking

(firefox12 unaffected, firefox13 verified, firefox14 verified, firefox15 verified, firefox-esr10 unaffected, status1.9.2 unaffected)

VERIFIED FIXED
Tracking Status
firefox12 --- unaffected
firefox13 --- verified
firefox14 --- verified
firefox15 --- verified
firefox-esr10 --- unaffected
status1.9.2 --- unaffected

People

(Reporter: AlexLakatos, Assigned: AlexLakatos)

References

()

Details

(Whiteboard: [mozmill-test-failure])

Attachments

(2 files)

TEST: /testPasswordManager/testPasswordSavedAndDeleted.js::testSaveAndDeletePassword
ERROR: Expression "id("password-save-notification")" returned null. Anonymous == false 
WHEN: 2012-04-25
FIRST: 2012-04-25
FREQ: 3
BRANCHES: default

Something changed in popup-notification creation in Firefox.
On previous versions an element with id "password-save-notification" got created and after closing, still remained in the xul file. Not it is removed.
This patch fixes the initial failure. But then it fails with "Modal dialog has been found and processed". Seeing as how a lot of our tests fail with that message since the merge, I'm guessing the that change will be in the shared modules, and not in the test.
Assignee: nobody → alex.lakatos
Status: NEW → ASSIGNED
Attachment #618689 - Flags: review?(anthony.s.hughes)
Comment on attachment 618689 [details] [diff] [review]
patch v1.0 [checked-in:default,aurora,beta]

While we are here, is there any reason not to refactor this to use the assertions module?
Attachment #618689 - Flags: review?(anthony.s.hughes) → review-
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #2)
> Comment on attachment 618689 [details] [diff] [review]
> patch v1.0
> 
> While we are here, is there any reason not to refactor this to use the
> assertions module?
Maybe because there is a bug for that and it may conflict with that patch? bug 586286
If that's not the case, here is a patch that uses the assertions module
Attachment #618698 - Flags: review?(anthony.s.hughes)
Yeah, good point. So I think we take the first patch to fix the failure but the assertions patch in bug 586286 will need to be updated too as the changes made here will not be reflected.
Attachment #618698 - Flags: review?(anthony.s.hughes)
Comment on attachment 618689 [details] [diff] [review]
patch v1.0 [checked-in:default,aurora,beta]

Changing review to r+, the patch looks fine code-wise.
Attachment #618689 - Flags: review- → review+
Comment on attachment 618689 [details] [diff] [review]
patch v1.0 [checked-in:default,aurora,beta]

Landed:
http://hg.mozilla.org/qa/mozmill-tests/rev/55640e767cc3 (default)
Attachment #618689 - Attachment description: patch v1.0 → patch v1.0 [checked-in:default]
I think there is a bug already on file for the Modal Dialog issue -- please mark it as a dependency for this failure. If not, please file a new one (we may want this test to be disabled until it can be fixed properly).
Comment on attachment 618698 [details] [diff] [review]
patch with assertions

Please don't checkin the assertion changes. You all know that we have bug 586286 for it.
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #7)
Please drop my last comment. Have missed one former comment from Alex.

> I think there is a bug already on file for the Modal Dialog issue -- please
> mark it as a dependency for this failure. If not, please file a new one (we
> may want this test to be disabled until it can be fixed properly).

Actually for this new regression there hasn't been filed a bug yet. So please do so. If you can't make any progress on it until Wed next week, I will jump on it.
Landed on default, so it's fixed. Please make sure to also check-in the patch on Aurora because Firefox 14 is also affected.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Also where is the /testPasswordManager/testPasswordNotificationBar.js failure covered? It's exactly the same issue.
(In reply to Henrik Skupin (:whimboo) from comment #11)
> Also where is the /testPasswordManager/testPasswordNotificationBar.js
> failure covered? It's exactly the same issue.

I believe what you are looking for is bug 749156.
Comment on attachment 618689 [details] [diff] [review]
patch v1.0 [checked-in:default,aurora,beta]

Landed:
http://hg.mozilla.org/qa/mozmill-tests/rev/8a196ca5f031 (mozilla-aurora)
Attachment #618689 - Attachment description: patch v1.0 [checked-in:default] → patch v1.0 [checked-in:default,aurora]
Comment on attachment 618689 [details] [diff] [review]
patch v1.0 [checked-in:default,aurora,beta]

Noticed this failure made it into Beta recently:
http://mozmill-ondemand.blargon7.com/#/functional/report/c2b72632f20450b6d99d14c709b017e5

Landed:
http://hg.mozilla.org/qa/mozmill-tests/rev/f3e0029524a5 (mozilla-beta)
Attachment #618689 - Attachment description: patch v1.0 [checked-in:default,aurora] → patch v1.0 [checked-in:default,aurora,beta]
Have not seen this recently, marking verified.
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.