Last Comment Bug 749222 - Create a separate way to start a chrome debugger
: Create a separate way to start a chrome debugger
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: 12 Branch
: All All
: -- normal (vote)
: Firefox 15
Assigned To: Victor Porof [:vporof][:vp]
:
: James Long (:jlongster)
Mentors:
Depends on:
Blocks: 747429
  Show dependency treegraph
 
Reported: 2012-04-26 08:59 PDT by Victor Porof [:vporof][:vp]
Modified: 2012-05-04 07:28 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (6.24 KB, patch)
2012-04-26 09:19 PDT, Victor Porof [:vporof][:vp]
past: review+
Details | Diff | Splinter Review
v2 (5.79 KB, patch)
2012-04-26 11:20 PDT, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review
v2.1 (5.77 KB, patch)
2012-04-26 11:29 PDT, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review

Description Victor Porof [:vporof][:vp] 2012-04-26 08:59:08 PDT

    
Comment 1 Victor Porof [:vporof][:vp] 2012-04-26 09:19:27 PDT
Created attachment 618685 [details] [diff] [review]
v1
Comment 2 Panos Astithas [:past] 2012-04-26 10:37:47 PDT
Comment on attachment 618685 [details] [diff] [review]
v1

Review of attachment 618685 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/app/profile/firefox.js
@@ +1064,4 @@
>  pref("devtools.debugger.remote-enabled", false);
>  pref("devtools.debugger.remote-host", "localhost");
>  pref("devtools.debugger.remote-port", 6000);
> +pref("devtools.debugger.chrome-enabled", false);

No need for that, we already have devtools.chrome.enabled.

::: browser/locales/en-US/chrome/browser/devtools/debugger.dtd
@@ +16,5 @@
>  <!ENTITY remoteDebuggerMenu.label    "Remote Debugger">
>  
> +<!-- LOCALIZATION NOTE (firefoxDebuggerMenu.label): This is the label for the
> +  -  application menu item that opens the firefox debugger UI. -->
> +<!ENTITY firefoxDebuggerMenu.label   "Firefox Debugger">

Browser Debugger I believe was the consensus in the room.
Comment 3 Victor Porof [:vporof][:vp] 2012-04-26 11:20:41 PDT
Created attachment 618729 [details] [diff] [review]
v2
Comment 4 Victor Porof [:vporof][:vp] 2012-04-26 11:29:47 PDT
Created attachment 618736 [details] [diff] [review]
v2.1

Using "chromeDebugger" ids instead of "firefoxDebugger" for consistency.
Comment 5 Victor Porof [:vporof][:vp] 2012-04-27 06:14:12 PDT
A test fails.
Comment 6 Victor Porof [:vporof][:vp] 2012-04-27 06:15:49 PDT
(In reply to Victor Porof from comment #5)
> A test fails.

Nope, I had my mq messed up.
Comment 7 Rob Campbell [:rc] (:robcee) 2012-04-27 10:26:08 PDT
also, this appears to depend on the remote debugger patches.
Comment 8 Victor Porof [:vporof][:vp] 2012-04-27 10:27:04 PDT
(In reply to Rob Campbell [:rc] (:robcee) from comment #7)
> also, this appears to depend on the remote debugger patches.

...which landed
Comment 9 Rob Campbell [:rc] (:robcee) 2012-05-02 07:34:48 PDT
https://hg.mozilla.org/integration/fx-team/rev/77ee439cc506
Comment 10 Tim Taubert [:ttaubert] 2012-05-02 17:10:20 PDT
Sorry, I had to back this out because of a merge conflict with m-c.

https://hg.mozilla.org/integration/fx-team/rev/90a1323daf91

We needed to merge m-c to fx-team because we had to backout patches causing a Ts regression:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d871849ac3a3&tochange=0f8ea3826bf7
Comment 11 Rob Campbell [:rc] (:robcee) 2012-05-03 05:56:35 PDT
https://hg.mozilla.org/integration/fx-team/rev/dc3bd5eab128
Comment 12 Tim Taubert [:ttaubert] 2012-05-04 07:28:56 PDT
https://hg.mozilla.org/mozilla-central/rev/dc3bd5eab128

Note You need to log in before you can comment on or make changes to this bug.