The default bug view has changed. See this FAQ.

"make install" doesn't install xpcshell and run-mozilla.sh in the SDK

RESOLVED FIXED in Firefox 14

Status

()

Core
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

Trunk
mozilla15
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox12 unaffected, firefox13 unaffected, firefox14 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
bug 743560 made them part of the SDK instead of xulrunner. make make-sdk ships them, but make install doesn't.

As a side note, run-mozilla.sh is not shipped in xulrunner, maybe it shouldn't be shipped in Firefox either.
(Assignee)

Comment 1

5 years ago
Created attachment 618992 [details] [diff] [review]
Declare run-mozilla.sh and xpcshell as SDK_BINARY
Attachment #618992 - Flags: review?(ted.mielczarek)
(Assignee)

Updated

5 years ago
status-firefox12: --- → unaffected
status-firefox13: --- → unaffected
status-firefox14: --- → affected
Attachment #618992 - Flags: review?(ted.mielczarek) → review+
(Assignee)

Comment 2

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/879fd99f199c
Target Milestone: --- → mozilla15
https://hg.mozilla.org/mozilla-central/rev/879fd99f199c
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

5 years ago
Comment on attachment 618992 [details] [diff] [review]
Declare run-mozilla.sh and xpcshell as SDK_BINARY

[Approval Request Comment]
Regression caused by: bug 743560 
User impact if declined: People using make install (mostly, Linux distros) won't have run-mozilla.sh and xpcshell installed with SDK.
Testing completed (on m-c, etc.): Landed on m-c a couple days ago.
Risk to taking this patch (and alternatives if risky): None.
String changes made by this patch: None.
Attachment #618992 - Flags: approval-mozilla-aurora?

Comment 5

5 years ago
Comment on attachment 618992 [details] [diff] [review]
Declare run-mozilla.sh and xpcshell as SDK_BINARY

[Triage Comment]
Low risk fix in support of local builds.
Attachment #618992 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 6

5 years ago
http://hg.mozilla.org/releases/mozilla-aurora/rev/f9241d246616
status-firefox14: affected → fixed
You need to log in before you can comment on or make changes to this bug.