Closed Bug 749608 Opened 9 years ago Closed 8 years ago

Add dvm* to skiplist for Android

Categories

(Socorro :: Infra, task)

x86
macOS
task
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 741315

People

(Reporter: snorp, Assigned: rhelmer)

Details

Any time we crash on Android in the Dalvik VM, we get a trace that has a bunch of libdvm symbols (see bug 747799). Please add 'dvm' to the skiplist regex.
I believe the regex would be:
'libdvm.so@0x.*'

Is that correct?
(In reply to Naoki Hirata :nhirata from comment #1)
> I believe the regex would be:
> 'libdvm.so@0x.*'
> 
> Is that correct?

Hmm looks like we already have it:
https://github.com/mozilla/socorro/blob/master/scripts/config/processorconfig.py.dist#L134

Is it incorrect or otherwise not working?
You're right.... that should do the trick but for some reason it is not working.
Assignee: nobody → rhelmer
Status: NEW → ASSIGNED
If every frames in the stack are in the ignore skiplist, the fallback mechanism is to show the first frame anyway. So I think it should be closed as invalid.
The current libdvm ignore list works. See bp-b70404d0-75b1-49ea-ac04-4db0d2120505 (there's bug 741222 for dalvik-LinearAlloc (deleted))
(In reply to Scoobidiver from comment #4)
> If every frames in the stack are in the ignore skiplist, the fallback
> mechanism is to show the first frame anyway. So I think it should be closed
> as invalid.

Please reopen if there's any disagreement ^
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
Turns out that we need it for bug 738198

Socorro is still showing : dvmAsmInstructionStart

It should be skipping this, but I believe that skiplist is expecting a \s so it's not skipping it properly.


'libdvm.so' should skip the correct stuff.  I had the wrong skiplist in comment 1.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
If the goal of this bug is to add dvm.*, it's already asked in bug 741315.
In that light I also don't understand the reopen here.
Hrm.  true.  closing; I wasn't thinking when I reopened this bug, I suppose.  I'll close it as a dup.
Status: REOPENED → RESOLVED
Closed: 9 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 741315
You need to log in before you can comment on or make changes to this bug.