The default bug view has changed. See this FAQ.

favicon of previous page is displayed on tab when you hit back button

RESOLVED FIXED

Status

SeaMonkey
Tabbed Browser
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: FourthDr, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

Trunk
regression

SeaMonkey Tracking Flags

(seamonkey2.10 fixed, seamonkey2.11 fixed, seamonkey2.12 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 619250 [details]
Show wrong icon on tab for google

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14; Firefox/5.0.0
Build ID: 20110420224920

Steps to reproduce:

Open Seamonkey, open a few tabs. Go to different websites that have favicons. 


Actual results:

Hit the browser back button once, that tab retains the previous sites favicon. This works the other way around as well, if you go forward the last websites favicon is displayed on the tab. However if you go forwared or back more than once the icon on the tab does update. But the next forward/back it does it again. This can be confusing when you have lots of tabs open and are looking for the site specific icon.


Expected results:

The tab should be displaying the correct site favicon on the tab at all times, not the previous icon when using the forward/back buttons.

Comment 1

5 years ago
> User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19)
> Gecko/20110420 SeaMonkey/2.0.14; Firefox/5.0.0
> Build ID: 20110420224920
SeaMonkey 2.0 is old, obsolete and unsupported. Does this happen in SeaMonkey 2.9?
(Reporter)

Comment 2

5 years ago
Yes, I started noticing this beginning with version ~2.2. The most current version 2.9 does it too.

Comment 3

5 years ago
Confirming problem on trunk
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120425 Firefox/15.0a1 SeaMonkey/2.12a1
1) Visit somewebsite.com with favicon
2) Go to google.com, favicon is correct
3) Press back button, previous site with it's favicon also rendered correctly
4) Now press Forward button, and Google get favicon from previous site on tab
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Version: SeaMonkey 2.9 Branch → Trunk

Comment 4

5 years ago
Hmm. Neil, is this a tabbrowser bug?
Component: General → Tabbed Browser
QA Contact: general → tabbed-browser
(Assignee)

Comment 5

5 years ago
Actually this looks like a regression from bug 660618, which landed in 2.2; what's happening is that we're no longer clearing the previous favicon when we're navigating through the bfcache.

For consistency I suppose the easiest fix is to always remove the favicon (if the page is blank then it won't have a favicon, so no change there).
Blocks: 660618
(Assignee)

Comment 6

5 years ago
Except that that's suboptimal because we then have a slight visual glitch when navigating between two pages with favicons...

Updated

5 years ago
Keywords: regression
(Assignee)

Comment 7

5 years ago
Created attachment 620246 [details] [diff] [review]
Proposed patch

At this point of the code we're normally turning off the busy animation, so we're not expecting there to be an image set on the tab.

But of course bug 660618 changed this, so we're not busy, and any previous image is still there. This looks like the best place to remove it.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #620246 - Flags: review?(philip.chee)

Updated

5 years ago
Summary: favicon of previuos page is displayed on tab when you hit back button → favicon of previous page is displayed on tab when you hit back button

Comment 8

5 years ago
Comment on attachment 620246 [details] [diff] [review]
Proposed patch

r=me
Attachment #620246 - Flags: review?(philip.chee) → review+
(Assignee)

Comment 9

5 years ago
Pushed changeset eae8f8e14ac3 to comm-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

5 years ago
Comment on attachment 620246 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 660618
User impact if declined: tab favicon confusion
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): low
String changes made by this patch: none
Attachment #620246 - Flags: approval-comm-beta?
Attachment #620246 - Flags: approval-comm-aurora?

Comment 11

5 years ago
Comment on attachment 620246 [details] [diff] [review]
Proposed patch

a=me
Attachment #620246 - Flags: approval-comm-beta?
Attachment #620246 - Flags: approval-comm-beta+
Attachment #620246 - Flags: approval-comm-aurora?
Attachment #620246 - Flags: approval-comm-aurora+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Whiteboard: [transplant changeset eae8f8e14ac3]

Comment 12

5 years ago
Pushed to branches:
http://hg.mozilla.org/releases/comm-aurora/rev/7bedf46ed3f1
http://hg.mozilla.org/releases/comm-beta/rev/58780f423196
status-seamonkey2.10: --- → fixed
status-seamonkey2.11: --- → fixed
status-seamonkey2.12: --- → fixed
Keywords: checkin-needed
Whiteboard: [transplant changeset eae8f8e14ac3]
You need to log in before you can comment on or make changes to this bug.