Should be able to set e-mail prefs on a per-watch basis

RESOLVED WONTFIX

Status

()

P4
enhancement
RESOLVED WONTFIX
18 years ago
4 years ago

People

(Reporter: jacob, Unassigned)

Tracking

Dependency tree / graph

Details

(Reporter)

Description

18 years ago
I was just talking w/Håkan in IRC and the request was made to have a category
for filtering watched mail different than the rest.  Right now you inherit the
relationship of the person you are watching.

This involves a bit of code rearrangment (watching support will have to be moved
out of the filterEmailGroup sub to someplace before the names start getting
filtered) as well as the addition of the category into the prefs.
(Reporter)

Updated

18 years ago
Depends on: 73665
This might be best done with bug #14137 functionality, so you could specify
different watch settings per person and also be able to say something like "I am
watching X and I am on the CC of the bu."
Target Milestone: --- → Future
(Reporter)

Comment 2

17 years ago
-> New Bugzilla Product
Assignee: tara → myk
Component: Bugzilla → User Accounts
Product: Webtools → Bugzilla
Version: Bugzilla 2.11 → 2.11
(Reporter)

Updated

17 years ago
Blocks: 69399

Comment 3

17 years ago
Actually, I was wondering if that is really true.

I have set up two bugzilla accounts, one is watching the other.

The watched account has most mail prefs off, and receives little mail, but the
watching account has all flags on, and seems to receive everything going on in
the bugs, even bugmail that the watched account doesn't receive.
(Reporter)

Comment 4

17 years ago
Changing the summary to match where bug 73665 is taking this.  Also, bring this
down to 2.20 as it'll be quite a bit easier once bug 73665 lands.
Summary: Watching should have it's own filtering category. → Should be able to set e-mail prefs on a per-watch basis
Target Milestone: Future → Bugzilla 2.20
benc: That is a feature. If you're watching someone on vacation, then you still
want to get mail even if they've turned mail off...
(Reporter)

Updated

17 years ago
Blocks: 132893
Bugzilla 2.20 feature set is now frozen as of 15 Sept 2004.  Anything flagged
enhancement that hasn't already landed is being pushed out.  If this bug is
otherwise ready to land, we'll handle it on a case-by-case basis, please set the
blocking2.20 flag to '?' if you think it qualifies.
Target Milestone: Bugzilla 2.20 → Bugzilla 2.22
This is a WONTFIX. It was considered and rejected when doing the new email
architecture in bug 73665 - a) because it doesn't make much sense with our
watching model, and b) because it would increase UI and complexity a lot.

Gerv
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 8

14 years ago
Gerv, can you point me to the specific comments on bug 73665 where this was
discussed, or at least the timeframe. It was probably while I was away but I'd
like to see the more in depth reasoning behind the decision before I decide
whether or not to argue in favor of this (I still like the concept and don't
think it'd add too much UI complexity when viewed in a scope of its power).
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Target Milestone: Bugzilla 2.22 → Future
(Reporter)

Comment 9

14 years ago
Assigning to me while I look for more info so I don't lose track of it.
Assignee: myk → jake
Status: REOPENED → NEW
Jake: can you explain why it's a better model than the current one, and how the
UI would work?

Gerv
(Reporter)

Comment 11

14 years ago
In my head the UI was something along the lines of using subtabs on the mail
prefs. One for our current prefs, one for watching people, one for watching
products, etc. for every watch type. Then the "checkbox matrix" on those other
tabs would just have what you're watching (the user, the product, whatever)
where we currently have CCed, Assignee, Reporter, etc. The add and remove watch
would be a bit trickyer, but I think it would still be useful. Right now what we
have is "watch all these users or don't" and people are often confused about how
to set email prefs when they are using the watching feature.
I agree in the past people were confused when using the feature, so I rewrote
the explanatory text as part of bug 73665. What do you think of the new text?

I think a "standing in the shoes of" model for watching (of all sorts) is easy
to explain and understand, and prevents a proliferation of email preferences.

Gerv

Updated

13 years ago
No longer blocks: 132893

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa
Target Milestone: Future → ---

Updated

12 years ago
Duplicate of this bug: 69399

Updated

12 years ago
Priority: -- → P4

Updated

9 years ago
Assignee: jake → user-accounts
as per comment 7, re-resolving as WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 14 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.