FF12: Tooltips, Context Menus leaving junk on window borders with Hardware Acceleration enabled

RESOLVED DUPLICATE of bug 610713

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 610713
6 years ago
6 years ago

People

(Reporter: MarkRH, Unassigned)

Tracking

12 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 619435 [details]
ff12-hardware-accel-bug.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Right-click to display a context menu or hover over an item that causes a tooltip to display. Also happens with the bookmarks menu if it's long enough to go beyond the Window border. It does happen when using the Default Firefox theme.

This only happens when Hardware Acceleration is enabled in advanced options. Running Windows 7 Pro 64bit/SP1 with Nvidia 550ti with 296.10 WHQL drivers (the current version). It also happened with 285.62 drivers. If I switch program focus to force a border redraw, it clears it up. If I disable Hardware Acceleration I can not get it to happen.

Follow-up to this thread: http://forums.mozillazine.org/viewtopic.php?f=38&t=2464337


Actual results:

It sometimes leaves garbage on the Window Borders and possibly over programs that are behind Firefox.


Expected results:

It should have left nothing behind when the tooltip or context menu is no longer displayed.
(Reporter)

Updated

6 years ago
Component: Untriaged → Graphics
Product: Firefox → Core
(Reporter)

Comment 1

6 years ago
Oh yeah, my graphics info from Troubleshooting:

Adapter Description	NVIDIA GeForce GTX 550 Ti
Vendor ID	0x10de
Device ID	0x1244
Adapter RAM	1024
Adapter Drivers	nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version	8.17.12.9610
Driver Date	2-29-2012
Direct2D Enabled	true
DirectWrite Enabled	true (6.1.7601.17776)
ClearType Parameters	Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
WebGL Renderer	Google Inc. -- ANGLE (NVIDIA GeForce GTX 550 Ti) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)
GPU Accelerated Windows	1/1 Direct3D 10
AzureBackend	direct2d

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

6 years ago
Dupe of Bug 610713?
(Reporter)

Comment 3

6 years ago
Could be a dupe of that bug. I am using the Windows Classic theme and it does seem that turning off "Show shadows under windows" Visual Effects performance options seems to keep it from happening.  I also noticed that not all the tooltips obey the change in setting unless I restart the browser. For example, the tooltip that shows for Adblock Plus when hovering over the toolbar icon would not start showing the shadow after I changed the setting in Windows.

So whatever this is seems to be tied to Windows Classic theme and that Window Shadow option. Can't say I used an Aero theme much so I'll play with one for a while just to verify it's purely with the Windows Classic theme.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 610713
You need to log in before you can comment on or make changes to this bug.