Closed Bug 610713 Opened 9 years ago Closed 7 years ago

Popup menus leave artifacts on the desktop and nc client areas

Categories

(Core :: Widget: Win32, defect)

x86
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla18
Tracking Status
blocking2.0 --- -

People

(Reporter: jimm, Assigned: roc)

References

Details

(Keywords: regression)

Attachments

(8 files, 3 obsolete files)

Attached image artifacts
This has been reported before, but we discounted it as a windows bug. I've found a reliable way to reproduce this, and can't reproduce it in any other application. I've also found our 2d acceleration settings change the outcome.

STR:

1) enabled 2d acceleration
2) switch to aero basic on win7
3) shrink the window up so a menu in the favorites bar or menu bar overlaps the low/right side of the window.
4) display the menu
5) click on the content area to hide the menu

results: the area of the menu displayed over the desktop and nc client area does not repaint.

Disabling 2d accel "fixes" part of this bug in that the desktop is restored. The nc client area though still isn't refreshed.
blocking2.0: --- → ?
3.6 doesn't have the problem, marking as a regression. I'll see if I can track down a range.
8/17 -> 8/18:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=116f2046b9ef&tochange=9ef027bf2120

Bas, just a guess but "Bug 587861: Clear D2D surfaces on window destruction" looks kinda suspect.
(In reply to comment #2)
> 8/17 -> 8/18:
> 
> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=116f2046b9ef&tochange=9ef027bf2120
> 
> Bas, just a guess but "Bug 587861: Clear D2D surfaces on window destruction"
> looks kinda suspect.

All that does is nuke the cairo surface. Which really does nothing but release all the D3D10 surfaces. I don't really understand how it could affect this, what it means is the D3D10 surfaces get killed before the HWND is going to be destroyed, but I don't see how that would be a problem. There's no painting events coming in at this point anyway!

If the window is nuked, the desktop should still refresh. This might be a windows bug only with D3D usage, but it'd still be a windows bug as far as I can see.
While it's a regression, I kind of feel that coming across it would be unusual enough that it doesn't need to block. Feel free to renom if I'm wrong on that!
blocking2.0: ? → -
(In reply to comment #3)
> (In reply to comment #2)
> > 8/17 -> 8/18:
> > 
> > http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=116f2046b9ef&tochange=9ef027bf2120
> > 
> > Bas, just a guess but "Bug 587861: Clear D2D surfaces on window destruction"
> > looks kinda suspect.
> 
> All that does is nuke the cairo surface. Which really does nothing but release
> all the D3D10 surfaces. I don't really understand how it could affect this,
> what it means is the D3D10 surfaces get killed before the HWND is going to be
> destroyed, but I don't see how that would be a problem. There's no painting
> events coming in at this point anyway!
> 
> If the window is nuked, the desktop should still refresh. This might be a
> windows bug only with D3D usage, but it'd still be a windows bug as far as I
> can see.

That wasn't it, I tried commenting out ClearResources and it didn't help.

We also enabled 2d2 on 8/17 which triggered the desktop issue, but the repaint problem on the frame was present before this date.
Duplicate of this bug: 641343
Jim, could I somehow help fixing this?  I can reproduce with a debug build.
(In reply to comment #7)
> Jim, could I somehow help fixing this?  I can reproduce with a debug build.

Try and find some pattern in STR? I still see this as well, and it's weird, sometimes it happens, sometimes it does. Different menus & drop downs exhibit different behavior.
Regression window of the non-d2d portion of this bug might be helpful.
I experience this on Windows 7 using Windows Classic theme theme and its pretty annoying:

http://i.imgur.com/PMgT1.png (1. Place windows like this;)
http://i.imgur.com/OnWMB.png (2. Open the Bookmarks -> Bookmarks Toolbar menu and
                              hover over Latest Headlines to open its popup;)
http://i.imgur.com/dNMdm.png (3. Move the mouse over Getting Started to
                              dismiss Latest Headlines.)

http://i.imgur.com/LnHJL.png (1. Right-click near the border make sure you
                              move the mouse inside context menu;)
http://i.imgur.com/6GcJR.png (2. Move the mouse away and click to dismiss.)

Note with the second example, if I don't move the mouse inside the menu popup the the invalidated areas get repainted properly.

I experience the same using Windows 7 Basic theme also, however with it artifacts get left on the desktop sometimes, also.

I don't experience this using Windows 7 Aero with transparency turned on or off, and I don't experience such problem using Windows XP, FWIW.  I've tried using:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0a2) Gecko/20110416 Firefox/5.0a2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110416 Firefox/6.0a1
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:6.0a1) Gecko/20110415 Firefox/6.0a1
Duplicate of this bug: 654689
I think you have all elements for a permanent fix.

Let me know about any progress.

Thank you.
I too have started to experience this problem.  

It appears that Firefox wrongly calculates the size of its window.

I think it only started recently (a few weeks ago) perhaps after FF4 or after a Windows 7 update.  I am running FF4.0.1 under Windows 7 Home 64 bit, basic theme, no Aero etc. 
 
Firefox popdown menus leave residual text on the top 1mm of the Windows TaskBar after the menu closes.  Firefox pop-up menus leave residual text etc on the Firefox window TitleBar.  See the image at http://i54.tinypic.com/5z4nps.gif

It appears that Firefox wrongly calculates the size of its window because if I expand a FF window to full screen, the lowest 1mm or so of the FF window is hidden "under" the taskbar.  Hence, I expect, that when FF repaints the taskbar after overwriting it, it does not repaint this 1mm strip because Firefox thinks this 1mm is Firefox window space, whereas it belongs to the TaskBar.  

If I resize a Firefox window to full screen height by dragging it to the screen edge and using Windows7 to resize it, the window is the correct height, and the last 1mm is not obscured by the TaskBar.  However, if I open a FF menu which overwrites the TaskBar, residual text is still left on the top 1mm of the taskbar when the menu closes.
(In reply to comment #13)
> I too have started to experience this problem.  

John, would you mind posting your about:support information on hardware acceleration?
Jim
I trust this is what you want - type about:support in the address field, and copy everything which appears under the Graphics heading.  If not let me know.

Graphics
      
Adapter Description      Intel(R) G41 Express Chipset
Vendor ID                8086
Device ID                2e32
Adapter RAM              Unknown
Adapter Drivers          igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version           8.15.10.2226
Driver Date              10-15-2010
Direct2D Enabled         true
DirectWrite Enabled      true (6.1.7601.17563, font cache n/a)
WebGL Renderer           Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.611)
GPU Accelerated Windows  3/3 Direct3D 10
Further testing shows a difference between disabling all add-ons/extensions and running in Safe Mode.

If I disable all my add-ons and extensions, FF still does it.

BUT, if I start in Safe Mode (from Help), the problem does not occur.
I agree with John_Ha. I already tested extensively this behavior in Bug 654689 (read comment 11 of this thread). Same conclusions.  

However, I haven't reported yet my about:support page concerning hardware acceleration. I do it now.

Graphics
      
Adapter Description      ATI Radeon HD 5800 Series
Vendor ID                1002
Device ID                6899
Adapter RAM              1024
Adapter Drivers          aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version           8.841.0.0
Driver Date              4-5-2011
Direct2D Enabled         true
DirectWrite Enabled      true (6.1.7601.17563, font cache n/a)
WebGL Renderer           Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.611)
GPU Accelerated Windows  2/2 Direct3D 10
Duplicate of this bug: 645524
No future plan for this issue? Still not fixed on Firefox 5 beta 3.
I have the same issue in Firefox 4.0.1 on Windows 7 64bit Home Premium it only happens when aero is off.

Adapter Description: NVIDIA GeForce GT 330M
Vendor: ID10de
Device: ID0a2b
Adapter: RAM1024
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version: 8.17.12.7533
Driver Date: 5-20-2011
Direct2D Enabled: true
DirectWrite Enabled: true (6.1.7601.17563, font cache n/a)
WebGL Renderer: Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.611)
GPU Accelerated Windows: 1/1 Direct3D 10
Still reproducible on Firefox 5.0
In like with minus54 comment I just retested with Firefox v5.0 stable same problem I had same system information as in my previous post (https://bugzilla.mozilla.org/show_bug.cgi?id=610713#c20)
Duplicate of this bug: 670979
Still present on Firefox 6 beta 2:
http://eng2ita.altervista.org/_altervista_ht/ARTIFACT.jpg
Starting the screen saver purges the taskbar of the 1mm of text that sticks from the bookmarks menu...

Windows 7 Home using classic theme.
Also, the "show desktop" button on the extreme right of the taskbar will purge the taskbar of any artifacts as well.
Assignee: nobody → jmathies
This bug seems to disappear whenever I attach a second monitor to my computer.

In addition to my primary display (1680x1050), I have attached, one at a time, two different monitors (1680x1050 and 1280x1024). When I attach a second monitor, any errors on my screen disappear, and I can't create more. This continues even if the second monitor is turned off. When I detach the second monitor, the errors start appearing again.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101 Firefox/6.0

without a second monitor connected:
Graphics
Adapter Description      ATI Radeon HD 4800 Series        
Vendor ID                1002
Device ID                9440
Adapter RAM              1024
Adapter Drivers          aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version           8.861.0.0
Driver Date              5-24-2011
Direct2D Enabled         true
DirectWrite Enabled      true (6.1.7601.17563)
ClearType Parameters     Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 100 
WebGL Renderer           Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)
GPU Accelerated Windows  1/1 Direct3D 10

with a second monitor connected:
GPU Accelerated Windows  3/3 Direct3D 10
Looks like I have 100% functional STR:

- run Earlybird (= TB Alpha)
- Tools/Account Settings...
- Press the Account Actions button, a small menu pops up
- Press the same button again, the menu is hidden again

-> That breaks the frame bellow and if put the right distance from the task bar bellow to draw over it, it breaks it too
Duplicate of this bug: 672752
I experience the same error in Firefox 9.0.1 (Release) with Windows 7 Pro 64bit.

Karten-Beschreibung	ATI Radeon HD 5800 Series
Vendor-ID		1002
Geräte-ID		6898
Karten-RAM		1024
Karten-Treiber		aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Treiber-Version		8.920.0.0
Treiber-Datum		11-9-2011
Direct2D aktiviert	true
DirectWrite aktiviert	true (6.1.7601.17563)
ClearType-Parameter	ClearType-Parameter nicht gefunden
WebGL-Renderer		Google Inc. -- ANGLE (ATI Radeon HD 5800 Series) -- OpenGL ES 2.0 (ANGLE 0.0.0.809)
GPU-beschleunigte Fenster 1/1 Direct3D 10
Duplicate of this bug: 718598
I have the same bug reported in this post, I use firefox 11.0 and windows 7 64bit professional.

Basically when I open firefox with the favorites that come to the end, these are printed on the taskbar (see picture) until I click on it or I click on start or change the screen showing the desktop or open another program or folder ... ...... in this case disappear immediately.

http://www.imagehost.it/di-6PTV.png

http://www.imagehost.it/di-OITT.png

I noticed that the problem occurs with all the themes win7 do not make use of aero, while the issues of using aero win7 the problem does not occur.
If I disable hardware acceleration in firefox the problem goes away but I will not do it.

I also tried to disable the extensions and the problem remains.

May not be able to solve this problem? We are already at version 11.0 and the problem has been present for a long time.
What should we do switch to Chrome?

excuse my English I used a translator
I forgot, I use the integrated Intel HD3000 graphics card and CPU is Intel i5-2500K.

the driver of graphics card is 8.15.10.2622.
I tested the following drivers for intel HD3000:

-8.15.10.2622
-8.15.10.2509

and the problem remains.
(In reply to clodrusso from comment #34)
> I tested the following drivers for intel HD3000:
> 
> -8.15.10.2622
> -8.15.10.2509
> 
> and the problem remains.

Same here using the last driver 8.15.10.2653 for Intel HD3000.
(In reply to noghere from comment #37)
> Same here using the last driver 8.15.10.2653 for Intel HD3000.

And same using Nvidia GeForce 540M 2GB 296.10 driver on Win7 HP.
Ans same using FF 9,10 and 11 release.
confirm with firefox 10 and 11.

Intel hd3000 driver tested
-8.15.10.2622
-8.15.10.2509
-8.15.10.2653

and the problem remains.
new driver for intel hd2000/3000 
Version 8.15.10.2669

link win7/vista 64bit:
http://download.asrock.com/drivers/Intel/VGA/VGA_Win7-64_Vista64(v15.26.6.64.2669).zip

someone has tested them to see if it solve?
noghere have you tested?
(In reply to clodrusso from comment #41)
> new driver for intel hd2000/3000 
> Version 8.15.10.2669
> 
> link win7/vista 64bit:
> http://download.asrock.com/drivers/Intel/VGA/VGA_Win7-64_Vista64(v15.26.6.64.
> 2669).zip
> 
> someone has tested them to see if it solve?
> noghere have you tested?

I've tested the latest driver version 8.15.10.2656 downloaded from the official Intel web site: same bug.I think it is not a VGA problem. The same happens using Nvidia GeForce GT 540M 296.10 VGA . It is a FF bug!
yes I think so too, but groped costs nothing.visto che avevi messo i 2656 pensavo volessi provare anche questi.

Even the versione 2669 which I have posted is official intel ...... what is the link station driver, even if it reports asrock OK too for all HD2000 HD3000.
(In reply to noghere from comment #42)
> > 
> > It is a FF bug!

I agree it is most likey to be a FF bug.  My first caveat is I know nothing about FF code, but even so, I doubt it is a driver problem as other apps do not do it.  I believe, as I said in my original post 13 above, "It appears that Firefox wrongly calculates the size of its [pop up] window".

Assume that when FF wants to paint a pop up window, it copies the existing screen image data to a buffer.  FF then paints its pop up.  FF closes the pop up by repainting what it has stored in its buffer.  (Alternatively, Windows might own the buffer, and FF ask Windows to repaint this rectangele FF used for its pop up.    

Whichever is the case, if FF uses different co-ordinates for its pop up window, and for the area it wants to be put back to how it looked before, then this explains the artefacts, and why only FF causes them.

So my guess is that FF paints a bigger area for its pop up than it asks to be put back as it was before.  And so it is not a driver issue. 

... but I am not a programmer.
After replacing my video card with a ATI card I have noticed the same problem for the mainmenu, bookmark menu's and popups, it does not correctly draw/redraw its menu's making it a terrible and unusable browser. On my previous low end graphic card there were no problems so i suspect there are problems with the mozilla video card interface

Specs: Mozilla 11, windows 7 ultimate, 64 bit with aero and theming disabled. ATI 5700 card with 11.2 driver (the newest 12.x driver had the same problem)
(In reply to Marius from comment #45)
> Specs: Mozilla 11, windows 7 ultimate, 64 bit with aero and theming
> disabled. ATI 5700 card with 11.2 driver (the newest 12.x driver had the
> same problem)

Me: Fx13, Win7 64, no aero, ATI 5700, Catalyst 12.3.  It could be a driver issue...
I'm not yet sure if its a driver issue or a ff issue. 

I do however have a solution for my menu problems and it may help the ff crew / programmers to understand what/where the problem is. If you disable the "Show shadow under windows" in de the "performance options" tabsheet "visual effects" then suddenly the menu nightmare stops and everything works like a charm!

(for some reason the installation of a new video driver resets all those options because i always disable those idiotic animation options)
I confirm, I also work with intel HD3000.
you're great ...
(In reply to Marius from comment #48)
> I do however have a solution for my menu problems and it may help the ff
> crew / programmers to understand what/where the problem is. If you disable
> the "Show shadow under windows" in de the "performance options" tabsheet
> "visual effects" then suddenly the menu nightmare stops and everything works
> like a charm!


I confirm too: the problem seems to be the shadow under the bookmarks window of Firefox. If didabled the "show shadow under windows" all works fine (without the shadow obviously...).
I reported the artefacts problem.

I had not given much thought to the fact that most FF bookmark icons appear only as outlines - I mistakenly attributed it to a problem with Xmarks synchronisation.
I too have the bookmarks appear as outlines problem as can bee seen from the attached image.
I think we should try using BasicLayers for popup widgets.

Please try the test build that will appear here:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/rocallahan@mozilla.com-35005404003e
and see if it fixes your problem.
Hello Robert, that build has the same problems (at least for me it did not made any difference).
Oh well.

It's definitely some kind of driver or Windows bug. Our code isn't responsible for keeping other application or system windows up to date. But it's hard to tell from the data in this bug what the trigger is. Maybe there are multiple different triggers.
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #53)
> I think we should try using BasicLayers for popup widgets.
> 
> Please try the test build that will appear here:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/rocallahan@mozilla.
> com-35005404003e
> and see if it fixes your problem.

I think it fixes the issue for me.

With Aurora I have to open local menu, then click on some disabled field, and then click beside the menu to make it disappear.  In some significant number of cases this leaves artifacts on the task bar.  Other str is to just do a lot of right clicking.

With your build, using both the same STR, I cannot reproduce.
Attached patch partial fixSplinter Review
Alright, if this patch fixes some problems for some people, we should do it.
Assignee: jmathies → roc
Attachment #614934 - Flags: review?(bas.schouten)
Attachment #614934 - Flags: review?(bas.schouten) → review+
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #55)
> Oh well.
> 
> It's definitely some kind of driver or Windows bug.

There is a delightful haiku which sums that up rather well

Yesterday it worked.
Today it is not working.
Windows is like that.

Haiku has strict construction rules: each poem has three lines and only 17 syllables: 5 syllables in the first line, 7 in the second, 5 in the third.  They are used to communicate a timeless message, often achieving a wistful, yearning and powerful insight through extreme brevity.  See http://www.snopes.com/computer/internet/haiku.asp

Sorry for the off topic post :-( but you guys are working **** fixing this and I thought you needed a smile.
https://hg.mozilla.org/mozilla-central/rev/07f55ad76d8f
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla14
Given comment #54, this has probably not fixed the issue for everyone. Please file a new bug for issues occurring in builds after this was checked in.
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #61)
> Please file a new bug for issues occurring in builds after this was checked
> in.
I will be pleased to test this but unfortunately I do not know how to access the new build.  Could someone please tell me.  I am a user and I dot have a development environment or compiler.
Thanks
(In reply to John_Ha from comment #62)
> (In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #61)
> > Please file a new bug for issues occurring in builds after this was checked
> > in.
> I will be pleased to test this but unfortunately I do not know how to access
> the new build.  Could someone please tell me.  I am a user and I dot have a
> development environment or compiler.
> Thanks

Latest nightly builds installer:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/
Test result with Nightly - firefox-14.0a1.en-US.win64-x86_64.installer.exe 17 April 2012 - shows no change from before.  Windows 7 Home edition, 64 bit, no Aero.
I had not noticed that if I position the FF or Nightly window very close to the taskbar the artefact gets split by the desktop background
(In reply to John_Ha from comment #64)
> Created attachment 616086 [details]
> 17 April 2012 Nightly result - no change
> 
> Test result with Nightly - firefox-14.0a1.en-US.win64-x86_64.installer.exe
> 17 April 2012 - shows no change from before.  Windows 7 Home edition, 64
> bit, no Aero.

Jim  I had not noticed that if I position the FF or Nightly window very close to the taskbar, with a small 1mm gap, the artefact gets split by the 1mm of desktop background, with one bit on the taskbar, and another bit on the edge frame" of the FF/Nightly window - see image above.  Might that help diagnosis?
This is strange.  I was really careful while testing the try build, but now the latest nightly that has the patch (checked) still doesn't fix...  As well as the try build now!  Sorry for misleading you to a wrong fix...

Reopening :(
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I have magnified an image of my artefacts.  
Note that the ones caused by the vertical edges are not related to the shadow. The artefact stops left-right at the "two pixels wide illuminated edge to give a 3D effect" of the window.  
The artefact extends 4 pixels deep into the taskbar.  This is exactly the distance between the top of the taskbar and the top of the icons on the taskbar (see left).
Sorry - I posted the low magnification image.

This is the high magnification image which shows the individual pixels.
Just got a forced mozilla update 12, I noticed this bug is still present, so its not fixed (and the disable "show shadows under windows" luckely still suppresses the problem).

Ehsan, was your fix applied in version 12? Or was it not included?
It's only in Firefox 14. But you can download an Aurora build here to see if it fixes the problem for you:
http://www.mozilla.org/en-US/firefox/channel/#aurora/aurora-desktop
I'm guessing the patch didn't help though, based on comment #67.
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #71)
> I'm guessing the patch didn't help though, based on comment #67.

The recent Nightly (after your post - I now forget which) still does it for me. 

A thought - is any of the FF code shared with Thunderbird?  Thunderbird does not do it.
I might have filed a duplicate of this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=750110
Duplicate of this bug: 752238
Duplicate of this bug: 750110
Same bug using FF 14.0.1. Help please!
Was getting it on FF 14.0.1 so down graded to FF 13 and have the problem with both versions of FF.  Using Windows 7 Pro 64bit
(In reply to noghere from comment #76)
> Same bug using FF 14.0.1. Help please!

SAME BUG USING FF 15.0. No comment.
The bug is still present solid and reproduceable at will with 15.0 on any of my different machines 
The hardware used does not matter really. ( for example, a I7 2600k with hd3000
or an old e6800 dual core with nvidia fx5200 
The O/S doesn't either ( XP or win7 32bit or win7 64 bit same behaviour) 
If I can help tracing or testing I will try, but I am no programmer.
Attached patch patch (obsolete) — Splinter Review
This patch fixes it for me. From what I understand adding WS_EX_COMPOSITED just makes the popup window and descendents double buffered. This is probably buffering the drop shadow (layers?) with the popup and allowing Windows to invalidate everything correctly when hidden.

It may only be masking the problem since it only happens with hardware acceleration rendering, but it's a simple enough fix assuming it works for everyone.
Attachment #660958 - Flags: review?(jmathies)
Attachment #660958 - Flags: feedback?(roc)
Comment on attachment 660958 [details] [diff] [review]
patch

Review of attachment 660958 [details] [diff] [review]:
-----------------------------------------------------------------

If this works, fabulous!
Attachment #660958 - Flags: feedback?(roc) → feedback+
Does this will fix the Firefox tooltips (the same ones as in any Windows applications) which stay displayed over the tabs and sometimes over another application when you're switching?
Attached patch patch v2 (obsolete) — Splinter Review
I can't recreate your tooltip bug, but I'm glad you mentioned it. While testing if I could reproduce it I noticed my patch wasn't rendering tooltips at all. Updated the patch to fix that. Maybe someone could pass this through try and link a build for people to test in case there are more side effects like this?
Attachment #660958 - Attachment is obsolete: true
Attachment #660958 - Flags: review?(jmathies)
Attachment #661029 - Flags: review?(jmathies)
How did the previous version cause tooltips to fail to render? That's kinda disturbing.

Maybe you should check for mDropShadow and only do your thing in that case.
Attached patch patch v3Splinter Review
I'm not sure why the tooltips become transparent with that flag. Firefox tooltips look slightly different than native ones, so I may be missing something in how they're rendered.

I took your advice and added a check for mDropShadow. I also kept the check for the popup menu type to be a little more robust.
Attachment #661029 - Attachment is obsolete: true
Attachment #661029 - Flags: review?(jmathies)
Attachment #661084 - Flags: review?(jmathies)
(In reply to Loic from comment #82)
> Does this will fix the Firefox tooltips (the same ones as in any Windows
> applications) which stay displayed over the tabs and sometimes over another
> application when you're switching?

Is that bug 785708 ?
I think it is Bug 685470
Comment on attachment 661084 [details] [diff] [review]
patch v3

This definitely fixes the problem on my system, and from the description on msdn it makes sense that it would. I'd like to run this past Bas since he worked on all the funny popup issues we had with acceleration.
Attachment #661084 - Flags: review?(jmathies)
Attachment #661084 - Flags: review?(bas.schouten)
Attachment #661084 - Flags: review+
So it can be considered as solved now?
I don't think we need to wait for Bas' additional review, this has languished long enough.

https://hg.mozilla.org/integration/mozilla-inbound/rev/2d39dbbe75b3
https://hg.mozilla.org/mozilla-central/rev/2d39dbbe75b3
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → FIXED
Target Milestone: mozilla14 → mozilla18
Comment on attachment 661084 [details] [diff] [review]
patch v3

Review of attachment 661084 [details] [diff] [review]:
-----------------------------------------------------------------

This looks great in any case!
Attachment #661084 - Flags: review?(bas.schouten) → review+
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #90)
> I don't think we need to wait for Bas' additional review, this has
> languished long enough.
> 
> https://hg.mozilla.org/integration/mozilla-inbound/rev/2d39dbbe75b3

You say to have fixed the bug. I've installed just now FF 16 and the bug is still there! Why don't you fix the latest FF version? What is the problem? Several months later the bug appeared, I think is now the time to solve that issue.
(In reply to noghere from comment #93)
> You say to have fixed the bug. 

It has been fixed in version 18.  It will uplift in 12 weeks to the release channel.
(In reply to Honza Bambas (:mayhemer) from comment #94) 
> 
> It has been fixed in version 18.  It will uplift in 12 weeks to the release
> channel.

I have just downloaded Nightly v18 firefox-18.0a1.en-US.win64-x86_64.installer.exe and it has fixed the problem for me.

Phewww - it was a long wait, but I'm very pleased it's fixed - I posted back in comment 13.  Thanks to all involved (just wish I knew more programming so I could try my hand and assist).
Depends on: 801301
Depends on: 802316
Attachment #612148 - Attachment is obsolete: true
Blocks: 800701
This bug does NOT occur on Windows 7 32-bit or Windows 8 so far as I can tell.  Still occurring with FF 17.0 on Windows 7 64-bit with Windows 7 Basic theme.  Note: using AMD Catalyst drivers, don't have Nvidia on any systems so I can't test for that factor.
The first release where this patch landed was Firefox 18, so you are getting the expected result in Firefox 17. You can use beta or aurora or nightly if you want to try a version with this fix.
I was the author of comment 79 
Using the nightly 19 the bug has disappeared completely from all windows versions mentioned ( w7 x32, w7 x64, XP ) and has disappeared from both hardware (I7 2600k with hd3000 and e6800 dual core with nvidia fx5200)
I had it solid for years
Thank you
Setting VERIFIED on the basis of comment #95 and #98.

If you see this bug on Firefox/Thunderbird version 18.0a1 or later, SeaMonkey version 2.15a1 or later, *and* built after comment #91, please leave a comment describing in as much detail as you can what you see in which circumstances in which version of which program. If you have it, please paste the name and contents of the .txt file which accompanies on the ftp server the .zip, .installer.exe, .tar.bz2 or .dmg (etc.) which you used to install the program: that text file tells us exactly which version of the code you used.

Depending on circumstances, such "late sightings" may be reasons either to REOPEN this bug or to report a followup bug (but normally not both).
Status: RESOLVED → VERIFIED
Duplicate of this bug: 636242
Duplicate of this bug: 800701
Duplicate of this bug: 812084
No longer blocks: 800701
The reporter of bug 801813 still sees a bug where only the shadow of a context menu is visible.
FF 18.0 ---> FIXED.
Depends on: 844255
Depends on: 872466
You need to log in before you can comment on or make changes to this bug.