crash in _ZN7android33egl_get_image_for_current_contextEPv @ eglGetProcAddress on Gingerbread

RESOLVED WONTFIX

Status

()

Core
Graphics
--
critical
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: Scoobidiver (away), Assigned: snorp)

Tracking

({crash, reproducible})

Trunk
ARM
Android
crash, reproducible
Points:
---

Firefox Tracking Flags

(firefox15 wontfix, firefox16+ wontfix, firefox17+ wontfix, firefox18 wontfix, firefox19 wontfix, firefox20 wontfix, firefox36 wontfix, firefox37 wontfix, firefox38 wontfix, firefox39 wontfix, firefox40 wontfix, firefox41 wontfix, firefox42 wontfix, firefox43 wontfix, firefox44 wontfix, firefox45 wontfix, firefox46 affected, fennec+)

Details

(Whiteboard: [native-crash][startupcrash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Signature 	eglGetProcAddress More Reports Search
UUID	78d4c51c-a1f8-423c-a2c1-9f5da2120430
Date Processed	2012-04-30 07:31:13
Uptime	41
Last Crash	46 seconds before submission
Install Age	5.6 hours since version was first installed.
Install Time	2012-04-30 01:55:00
Product	FennecAndroid
Version	15.0a1
Build ID	20120429030504
Release Channel	nightly
OS	Linux
OS Version	0.0.0 Linux 2.6.35.11-I727RUXKJ7-CL646451 #2 SMP PREEMPT Sun Oct 30 04:59:00 KST 2011 armv7l
Build Architecture	arm
Build Architecture Info	
Crash Reason	SIGSEGV
Crash Address	0xdeadbaad
App Notes 	
EGL? EGL+ AdapterVendorID: qcom, AdapterDeviceID: SGH-I727R.
AdapterDescription: 'Android, Model: 'SGH-I727R', Product: 'SGH-I727R', Manufacturer: 'samsung', Hardware: 'qcom''.
GL Context? GL Context+ GL Layers? GL Layers+ WebGL? WebGL+ 
samsung SGH-I727R
samsung/SGH-I727R/SGH-I727R:2.3.5/GINGERBREAD/RUXKJ7:user/release-keys
EMCheckCompatibility	True

Frame 	Module 	Signature 	Source
0 	libc.so 	libc.so@0x16468 	
1 	libEGL.so 	eglGetProcAddress 	
2 	libutils.so 	_ZN7android10VectorImpl7_shrinkEjj 	
3 		@0xafd465e2 	
4 	libc.so 	libc.so@0x13e93 	
5 	libc.so 	libc.so@0x14d57 	
6 	libstdc++.so 	_ZdlPv 	
7 	libEGL.so 	_ZN7android33egl_get_image_for_current_contextEPv 	
8 	libEGL.so 	eglDestroyContext 	
9 	libEGL.so 	eglMakeCurrent 	
10 	libxul.so 	mozilla::gl::GLContextEGL::MakeCurrentImpl 	gfx/gl/GLLibraryEGL.h:148
11 	libxul.so 	mozilla::gl::GLContext::MakeCurrent 	GLContext.h:603
12 	libxul.so 	mozilla::gl::GLContextEGL::Init 	gfx/gl/GLContextProviderEGL.cpp:333
13 	libxul.so 	mozilla::gl::GLContextEGL::CreateEGLPBufferOffscreenContext 	gfx/gl/GLContextProviderEGL.cpp:1781
14 	libxul.so 	mozilla::gl::GLContextProviderEGL::CreateOffscreen 	gfx/gl/GLContextProviderEGL.cpp:1961
15 	libxul.so 	mozilla::WebGLContext::SetDimensions 	content/canvas/src/WebGLContext.cpp:527
16 	libxul.so 	nsHTMLCanvasElement::UpdateContext 	content/html/content/src/nsHTMLCanvasElement.cpp:652
17 	libxul.so 	nsHTMLCanvasElement::GetContext 	content/html/content/src/nsHTMLCanvasElement.cpp:573
18 	libxul.so 	nsIDOMHTMLCanvasElement_GetContext 	obj-firefox/js/xpconnect/src/dom_quickstubs.cpp:18007
19 	libxul.so 	js::Interpret 	js/src/jscntxtinlines.h:314
20 	libxul.so 	js::RunScript 	js/src/jsinterp.cpp:475
21 	libxul.so 	js::Execute 	js/src/jsinterp.cpp:674
22 	libxul.so 	JS_EvaluateUCScriptForPrincipalsVersionOrigin 	js/src/jsapi.cpp:5294
23 	libxul.so 	nsJSContext::EvaluateString 	dom/base/nsJSEnvironment.cpp:1458
...

More reports at:
https://crash-stats.mozilla.com/report/list?signature=eglGetProcAddress
The stack shows it's crashing during WebGL context creation. But the AppNotes say WebGL+ which means that a previous WebGL context had been successfully created. So, something went wrong only during the new context creation, the question is what.

The other weird thing is why is eglMakeCurrent calling eglDestroyContext? (frames 9 and 8).
Duplicate of this bug: 773765
This might be bug 774841.
(Reporter)

Updated

5 years ago
Crash Signature: [@ eglGetProcAddress] → [@ eglGetProcAddress] [@ _ZdlPv ]
Summary: crash in mozilla::gl::GLContextEGL::MakeCurrentImpl @ eglGetProcAddress → crash in _ZN7android33egl_get_image_for_current_contextEPv @ eglGetProcAddress
(Reporter)

Comment 4

5 years ago
(In reply to Jeff Gilbert [:jgilbert] from comment #3)
> This might be bug 774841.
If it's true, it should be uplifted to Beta because it's #12 top crasher in 15.0.
(Reporter)

Comment 5

5 years ago
With combined signatures, it's even #4 in 15.0.
tracking-firefox16: --- → ?
Depends on: 774841
Keywords: topcrash

Updated

5 years ago
Assignee: nobody → jgilbert
tracking-firefox16: ? → +

Comment 6

5 years ago
Jeff - when do you expect to start looking at this?
First off, this doesn't seem to be our bug, at least not based on the frames in the crash reports. It's likely us doing something the driver doesn't like. Notably, these seem to be all issues with WebGL context creation (Offscreen contexts), whereas the CreateForWindow contexts used by GL Layers work fine.

The frame dumps in the crash reports seem really obtuse to me, but here's an idea:

0 	libc.so 	libc.so@0x16468 	
1 	libEGL.so 	eglGetProcAddress 	
2 	libutils.so 	_ZN7android10VectorImpl7_shrinkEjj 	
3 		@0xafd465e2 	
4 	libc.so 	libc.so@0x13e93 	
5 	libc.so 	libc.so@0x14d57 	
6 	libstdc++.so 	_ZdlPv 	
7 	libEGL.so 	_ZN7android33egl_get_image_for_current_contextEPv 	
8 	libEGL.so 	eglDestroyContext 	
9 	libEGL.so 	eglMakeCurrent
10 	libxul.so 	mozilla::gl::GLContextEGL::MakeCurrentImpl 	gfx/gl/GLLibraryEGL.h:148

Inverted:
mozilla::gl:GLContextEGL::MakeCurrentImpl
  eglMakeCurrent
  eglDestroyContext
  android::egl_get_image_for_current_context(EGLContext)
  void::~void (?)
  ...
  ...
  android::VectorImpl::_shrink(size_t,size_t)
  eglGetProcAddress
  ...
  <crash>

Some things which could be problematic or are questionable:
[1] We don't MakeCurrent(Display(), NO_CONTEXT, NO_SURFACE, NO_SURFACE) before DestroySurface/Context.
[2] The driver may not like DestroyContext followed by DestroySurface of the surface that was attached to the context. (This is totally valid spec-wise, though)
[3] We do eglBindAPI relatively late (after eglChooseConfig) in CreateEGLPBufferOffscreenContext. 
[4] We don't ask for anything via EGL_CONFORMANT, only via EGL_RENDERABLE_TYPE.

While we should probably do [4], it's probably not going to help here. [1] might help with [2], but really shouldn't matter much here. A bug in the driver near [2] might explain the crash, but it wouldn't be something we can fix directly.

I think we should try [3]. My first thought here was that we should already be bound to GLES, but actually, many of the crash reports haven't initialized WebGL yet. Since we do OMTC with BasicLayers on Content thread, and OGLLayers only on OMTC thread, it's possible we haven't bound GLES as an API before.

One thing that might point to a driver issue similar to [2] is that MakeCurrent can give back an error if the EGLSurfaces we created for use by it were lazily allocated by the driver, and the driver realizes only at MakeCurrent that it doesn't have the resources to allocate the EGLSurface. This has a decent chance to cause a crash if there's a driver bug in regards to the EGLSurface handle being valid, but it containing null data, but being deleted anyways. What makes this unlikely is that it's hard to be low enough on resources that you can't alloc a 16x16 buffer, but it could be that the constraint is not memory but perhaps something else.

It seems like this crash is pretty prevalent across phones, too, which is both good and bad. We don't want to blacklist all these phones, but if all of them are having a similar issue, it should be the same problem. (or at least very similar to fix)

I'm trying to track down a Galaxy S2 to try to repro this with, but any phone on that list of crashes would be useful.
I've succeeded at getting a webgl-related crash by building beta and running it on an HTC Desire HD. Now to try things. :)
While I seem to be triggering a crash at times, I wasn't able to get it to reproduce. Marking qawanted to try to get a phone in MV known to reproduce this bug.

It also looks like this is also in 17 and 18, but the volume was low enough that there haven't been many reports.
Keywords: qawanted

Updated

5 years ago
status-firefox15: --- → affected
Devices listed in crashes
* Droid Incredible HD
* Galaxy SII (SGH-I727)
* HTC Rhyme
* Droid Incredible 2
* Desire HD
* Huawei M886 Glory
* T-Mobile myTouch 4G
* LG Revolution (VS910)
* Galaxy S Blaze 4G (SGH-T769)
* HTC Evo 4G
* Samsung Transform Ultra SPH-M930

The Droid Incredible 2, Droid Incredible HD and HTC Desire HD seem common from the 25 crashers I have looked at.
(Reporter)

Updated

5 years ago
Summary: crash in _ZN7android33egl_get_image_for_current_contextEPv @ eglGetProcAddress → crash in _ZN7android33egl_get_image_for_current_contextEPv @ eglGetProcAddress on Gingerbread
https://crash-stats.mozilla.com/report/index/1b39a35b-07ac-4d2a-8e26-7d8ae2120916
It looks like it might be reproducible on the HD Desire?  

URLs listed (I hope I removed all the NSFW Urls):
20 	about:home
20 	about:blank
2 	http://www.thexfactorusa.com/
2 	http://m.t-mobile.com/
2 	about:empty
2 	http://www.coliseodepuertorico.com/es/
2 	http://www.grantland.com/blog/hollywood-prospectus/post/_/id/57152/the-only-wort
1 	http://t.co/gFoklKYd
1 	http://www.google.com/search?hl=en&redir_esc=&client=ms-android-verizon&source=a
1 	http://m.facebook.com/l.php?u=http%3A%2F%2Fwww.mssongwritersfestival.com%2F&h=JA
1 	http://www.4life.com/default.aspx
1 	https://www.redwoodcu.org/
1 	http://www.npr.org/2012/09/11/160894364/how-to-get-birds-to-pick-blue-berries-th
1 	http://runkeeper.com/login
1 	http://trimet.org/stopsandstations/index.htm
1 	http://www.case-mate.com/?aff=5414&returnFull=1&gclid=CJHH1YKzrrICFUG8KgodeDcAhQ
1 	http://www.katu.com/
1 	http://www.otterbox.com/on/demandware.store/Sites-otterbox_us-Site?cid=MGOOTT12&
1 	http://coachesaid.com/forum.aspx?cat=289&forum=1692
1 	https://m.billfloat.com/signup/?biller=T-Mobile&external=d858cd8427a8e219c8086f1
1 	http://www.case-mate.com/?aff=5414&returnFull=1&gclid=CJqE9YLBrrICFec-Mgod4X8Alw
1 	https://m.vmp.intuit.com/?utm_source=vmp_landing_page#home
1 	http://m.t-mobile.com/unlimited-data-plan?cm_mmc_o=2q4%201BYzkfY%20m4mCjCmw5fwF_
1 	https://guardianproject.info/downloads/proxymob-addon-0.0.5.xpi
1 	http://www.amctv.com/the-walking-dead/videos/season-3-comic-con-trailer-the-walk
1 	http://www.mudramassage.net/
1 	http://m.t-mobile.com/phones
1 	http://ultimateears.logitech.com/en-us/home/7-Pro
1 	https://www.net313.caisse-epargne.fr/Pages/logout.aspx?ReturnUrl=%2fPortail.aspx
1 	https://weblogin.bu.edu//web@login3?jsv=1.5p&br=un&fl=0
1 	https://www.google.com/m?q=t-mobile.com&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:e
1 	http://www.goodreads.com/book/show/7797874-return-to-paradise
1 	http://www.otterbox.com/armor-series/armor-series,default,pg.html
1 	http://rule34.paheal.net/post/list
1 	http://ureddit.com/c59115
1 	http://www.google.com/search?hl=en&redir_esc=&client=ms-android-att-us&source=an
1 	http://www.avvo.com/legal-answers/painted-aluminum-panels-to-replicate-world-war
1 	http://www.highlandvillage.org/index.aspx?NID=116
1 	http://m.facebook.com/l.php?u=http%3A%2F%2Fwww.expedia.co.jp%2F&h=_AQFhBJui&s=1
1 	http://m.facebook.com/l.php?u=http%3A%2F%2Fpdnpulse.com%2F2012%2F09%2Fphotokina-
1 	http://www.virginmobileusa.com/
1 	http://mwsu.mobi/
1 	http://www.google.com/search?q=2.4.3+be+priest+racials&hl=en&gs_l=mobile-heirloo
1 	http://www.npr.org/2012/09/12/160989062/u-s-ambassador-to-libya-killed-in-attack
1 	http://www.dairyqueen.com/us-en/mobile/
1 	http://www.npr.org/2012/09/15/161200943/obama-polishes-his-regular-guy-image-wit
1 	http://t.co/aGnWVHTG
1 	http://www.toyscenter.it/
1 	http://m.t-mobile.com/home/account
1 	https://www.google.com/search?q=the+walking+dead+season+2+episode+1&oe=utf-8&rls
1 	http://www.highlandvillage.org/index.aspx?nid=151
1 	http://social.technet.microsoft.com/Forums/en/itprovistasetup/thread/8514464a-11
1 	https://www.google.com/search?q=html5test&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla
1 	https://www.google.com/search?q=daniel+trock&ie=utf-8&oe=utf-8&aq=t&rls=org.mozi
1 	http://tedmccagg.typepad.com/drawings/2012/09/best-word-ever-final.html
1 	http://www.expedia.com/MobileHotel
1 	http://m.otterbox.com/on/demandware.store/Sites-otterbox_us-Site/default/mHome-S
1 	https://www.ageofchampions.com/game/?fb_source=canvasbookmark&count=46
1 	http://shop.nordstrom.com/S/pisarro-nights-beaded-mesh-gown/3255479?origin=categ
1 	https://www.google.com/search?q=html+5+test&ie=utf-8&oe=utf-8&aq=t&rls=org.mozil
1 	http://www.amandapalmer.net/category/blog/
1 	http://www.katu.com/mobile-override?view=web
1 	https://m.billfloat.com/signup/?biller=Sprint&external=d3abe38a21eca6274cdf4da95
1 	http://9to5mac.com/2012/09/12/sprint-and-verizon-clarify-iphone-5-plans-sprint-p
1 	http://www.google.com/search?hl=en&redir_esc=&client=ms-android-sprint-us&source
1 	http://m.hollisterco.com/webapp/wcs/stores/servlet/CategoryDisplay?catalogId=102
1 	http://www.google.com/custom?hl=en&safe=images&client=pub-0192814012836577&cof=F
1 	http://www.npr.org/2012/09/04/160258240/children-succeed-with-character-not-test
1 	http://m.t-mobile.com/unlimited-data-plan?cm_mmc_o=2q4%201BYzkfY%20m4mCjCmw5fwF_
1 	https://www.google.com/search?q=breaking+bad&ie=utf-8&oe=utf-8&aq=t&rls=org.mozi
1 	http://www.npr.org/2012/09/11/160252399/fidelity-in-fiction-junot-diaz-deconstru
1 	https://starbucks.cashstar.com/gift-card/view/DMigoEPF6LtFLpv?utm_source=msr&utm
1 	http://www.google.com/search?hl=en&q=mozilla+labs&revid=1978429419&sa=X&ei=4WNSU
1 	http://m.mstarz.com/articles/4714/20120910/adam-sandler-died-ridiculous-celebrit
1 	http://www.real.de/startseite.html
Kevin noticed that some of the URL are cut.  It appears that there's a 85 character limit for each url line.  Reporting a separate socorro bug.
Crashed when going to http://t.co/aGnWVHTG from cold start.
After getting crash and selecting restart, it went to the website.
Also occurs after typing in the http://www.real.de/startseite.html as well as 
http://www.toyscenter.it/ in the url bar.  This is for HTC Desire HD running FF on Android 16b.

01-06 11:00:16.476: E/GeckoConsole(2756): [JavaScript Warning: "Expected media feature name but found 'modernizr'." {file: "http://www.real.de/startseite.html" line: 1}]
01-06 11:00:17.007: D/Zygote(1251): Process 2756 terminated by signal (11)
01-06 11:00:17.017: W/ContentService(1360): binderDied() at ObserverNode name org.mozilla.firefox_beta.db.browser
01-06 11:00:17.017: I/ActivityManager(1360): Process org.mozilla.firefox_beta (pid 2756) has died.
01-06 11:00:17.017: I/WindowManager(1360): WIN DEATH: Window{40adbf08 org.mozilla.firefox_beta/org.mozilla.firefox_beta.App paused=false}
01-06 11:00:17.027: W/ContentService(1360): binderDied() at ObserverNode name bookmarks
01-06 11:00:17.027: W/ContentService(1360): binderDied() at ObserverNode name bookmarks
01-06 11:00:17.027: D/SensorGUI(1360): ~SensorChannel: mSendFd = 250, mReceiveFd = -1
01-06 11:00:17.027: I/WindowManager(1360): WIN DEATH: Window{40b0d968 SurfaceView paused=false}
Keywords: qawanted → reproducible
I have an HTC Desire HD and I can reproduce a crash when navigating to http://www.real.de/startseite.html, but not http://www.toyscenter.it

the stack looks like this:

Program received signal SIGILL, Illegal instruction.
[Switching to Thread 3161]
0x4f2612d4 in ?? ()
Loading symbols... Done
(gdb) bt
#0  0x4f2612d4 in ?? ()
#1  0xffffff84 in ?? ()
#2  0xffffff84 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
Based on this dump, this bug is a dupe of bug 791462

(gdb) x/20i $pc-40
   0x4f2612ac:	b	0x4f2612c0
   0x4f2612b0:	movw	r7, #57408	; 0xe040
   0x4f2612b4:	movt	r7, #20967	; 0x51e7
   0x4f2612b8:	ldr	r7, [r7]
   0x4f2612bc:	mov	r8, #1
   0x4f2612c0:	push	{pc}		; (str pc, [sp, #-4]!)
   0x4f2612c4:	blx	r7
   0x4f2612c8:	sub	sp, sp, #12
   0x4f2612cc:	b	0x4f261300
   0x4f2612d0:	add	sp, sp, #24
=> 0x4f2612d4:	push	{sp}		; (str sp, [sp, #-4]!)
   0x4f2612d8:	mov	r12, #1
   0x4f2612dc:	push	{r12}		; (str r12, [sp, #-4]!)
   0x4f2612e0:	push	{r5}		; (str r5, [sp, #-4]!)
   0x4f2612e4:	mov	r12, #928	; 0x3a0
   0x4f2612e8:	push	{r12}		; (str r12, [sp, #-4]!)
   0x4f2612ec:	movw	r12, #63488	; 0xf800
   0x4f2612f0:	movt	r12, #20261	; 0x4f25
   0x4f2612f4:	push	{pc}		; (str pc, [sp, #-4]!)
   0x4f2612f8:	blx	r12
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 791462
(Reporter)

Comment 17

5 years ago
(In reply to Mark Finkle (:mfinkle) from comment #16)
> Based on this dump, this bug is a dupe of bug 791462
I am surprised because this bug happens in 15.0 and above while bug 791462 is a regression in 18.0.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(In reply to Scoobidiver from comment #17)
> (In reply to Mark Finkle (:mfinkle) from comment #16)
> > Based on this dump, this bug is a dupe of bug 791462
> I am surprised because this bug happens in 15.0 and above while bug 791462
> is a regression in 18.0.

In which case we'll need to test this again with bug 791492 fixed. Right now, it is masking any other crash.
I rebuilt Fennec with the fix from bug 791492 and I no longer crash at all on http://www.real.de/startseite.html

I tested with HTC Desire HD running Android 2.3.5

Looking at crash-stats, I don't see this signature in fx18 and fx17. I see something that could be it at #74 on fx16 and at #15 on fx15.
(Reporter)

Comment 20

5 years ago
(In reply to Mark Finkle (:mfinkle) from comment #19)
> I see something that could be it at #74 on fx16 and at #15 on fx15.
With both signatures, it's #4 top crasher in 15.0.1 and #43 in 16.0b3 (will be higher in 16.0b4 with bug 774622 fixed).
(In reply to Jeff Gilbert [:jgilbert] from comment #9)
> While I seem to be triggering a crash at times, I wasn't able to get it to
> reproduce. Marking qawanted to try to get a phone in MV known to reproduce
> this bug.
> 
> It also looks like this is also in 17 and 18, but the volume was low enough
> that there haven't been many reports.

mfinkle has been able to reproduce - can you sync up with him and figure out a plan forward here?
status-firefox16: --- → wontfix
tracking-firefox17: --- → +
Jeff - any luck following up with Mark on this?
Flags: needinfo?(jgilbert)

Updated

5 years ago
Whiteboard: [native-crash] → [native-crash][startupcrash]
We'll still take a fix on this reproducible crash, but Jeff doesn't have bandwidth right now to work on this and it's #34 on 16.0.1 and #181 on 17.0b3 so we're going to remove tracking.
Assignee: jgilbert → jpr
tracking-firefox17: + → -
(Reporter)

Comment 24

5 years ago
(In reply to Lukas Blakk [:lsblakk] from comment #23)
> it's #34 on 16.0.1 and #181 on 17.0b3 so we're going to remove tracking.
With both signatures, there are 1346 crashes in 16.0.1 (#10 top crasher) and 68 crashes in 17.0b2 (#31 top crasher) so it's still a top crasher. The difference in ranking is likely due to the difference between Release and Beta populations. Thus, it has a good chance to be around #10 top crasher in 17.0.
tracking-firefox17: - → ?
We can track, but this crash has been in the build since FF15 without any action taken thus far. Whether or not this actually gets fixed in FF16 is up to JP finding somebody who has the time to work on this.
tracking-firefox17: ? → +

Comment 26

5 years ago
Benoit, can you take a poke to see how serious this is for 17?
Assignee: jpr → bjacob
I am already busy with bug 806369 and then I should get back to my B2G bug, 775469. I can do this later this week but if this needs urgent action, you may want someone else.
I'll be busy until the end of this week. I can work on this early next week.
I'm trying to reproduce it on the HTC Desire HD
status-firefox17: --- → affected
status-firefox18: --- → unaffected
status-firefox19: --- → unaffected
.. and I'm unable to reproduce it. (I was using a local build from the latest mozilla-beta code)
Given the lack of reproducibility at this stage, we have to wontfix for 17.
status-firefox17: affected → wontfix

Comment 32

5 years ago
This is still around but not in topcrash ranks any more.
Keywords: topcrash
(Reporter)

Comment 33

5 years ago
It's #4 top crasher in 19.0 for ARMv6 devices so that qualifies it for the topcrash keyword.

Here are affected devices (more than 3 over the last day):
* _ZdlPv 	61
Sony Ericsson LT26i (Xperia S) 	11
PANTECH PantechP9070 (Burst)	7
LGE LG-VM696 (Optimus Elite)	5
Samsung GT-S7500L (Galaxy Ace Plus)	4
Samsung GT-S7500 (Galaxy Ace Plus) 	4
Motorola XT615 (Motosmart Plus) 	3
Samsung GT-I9001 (Galaxy S Plus)	3
Samsung GT-S6500D (Galaxy Mini 2) 	3

* libstdc++.so@0x9cd 	50
Samsung GT-I9100 (Galaxy SII)	10
Sony Ericsson LT26i (Xperia S) 	3
LGE LG-E510f 	3

* eglGetProcAddress 	39
Samsung SGH-T989 (Galaxy SII Plus)	15
Samsung SGH-T769 (Galaxy S Blaze)	8
Samsung SGH-I727 (Galaxy SII Skyrocket)	4
Samsung SGH-I717 (Galaxy Note LTE)	3
HUAWEI T-Mobile myTouch 	3

More reports at:
https://crash-stats.mozilla.com/report/list?signature=_ZdlPv
https://crash-stats.mozilla.com/report/list?signature=libstdc%2B%2B.so%400x9cd
https://crash-stats.mozilla.com/report/list?signature=eglGetProcAddress
Crash Signature: [@ eglGetProcAddress] [@ _ZdlPv ] → [@ eglGetProcAddress] [@ _ZdlPv ] [@ libstdc++.so@0x9cd ]
status-firefox18: unaffected → affected
status-firefox19: unaffected → affected
status-firefox20: --- → affected
Keywords: topcrash
(Reporter)

Comment 34

5 years ago
It's #34 crasher in 21.0 and #13 for ARMv6 devices only.
Keywords: topcrash
Removing needinfo. This is currently assigned to bjacob, but I think he's probably not working on it. Something similar is still happening according to crash reports, so if someone has one of these devices and can confirm reproducibility, I might be able to take a look.
Flags: needinfo?(jgilbert)
Indeed, I'm not working on it.
Assignee: bjacob → nobody
I am able to reproduce this crash on Samsung Galaxy R (Android 2.3.4) with Firefox for Android 36.a01 (2014-11-18)
Steps:
1. Go to http://www.intel.com/museumofme/r/index.htm;
2. Tap on 'Tap here to activate plugin";
3. Tap on 'Play' button.
Reproducible on latest Nightly 38.0a1 (2015-01-19) and latest Aurora 37.0a2 (2015-01-19) with steps from comment 37.
Device: Samsung Galaxy R (Android 2.3.4)
status-firefox36: --- → affected
status-firefox37: --- → affected
status-firefox38: --- → affected
Created attachment 8569032 [details]
log.txt
(In reply to Teodora Vermesan (:TeoVermesan) from comment #39)
> Created attachment 8569032 [details]
> log.txt

I've attached the logs while trying to play flash videos and firefox crashes.
On HTC Desire HD (Android 2.3.5) Firefox crashes on all branches with steps from comment 38 and also 
while trying to play youtube desktop site videos and vplay.ro videos.
Here is the crash-report: https://crash-stats.mozilla.com/report/index/14c9dbde-d683-469c-beb2-104032150225
Is it this bug, or fill another one?

Note:
- 37 Beta 1 crashes with steps from comment 38 on Samsung Galaxy R (Android 2.3) and HTC Desire S (Android 2.3)

Updated

3 years ago
status-firefox39: --- → affected
Fennec crashes every time you try to play a flash video on Gingerbread devices:
https://crash-stats.mozilla.com/report/index/14c9dbde-d683-469c-beb2-104032150225

I believe that we should track this for a feature release.
tracking-fennec: --- → ?
(In reply to Catalin Suciu from comment #41)
> Fennec crashes every time you try to play a flash video on Gingerbread
> devices:
> https://crash-stats.mozilla.com/report/index/14c9dbde-d683-469c-beb2-
> 104032150225
> 
> I believe that we should track this for a *future release.
Catalin, does it happen with 36.0.2 build 2 (as we took bug 1118216)
Thanks
Flags: needinfo?(catalin.suciu)
Yes, this crash affects all versions, including 36.0.2 build 2 and does not seem to be related to bug 1118216. 
This is specific to Gingerbread devices.
Flags: needinfo?(catalin.suciu)
Snorp will investigate. If this is not an easy fix, we'll likely block Flash on Gingerbread.
Assignee: nobody → snorp
tracking-fennec: ? → +

Updated

3 years ago
status-firefox40: --- → affected

Updated

2 years ago
status-firefox41: --- → affected
status-firefox42: --- → affected

Updated

2 years ago
status-firefox43: --- → affected
status-firefox44: --- → affected
This showed up 723 times for Fennec 41.0.2 last week. Snorp, have you made any progress on this issue?
status-firefox15: affected → wontfix
status-firefox18: affected → wontfix
status-firefox19: affected → wontfix
status-firefox20: affected → wontfix
status-firefox36: affected → wontfix
status-firefox37: affected → wontfix
status-firefox38: affected → wontfix
status-firefox39: affected → wontfix
status-firefox40: affected → wontfix
status-firefox41: affected → wontfix
Flags: needinfo?(snorp)
So this bug was filed with a crash when creating a GLContext for WebGL, but now it's somehow about a Flash crash? What's going on? The report in comment 41 is nothing like the original one. I can try to look at the Flash stuff next week, though.
Flags: needinfo?(snorp)
I filled bug #1227074 for the crashes reported in comment #40 and comment #41
Is this bug still relevant given we're dropping support for Gingerbread?
status-firefox42: affected → wontfix
status-firefox43: affected → wontfix
status-firefox44: affected → wontfix
status-firefox45: --- → wontfix
status-firefox46: --- → affected
Flags: needinfo?(snorp)
Nope.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago2 years ago
Flags: needinfo?(snorp)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.