Last Comment Bug 750264 - Give IDLType an operator!=
: Give IDLType an operator!=
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Boris Zbarsky [:bz]
:
Mentors:
: 742150 (view as bug list)
Depends on: 742145
Blocks: 748266
  Show dependency treegraph
 
Reported: 2012-04-30 07:41 PDT by Boris Zbarsky [:bz]
Modified: 2012-05-24 22:11 PDT (History)
1 user (show)
bzbarsky: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Give IDLType an operator!= so that codegen actually works correctly. (1.60 KB, patch)
2012-04-30 07:42 PDT, Boris Zbarsky [:bz]
khuey: review+
Details | Diff | Splinter Review

Description Boris Zbarsky [:bz] 2012-04-30 07:41:19 PDT
It already has an operator==, but I'm using != on it.
Comment 1 Boris Zbarsky [:bz] 2012-04-30 07:42:47 PDT
Created attachment 619558 [details] [diff] [review]
Give IDLType an operator!= so that codegen actually works correctly.
Comment 2 Boris Zbarsky [:bz] 2012-04-30 19:00:52 PDT
Looks like this needs to be applied on top of the patch in bug 742145.
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-04-30 19:36:31 PDT
*** Bug 742150 has been marked as a duplicate of this bug. ***
Comment 4 Boris Zbarsky [:bz] 2012-05-24 22:11:25 PDT
http://hg.mozilla.org/mozilla-central/rev/846a1c3abadc

Note You need to log in before you can comment on or make changes to this bug.