Update about:license to give link to Hg rev and build instructions

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
a year ago

People

(Reporter: gerv, Assigned: gerv)

Tracking

Details

Attachments

(1 attachment, 2 obsolete attachments)

See bug 749312 - it would be convenient to stop having to ship tarballs of source on our FTP server. This in no way changes Mozilla's commitment to provide source to its products - it's just that tarballs of each version are a very inefficient way of doing it, and the MPL 2 has been given additional flexibility over MPL 1.1 that we should take advantage of.

The MPL 2's requirements on this are in sections 3.1 and 3.2. By design :-), they are not onerous to comply with.

3.2: "You must inform recipients of the Executable Form how they can obtain a copy of such Source Code Form by reasonable means in a timely manner, at a charge no more than the cost of distribution to the recipient". 

At the bottom of the About box, we link to "Licensing Information", which takes you to about:license. We should update the blurb at the top of about:license to give the necessary Hg URL alongside the download instructions. That meets MPL 2's requirements.

Gerv

Updated

7 years ago
Blocks: 747168
Created attachment 619594 [details] [diff] [review]
Patch v.1

Here's a patch.

Gerv
Comment on attachment 619594 [details] [diff] [review]
Patch v.1

Requesting sanity check from Luis.

Gerv
Attachment #619594 - Flags: review?(villalu)
Summary: Update about:license to link to about:buildconfig → Update about:license to give link to Hg rev and build instructions
Comment on attachment 619594 [details] [diff] [review]
Patch v.1

Review of attachment 619594 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/content/license.html
@@ +34,5 @@
>         <a href="http://www.gnu.org/philosophy/free-sw.html">free</a> and 
>         <a href="http://www.opensource.org/docs/definition.php">open source</a>.
> +#ifdef SOURCE_REPO
> +#ifdef SOURCE_CHANGESET
> +The specific source code is identified by the URL <a href="@SOURCE_REPO@/rev/@SOURCE_CHANGESET@">@SOURCE_REPO@/rev/@SOURCE_CHANGESET@</a>,

I would say "specific source code _for this product_." Otherwise, looks good.

Comment 5

7 years ago
https://hg.mozilla.org/mozilla-central/rev/9ebceb5cac17
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 6

7 years ago
Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/15.0 Firefox/15.0a1
2012-05-03 Nightly

There are 2 problems here:

1. You've added a random "h" to the beginning of about:license.
2. This patch doesn't actually work (at least, I don't see anything from the #ifdef block).

As this is more than a text change it should have a code review as well.

I think this should be backed out until a new patch has been created and properly reviewed.
AIUI, you may not necessarily see anything in a self-built build; it may be that those params are only defined for more official builds. I used the code from about:buildconfig. Do you see an Hg URL there? If you do, but not one in about:license, then it's broken.

Do jump on to IRC to chat about it. I'm not opposed to backing it out, but I want to make sure it's actually broken first :-)

The "h" is clearly a mistake, easily fixed.

Gerv

Comment 8

7 years ago
(In reply to Gervase Markham [:gerv] from comment #7)
> AIUI, you may not necessarily see anything in a self-built build; it may be
> that those params are only defined for more official builds. I used the code
> from about:buildconfig. Do you see an Hg URL there? If you do, but not one
> in about:license, then it's broken.

Yes, in about:buildconfig is see: "Built from http://hg.mozilla.org/mozilla-central/rev/807403a04a6a"

This is Nightly build from Mozilla (see "2012-05-03 Nightly" in comment 6), not self-built.
Hmm. Clearly the preprocessor does not work as simply as I thought. 

I would back it out, but mozilla-inbound is currently closed. In the mean time, I'll try and get it working.

Gerv
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
See also bug 751599.

Gerv

Updated

7 years ago
Depends on: 754912

Comment 11

7 years ago
(In reply to Gervase Markham [:gerv] from comment #7)
> AIUI, you may not necessarily see anything in a self-built build; it may be
> that those params are only defined for more official builds. I used the code
> from about:buildconfig. Do you see an Hg URL there? If you do, but not one
> in about:license, then it's broken.
> 
> Do jump on to IRC to chat about it. I'm not opposed to backing it out, but I
> want to make sure it's actually broken first :-)
> 
> The "h" is clearly a mistake, easily fixed.
> 
> Gerv

Bug 754912 fixed the "h" problem. I still think that this should be backed out because it is unreviewed and doesn't work.
Created attachment 634466 [details] [diff] [review]
Patch v.2

Here is a version which does not require the preprocessor. That's much better than nothing, and avoids the tarpit that is bug 751599.

Gerv
Attachment #619594 - Attachment is obsolete: true
Attachment #619594 - Flags: review?(villalu)
Attachment #634466 - Flags: review?(djcater+bugzilla)
Created attachment 752779 [details] [diff] [review]
Patch v.3

Unbitrotted. djcater seems to have gone. This patch no longer contains a code component, so I am just going to check it in.

Gerv
Attachment #634466 - Attachment is obsolete: true
Attachment #634466 - Flags: review?(djcater+bugzilla)
https://hg.mozilla.org/mozilla-central/rev/d742d927b9e8
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.