If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Implement tests for on-wire update format

RESOLVED FIXED

Status

()

Toolkit
Safe Browsing
P3
normal
RESOLVED FIXED
6 years ago
8 months ago

People

(Reporter: gcp, Assigned: tnguyen)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
UrlClassifier / SafeBrowsing tests currently rely for a large part on a custom format for inserting updates for testing. This is very brittle, as illustrated by bug 744993.

The initial code was written and contributed by Google, which presumably could test against their own server. We no longer have that luxury.

We should make a testing setup that is capable of feeding "real" updates to the browser and test on that. This will included a minimal implementation of a SafeBrowsing protocol server.
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
Let's do this in the V4 tests.
Blocks: 1167038
Priority: -- → P5
Assignee: nobody → hchang
Status: NEW → ASSIGNED
Assignee: hchang → nobody
Status: ASSIGNED → NEW
Priority: P5 → P3
(Assignee)

Updated

a year ago
Assignee: nobody → tnguyen
This is the approach we are talking for all new unit tests (including all of the V4 unit tests). We will not re-do the existing V2 tests though.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → FIXED
Duplicate of this bug: 406634
You need to log in before you can comment on or make changes to this bug.