<em:updateLink> for firefox-hotfix@mozilla.org points to file with Length: 0

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
API
--
major
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: MattN, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

Created attachment 620004 [details]
wget output for updateLink URLs (2)

VersionCheck.php for firefox-hotfix@mozilla.org is pointing to a URL which returns no content (Length: 0). We've waited more than 30 minutes but I'm not sure how long it normally takes to roll out a new version.

The em:updateLink initially was:
https://addons.mozilla.org/_files/354399/mozilla_firefox_hotfix-20120430.01-fx-windows.xpi

and then it changed to:
http://releases.mozilla.org/pub/mozilla.org/addons/354399/mozilla_firefox_hotfix-20120430.01-fx-windows.xpi

Responses for both had length: 0. (see attached wget output)

URL field has the VersionChech.php address.

Updated

6 years ago
Severity: major → critical
Looking at the files on disk they are zero length files.  This isn't something that will recover itself - you'll need to re-upload the .xpis.  We can coordinate the timing if you want me to watch the files on disk.
Severity: critical → major

Comment 2

6 years ago
I've redownloaded the XPI from bugzilla, reuploaded the XPI after confirming it was the correct size, then redownloaded the XPI from AMO and it was 0-length.
Lots of talk about this on IRC.  The summary is that I tried it and it worked.  I don't know what the problem was.  If it happens again, let us know, of course.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.