Closed Bug 750903 (metro-browser) Opened 8 years ago Closed 7 years ago

Review and land browser/* metro related code on mc

Categories

(Firefox for Metro Graveyard :: General, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jimm, Assigned: jimm)

References

Details

(Whiteboard: [completed-elm][metro-it2])

Attachments

(1 file, 5 obsolete files)

No description provided.
Summary: Fork fennec XUL front end code into /browser integrate with Fx's build → Fork fennec XUL front end code into /browser and integrate with Fx's build
This bug can also include the metro related work we've done for os registration -

http://mxr.mozilla.org/projects-central/source/elm/mobile/xul/metro/
Depends on: metro-build
Assignee: nobody → jmathies
Attached patch file copies patch (obsolete) — Splinter Review
Attached patch new files patch (obsolete) — Splinter Review
Attached patch misc changes patch (obsolete) — Splinter Review
Attached patch misc changes patch (obsolete) — Splinter Review
Attachment #627493 - Attachment is obsolete: true
Blocks: 756580
Attached patch misc changes patch (obsolete) — Splinter Review
Attachment #627503 - Attachment is obsolete: true
Whiteboard: completed-elm
No longer depends on: metro-build
Product: Firefox → Firefox for Metro
No longer blocks: 756580
Assignee: jmathies → nobody
Summary: Fork fennec XUL front end code into /browser and integrate with Fx's build → Review and land browser/* metro related code on mc
Whiteboard: completed-elm → [completed-elm][metro-it2]
Depends on: 756580
Resolving bugs in the Firefox for Metro product that are fixed on the elm branch.  Sorry for the bugspam.  Search your email for "bugspam-elm" if you want to find and delete all of these messages at once.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Alias: metro-browser
Attached patch patchSplinter Review
This will be refreshed to elm tip before the final checkin.
Assignee: nobody → jmathies
Attachment #627491 - Attachment is obsolete: true
Attachment #627492 - Attachment is obsolete: true
Attachment #627514 - Attachment is obsolete: true
Attachment #712440 - Flags: review?(mbrubeck)
Attachment #712440 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/mozilla-central/rev/a85a2ddb41bf
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Blocks: 840888
No longer blocks: 840888
Note for future historians:  This code was originally developed on the "elm" disposable project branch.  We did not merge the full history into mozilla-central because much of it was not very clean and because of merge problems caused by hg copy relationships on elm, but you can find the complete history preserved here:

http://hg.mozilla.org/users/mbrubeck_mozilla.com/elm-metro-firefox/
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.