Move pan/zoom logic in browser.js to a shareable location in Gecko

RESOLVED DUPLICATE of bug 750977

Status

()

Core
General
RESOLVED DUPLICATE of bug 750977
6 years ago
6 years ago

People

(Reporter: cjones, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

The goal is to make the logic that lives on the content thread not specific to any frontend.  That means that the code to set the displayport etc. has to live in gecko proper.

By the end of this work, all the current logic that lives in the native-fennec frontend browser.js should be in gecko, and the old code should be removed, without regressing the native-fennec frontend.
The initial work will done by bug 750977.  We'll be able to build on that piecemeal.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 750977
You need to log in before you can comment on or make changes to this bug.