Closed Bug 745136 Opened 8 years ago Closed 3 years ago

Tracking: Port asynchronous pan/zoom code to generic Gecko C++

Categories

(Core :: Widget, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: cjones, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [technical-debt])

We have generic code for async panning/zooming in platform-specific and frontend-specific locations right now.  The only change we have to sanely maintain that code is to centralize it and let platforms/frontends twiddle shared configuration params.

This is likely to be a tracking bug itself.  We'll see what this entails.
It would also be nice to have the async pan/zoom code use async layers animation support instead of hand-interpolating animations.
Duplicate of this bug: 723373
Summary: Port asynchronous pan/zoom code to generic Gecko C++ → Tracking: Port asynchronous pan/zoom code to generic Gecko C++
blocking-basecamp: --- → +
blocking-kilimanjaro: --- → +
Is this the bug which is tracking the pinch-to-zoom which will be used for mozbrowser iframes? If so, what's the progress on this?

Also, is there an implementation of double-tapping to zoom in on particular elements in here somewhere or is that a separate bug?
Depends on: 776149
Depends on: 776310
Depends on: 776226
Depends on: 776413
Depends on: 777264
Depends on: 780335
Depends on: 780395
Depends on: 780397
Please nom individual bugs since the general work has landed.
blocking-basecamp: + → ---
blocking-kilimanjaro: + → ---
I'm going to nom this so we ensure all blockers are basecamp+'d/basecamp-'d at the next triage session.  Then we'll remove this nom since it's a tracker bug and shouldn't be a blocker.
blocking-basecamp: --- → ?
blocking-basecamp: ? → ---
Depends on: 786271
No longer blocks: 786267
Depends on: 786267
Depends on: 786282
Depends on: 823066
Depends on: 824511
Depends on: 826489
Blocks bug 830750 as a 2013 Platform Goal to unify platform technologies and reduce technical debt.
Blocks: 830750
Depends on: 834010
Blocks: 688990
I think this can be closed, the async pan/zoom code is living in C++ now.
Status: NEW → RESOLVED
Closed: 3 years ago
No longer depends on: apz-fennec
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.