Last Comment Bug 751273 - Rip out cairo+pixman from libxul
: Rip out cairo+pixman from libxul
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: :Ehsan Akhgari
:
Mentors:
Depends on: 751521
Blocks: 750661
  Show dependency treegraph
 
Reported: 2012-05-02 11:32 PDT by :Ehsan Akhgari
Modified: 2012-05-03 04:27 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Part 1: Take out the debugging code which we no longer use (3.96 KB, patch)
2012-05-02 11:33 PDT, :Ehsan Akhgari
jmuizelaar: review+
Details | Diff | Splinter Review
Part 2: Split out cairo+pixman into gkmedias.dll (8.68 KB, patch)
2012-05-02 12:49 PDT, :Ehsan Akhgari
ted: review+
Details | Diff | Splinter Review
Part 2: Split out cairo+pixman into gkmedias.dll (8.86 KB, patch)
2012-05-02 14:05 PDT, :Ehsan Akhgari
ted: review+
Details | Diff | Splinter Review
Part 2: Split out cairo+pixman into gkmedias.dll (12.41 KB, patch)
2012-05-02 14:33 PDT, :Ehsan Akhgari
no flags Details | Diff | Splinter Review
Part 2: Split out cairo+pixman into gkmedias.dll (12.97 KB, patch)
2012-05-02 15:10 PDT, :Ehsan Akhgari
khuey: review+
Details | Diff | Splinter Review

Description :Ehsan Akhgari 2012-05-02 11:32:53 PDT
+++ This bug was initially created as a clone of Bug #750747 +++

cairo+pixman needs to go outside of libxul, too!
Comment 1 :Ehsan Akhgari 2012-05-02 11:33:34 PDT
Created attachment 620396 [details] [diff] [review]
Part 1: Take out the debugging code which we no longer use
Comment 2 :Ehsan Akhgari 2012-05-02 12:49:36 PDT
Created attachment 620431 [details] [diff] [review]
Part 2: Split out cairo+pixman into gkmedias.dll
Comment 3 :Ehsan Akhgari 2012-05-02 13:29:40 PDT
Landed the first part: https://hg.mozilla.org/integration/mozilla-inbound/rev/a642269f01a2
Comment 4 :Ehsan Akhgari 2012-05-02 13:32:56 PDT
And the second part: https://hg.mozilla.org/integration/mozilla-inbound/rev/27c51f14c3ed
Comment 5 :Ehsan Akhgari 2012-05-02 13:47:35 PDT
Backed out the last part because of build bustage: https://hg.mozilla.org/integration/mozilla-inbound/rev/070534825e25
Comment 6 :Ehsan Akhgari 2012-05-02 14:05:09 PDT
Created attachment 620464 [details] [diff] [review]
Part 2: Split out cairo+pixman into gkmedias.dll

This version of the patch actually does compile!
Comment 7 :Ehsan Akhgari 2012-05-02 14:33:48 PDT
Created attachment 620471 [details] [diff] [review]
Part 2: Split out cairo+pixman into gkmedias.dll

This should work on Linux as well, I'll request review when my build finishes.
Comment 8 :Ehsan Akhgari 2012-05-02 15:10:31 PDT
Created attachment 620482 [details] [diff] [review]
Part 2: Split out cairo+pixman into gkmedias.dll

Note You need to log in before you can comment on or make changes to this bug.