Last Comment Bug 751355 - Linux and Fennec profiling builds should be built with disable elfhack and not strip symbols
: Linux and Fennec profiling builds should be built with disable elfhack and no...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Gecko Profiler (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Benoit Girard (:BenWa)
:
:
Mentors:
: 749521 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 13:58 PDT by Benoit Girard (:BenWa)
Modified: 2012-05-25 10:51 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.58 KB, patch)
2012-05-02 13:58 PDT, Benoit Girard (:BenWa)
ted: review-
Details | Diff | Splinter Review
patch v2 (1.64 KB, patch)
2012-05-04 10:07 PDT, Benoit Girard (:BenWa)
ted: review+
Details | Diff | Splinter Review

Description Benoit Girard (:BenWa) 2012-05-02 13:58:38 PDT
Created attachment 620462 [details] [diff] [review]
patch

This will let us pull the symbols from the link cache on android when profiling and along with bug 751034 be able to profile tinderbox profiling nightly builds.
Comment 1 Ted Mielczarek [:ted.mielczarek] 2012-05-04 08:27:19 PDT
Comment on attachment 620462 [details] [diff] [review]
patch

Review of attachment 620462 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +1960,5 @@
>      MOZ_PROFILING=1,
>      MOZ_PROFILING= )
>  
> +# For profiling builds keep the symbol information
> +if test "$MOZ_PROFILING" -a -n "$STRIP_FLAGS"; then

Did you mean '-z "$STRIP_FLAGS"'; here? As written this won't do anything unless STRIP_FLAGS is already set.

@@ +7468,5 @@
>      USE_ELF_HACK=,
>      USE_ELF_HACK=1)
>  
> +# Disable elf hack for profiling because the built in profiler
> +# doesn't read the segments properly with elf hack.

Is this something worth fixing in the profiler?
Comment 2 Benoit Girard (:BenWa) 2012-05-04 08:47:06 PDT
(In reply to Ted Mielczarek [:ted] from comment #1)
> Comment on attachment 620462 [details] [diff] [review]
> patch
> 
> Review of attachment 620462 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: configure.in
> @@ +1960,5 @@
> >      MOZ_PROFILING=1,
> >      MOZ_PROFILING= )
> >  
> > +# For profiling builds keep the symbol information
> > +if test "$MOZ_PROFILING" -a -n "$STRIP_FLAGS"; then
> 
> Did you mean '-z "$STRIP_FLAGS"'; here? As written this won't do anything
> unless STRIP_FLAGS is already set.
> 
> @@ +7468,5 @@
> >      USE_ELF_HACK=,
> >      USE_ELF_HACK=1)
> >  
> > +# Disable elf hack for profiling because the built in profiler
> > +# doesn't read the segments properly with elf hack.
> 
> Is this something worth fixing in the profiler?

For sure, I plan on fixing this on relatively soon. But for now I wanted to take a temporary way around it.
Comment 3 Benoit Girard (:BenWa) 2012-05-04 10:07:35 PDT
Created attachment 621082 [details] [diff] [review]
patch v2
Comment 5 Ed Morley [:emorley] 2012-05-05 03:39:39 PDT
https://hg.mozilla.org/mozilla-central/rev/4ec6652da8b9
Comment 6 Benoit Girard (:BenWa) 2012-05-25 10:51:36 PDT
*** Bug 749521 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.