Last Comment Bug 751598 - sync Mozilla trees to npapi-sdk r20
: sync Mozilla trees to npapi-sdk r20
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Josh Aas
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on: 751602
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 09:35 PDT by Josh Aas
Modified: 2012-05-17 07:53 PDT (History)
5 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
+
fixed
fixed


Attachments
fix v1.0 (6.41 KB, patch)
2012-05-03 09:35 PDT, Josh Aas
bas: review+
Details | Diff | Splinter Review
fix v1.1 (6.33 KB, patch)
2012-05-03 15:25 PDT, Josh Aas
no flags Details | Diff | Splinter Review
fix v1.2 (6.28 KB, patch)
2012-05-03 22:03 PDT, Josh Aas
no flags Details | Diff | Splinter Review
fix v1.3 (5.00 KB, patch)
2012-05-04 05:48 PDT, Josh Aas
no flags Details | Diff | Splinter Review
fix v1.3 for Aurora (5.79 KB, patch)
2012-05-07 08:06 PDT, Josh Aas
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Josh Aas 2012-05-03 09:35:14 PDT
Created attachment 620737 [details] [diff] [review]
fix v1.0

We need to update to a new version of npapi-sdk to pick up a number of changes.
Comment 1 Josh Aas 2012-05-03 11:23:23 PDT
Try server run:

https://tbpl.mozilla.org/?tree=Try&rev=25932b8b16a3
Comment 2 Josh Aas 2012-05-03 15:25:43 PDT
Created attachment 620867 [details] [diff] [review]
fix v1.1

Compile fix.
Comment 3 Josh Aas 2012-05-03 15:27:22 PDT
Try server run:

https://tbpl.mozilla.org/?tree=Try&rev=af5c8cf3be32
Comment 4 Josh Aas 2012-05-03 17:23:50 PDT
Better try server run:

https://tbpl.mozilla.org/?tree=Try&rev=80237bebdaf7
Comment 5 Josh Aas 2012-05-03 22:03:59 PDT
Created attachment 620962 [details] [diff] [review]
fix v1.2

Another compile fix.
Comment 6 Josh Aas 2012-05-03 22:08:18 PDT
Updated try run:

https://tbpl.mozilla.org/?tree=Try&rev=74493bf39656
Comment 7 Josh Aas 2012-05-04 05:48:04 PDT
Created attachment 621023 [details] [diff] [review]
fix v1.3

This patch drops the removal of some android-specific code we added to our headers.
Comment 8 Josh Aas 2012-05-04 05:52:50 PDT
Updated try run:

https://tbpl.mozilla.org/?tree=Try&rev=6fe378eec17b
Comment 9 Josh Aas 2012-05-04 19:41:38 PDT
pushed to mozilla-inbound

https://hg.mozilla.org/integration/mozilla-inbound/rev/db4ba89d95ec
Comment 10 Josh Aas 2012-05-04 19:44:28 PDT
We really should update these headers for Firefox 13 and 14 as well. They have incorrect NPAPI values, a potential binary compatibility problem. Marking this tracking+ for those releases for this reason.
Comment 11 Ryan VanderMeulen [:RyanVM] 2012-05-05 20:22:56 PDT
https://hg.mozilla.org/mozilla-central/rev/db4ba89d95ec
Comment 12 Josh Aas 2012-05-07 08:06:56 PDT
Created attachment 621604 [details] [diff] [review]
fix v1.3 for Aurora

[Approval Request Comment]
Regression caused by (bug #): 651192
User impact if declined: Binary compatibility risk for plugins.
Testing completed (on m-c, etc.): already on m-c
Risk to taking this patch (and alternatives if risky): Plugins may be released with binary compatibility problems if they reference unpatched NPAPI headers, regardless of whether the feature is turned on in this particular build or not.
String changes made by this patch: none
Comment 13 Alex Keybl [:akeybl] 2012-05-09 16:10:06 PDT
(In reply to Josh Aas (Mozilla Corporation) from comment #12)
> User impact if declined: Binary compatibility risk for plugins.

What's our plan of attack for FF13?
Comment 14 Josh Aas 2012-05-09 17:56:06 PDT
(In reply to Alex Keybl [:akeybl] from comment #13)

> What's our plan of attack for FF13?

My plan is to try to land this for FF13 as well, thought I'd start with FF14. As soon as I get approval I'll post patches for FF13. Even if we can't get to FF13 for some reason, getting this done for FF14 is still good.
Comment 15 Alex Keybl [:akeybl] 2012-05-10 17:10:12 PDT
Comment on attachment 621604 [details] [diff] [review]
fix v1.3 for Aurora

[Triage Comment]
Approved for Aurora 14. We should land asap and then uplift to beta prior to our next go-to-build (5/15).
Comment 16 Josh Aas 2012-05-12 14:25:09 PDT
pushed to mozilla-aurora

https://hg.mozilla.org/releases/mozilla-aurora/rev/0b71fae84829
Comment 17 Matt Brubeck (:mbrubeck) 2012-05-12 19:01:34 PDT
Backed out on Aurora because of build errors on Windows:
https://hg.mozilla.org/releases/mozilla-aurora/rev/91b4b9f38e40
Comment 18 Josh Aas 2012-05-13 22:18:30 PDT
Aurora Windows build error:

PluginMessageUtils.h(98) : error C2065: 'NPDrawingModelAsyncWindowsDX9ExSurface' : undeclared identifier
Comment 19 Josh Aas 2012-05-13 23:01:31 PDT
pushed to mozilla-aurora again, compile fix is in the patch for bug 751602

http://hg.mozilla.org/releases/mozilla-aurora/rev/56d137349efc
Comment 20 Josh Aas 2012-05-14 12:28:30 PDT
Comment on attachment 621604 [details] [diff] [review]
fix v1.3 for Aurora

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Comment 21 Alex Keybl [:akeybl] 2012-05-14 13:36:12 PDT
We'll hold off on approving this one until we get a bit more feedback from Aurora.
Comment 22 Alex Keybl [:akeybl] 2012-05-16 11:34:26 PDT
Comment on attachment 621604 [details] [diff] [review]
fix v1.3 for Aurora

This has had some bake time now - approved for beta 13.
Comment 23 Josh Aas 2012-05-17 07:53:36 PDT
pushed to mozilla-beta

https://hg.mozilla.org/releases/mozilla-beta/rev/5f412ea09aba

Note You need to log in before you can comment on or make changes to this bug.