The default bug view has changed. See this FAQ.

compile fixes for drawing models (add ifdefs)

RESOLVED FIXED in Firefox 13

Status

()

Core
Plug-ins
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Josh Aas, Assigned: Josh Aas)

Tracking

Trunk
mozilla15
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox13 fixed, firefox14 fixed, firefox15 fixed)

Details

Attachments

(2 attachments, 4 obsolete attachments)

(Assignee)

Description

5 years ago
Created attachment 620739 [details] [diff] [review]
fix v1.0
Attachment #620739 - Flags: review?(bas.schouten)
(Assignee)

Updated

5 years ago
Summary: add ifdef for windows sync drawing model → add ifdef for sync drawing models in ipc code
(Assignee)

Comment 1

5 years ago
Created attachment 620760 [details] [diff] [review]
fix v1.1
Attachment #620739 - Attachment is obsolete: true
Attachment #620739 - Flags: review?(bas.schouten)
Attachment #620760 - Flags: review?(bas.schouten)
(Assignee)

Comment 2

5 years ago
Comment on attachment 620760 [details] [diff] [review]
fix v1.1

Made another mistake, I need to stop rushing this!
Attachment #620760 - Attachment is obsolete: true
Attachment #620760 - Flags: review?(bas.schouten)
(Assignee)

Comment 3

5 years ago
Created attachment 620777 [details] [diff] [review]
fix v1.2
Attachment #620777 - Flags: review?(bas.schouten)
Attachment #620777 - Flags: review?(bas.schouten) → review+
(Assignee)

Comment 4

5 years ago
Created attachment 620791 [details] [diff] [review]
fix v1.2 (real patch)

That time I got the patch right but included a bunch of other changes! Here's the patch without those.
Attachment #620777 - Attachment is obsolete: true
(Assignee)

Comment 5

5 years ago
try server run:

https://tbpl.mozilla.org/?tree=Try&rev=25932b8b16a3
(Assignee)

Updated

5 years ago
Blocks: 751598
(Assignee)

Comment 6

5 years ago
Try server run with a compile fix in the other patch:

https://tbpl.mozilla.org/?tree=Try&rev=80237bebdaf7
(Assignee)

Updated

5 years ago
Summary: add ifdef for sync drawing models in ipc code → compile fixes for drawing models (add ifdefs)
(Assignee)

Comment 7

5 years ago
Created attachment 620963 [details] [diff] [review]
fix v1.3

Added another compile fix.
Attachment #620791 - Attachment is obsolete: true
(Assignee)

Comment 8

5 years ago
Updated try run:

https://tbpl.mozilla.org/?tree=Try&rev=74493bf39656
(Assignee)

Comment 9

5 years ago
Updated try run with compile fix for NPAPI headers:

https://tbpl.mozilla.org/?tree=Try&rev=6fe378eec17b
(Assignee)

Comment 10

5 years ago
pushed to mozilla-inbound

https://hg.mozilla.org/integration/mozilla-inbound/rev/92f6c58e90c5
https://hg.mozilla.org/mozilla-central/rev/92f6c58e90c5
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla15
(Assignee)

Comment 12

5 years ago
Comment on attachment 620963 [details] [diff] [review]
fix v1.3

[Approval Request Comment]
Regression caused by (bug #): 651192
User impact if declined: Binary compatibility risk for plugins.
Testing completed (on m-c, etc.): already on m-c
Risk to taking this patch (and alternatives if risky): This is a required patch for bug 751598, the real fix. Plugins may be released with binary compatibility problems if they reference unpatched NPAPI headers, regardless of whether the feature is turned on in this particular build or not.
String changes made by this patch: none
Attachment #620963 - Flags: approval-mozilla-aurora?
We'd like to nail down the plan for both FF13 and FF14 before approving. See https://bugzilla.mozilla.org/show_bug.cgi?id=751598#c13

Updated

5 years ago
Attachment #620963 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 14

5 years ago
pushed to mozilla-aurora

https://hg.mozilla.org/releases/mozilla-aurora/rev/c19c13e83f94
status-firefox13: --- → affected
status-firefox14: --- → fixed
status-firefox15: --- → fixed
Backed out on Aurora because of build errors on Windows:
https://hg.mozilla.org/releases/mozilla-aurora/rev/91b4b9f38e40
status-firefox14: fixed → affected
(Assignee)

Comment 16

5 years ago
Created attachment 623588 [details] [diff] [review]
fix v1.4 for Aurora
(Assignee)

Comment 17

5 years ago
I don't have a Windows build environment handy and I don't see a way to do try server builds with Aurora. Fix is pretty straight-forward though, so trying again. Will back out myself if it doesn't work.
(Assignee)

Comment 18

5 years ago
pushed to mozilla-aurora again

http://hg.mozilla.org/releases/mozilla-aurora/rev/35f963416ff0
status-firefox14: affected → fixed
(Assignee)

Updated

5 years ago
Attachment #623588 - Flags: approval-mozilla-beta?
Comment on attachment 623588 [details] [diff] [review]
fix v1.4 for Aurora

This has had some bake time now - approved for beta 13.
Attachment #623588 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Comment 20

5 years ago
pushed to mozilla-beta

https://hg.mozilla.org/releases/mozilla-beta/rev/66f87d8a5eab
status-firefox13: affected → fixed
You need to log in before you can comment on or make changes to this bug.