bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Crashes loading this page.

VERIFIED DUPLICATE of bug 75494

Status

()

Core
ImageLib
VERIFIED DUPLICATE of bug 75494
18 years ago
17 years ago

People

(Reporter: Stephen Moehle, Assigned: Stuart Parmenter)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [imglib], URL)

(Reporter)

Description

18 years ago
Mozilla crashes while loading this page.  It just begins to render the page and
then crashes.  Reproducible always.

Talkback ID: TB28833163E

To reproduce:
1) Start Mozilla.
2) Enter URL into Location bar, and hit Enter.
3) Crash!

Tested with Mozilla 2001040805 and also 2001040414 on Linux.

Comment 1

18 years ago
This page works for me on a home made build from today, which has libpr0n turned
off.

Comment 2

18 years ago
Linux, libpr0n, newcache on.

GTK errors:

Gdk-CRITICAL **: file gdkgc.c: line 277 (gdk_gc_ref): assertion `gc != NULL' failed.

** CRITICAL **: file gdk-pixbuf-render.c: line 206
(gdk_pixbuf_render_to_drawable): assertion `gc != NULL' failed.

Gdk-CRITICAL **: file gdkgc.c: line 288 (gdk_gc_unref): assertion `gc != NULL'
failed.

Gdk-CRITICAL **: file gdkgc.c: line 277 (gdk_gc_ref): assertion `gc != NULL' failed.

Comment 3

18 years ago
   libgdk-1.2.so.0 + 0x1a05f (0x4066405f)            
nsImageGTK::DrawCompositedGeneral()             QBezierCurve::SubDivide()      
      PolyArea::GetRect()             nsDST::Insert()            
nsBlockReflowContext::ReflowBlock()            
nsBlockReflowContext::AlignBlockHorizontally()             nsDST::Insert()     
       nsDST::ConvertToTwoNode()             nsTableFrame::Reflow()            
nsTableBorderCollapser::ComputeLeftBorderForEdgeAt()            
nsTableBorderCollapser::ComputeLeftBorderForEdgeAt()            
nsBulletinBoardLayout::AddOffset()            
nsBulletinBoardLayout::AddOffset()             nsDST::Insert()            
nsDST::ConvertToTwoNode()             nsTableOuterFrame::SetInitialChildList() 
           nsDST::Insert()             nsTableRowGroupFrame::GetRowCount()     
       nsDST::Insert()             nsBlockReflowContext::ReflowBlock()         
   nsBlockReflowContext::AlignBlockHorizontally()             nsDST::Insert()  
          nsBlockReflowContext::ReflowBlock()            
nsBlockReflowContext::AlignBlockHorizontally()             nsDST::Insert()     
       nsDST::ConvertToTwoNode()             nsHTMLImageLoader::StartLoadImage()
            nsDST::Insert()             nsDST::ConvertToTwoNode()            
nsDST::ConvertToLeafNode()             nsScrollFrame::Reflow()            
nsView::~nsView()             nsViewManager::RenderViews()            
nsViewManager::RenderViews()             nsViewManager::Refresh()            
nsViewManager::UpdateView()             libgkview.so + 0x2fad (0x4103ffad)     
       nsWidget::OnButtonPressSignal()             nsWidget::HandlePopup()     
       nsWindow::DispatchActivateEvent()            
nsWindow::HandleMozAreaFocusOut()             nsWindow::SetFocus()            
libglib-1.2.so.0 + 0x11149 (0x4068f149)             libglib-1.2.so.0 + 0x10186
(0x4068e186)             libglib-1.2.so.0 + 0x10751 (0x4068e751)            
libglib-1.2.so.0 + 0x108f1 (0x4068e8f1)             libgtk-1.2.so.0 + 0x8c8e9
(0x405b68e9)             nsButton::SetFontNative()            
nsAppShellService::DestroyExitEvent()             InitializeProfileService()   
         main1()             libc.so.6 + 0x189cb (0x401e89cb)  
Assignee: asa → pavlov
Status: UNCONFIRMED → NEW
Component: Browser-General → ImageLib
Ever confirmed: true
QA Contact: doronr → tpreston

Updated

18 years ago
Whiteboard: [imglib]

Updated

18 years ago
Keywords: crash
(Assignee)

Comment 4

18 years ago
works fine on windows.. linux only?
Keywords: qawanted
(Reporter)

Comment 5

18 years ago
It does seems to be Linux only.  The page loads fine for me on Win2000 but still
crashes on Linux.

Comment 6

18 years ago
Duping....

*** This bug has been marked as a duplicate of 75494 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED

Updated

17 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.