Clear chrome from cache on theme switch

VERIFIED FIXED in mozilla0.9

Status

()

P1
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: selmer, Assigned: pavlov)

Tracking

Trunk
mozilla0.9
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
The new image library needs to notice theme switching and clear the old chrome
images from the cache so the new theme will look right when the switch is complete.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 1

18 years ago
Created attachment 30720 [details] [diff] [review]
patch to fix
(Assignee)

Updated

18 years ago
Keywords: patch

Comment 2

18 years ago
sr=hyatt but test.
Let's hear about those test results.  r=brendan@mozilla.org.

/be
(Assignee)

Comment 4

18 years ago
works like a charm.
(Assignee)

Comment 5

18 years ago
checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

18 years ago
*** Bug 74333 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
Using --disable-libpr0n - imgICache.h
 not found!
Forced to use buggy libpr0n...



(Assignee)

Comment 8

18 years ago
*** Bug 75036 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
Created attachment 31120 [details] [diff] [review]
make old imglib work again.
(Assignee)

Comment 10

18 years ago
the old imagelib is going away very soon.  there is no point in checking in this 
patch.
(Reporter)

Comment 11

18 years ago
And this bug is not about re-activating the old cache.  If you have some other
bug you're worried about, please open a new bug for it.

Comment 12

18 years ago
Verified patch checked into lxr, marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.