Closed Bug 751891 Opened 8 years ago Closed 8 years ago

Press ESC key does not hide FindBar, Edit Bookmarks Panel and any menupopup

Categories

(Core :: DOM: Events, defect)

15 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 751881

People

(Reporter: alice0775, Unassigned)

Details

(Keywords: regression)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/e1a40027dc7e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120504014349

Press ESC key does not hide FindBar

Reproducible: Always

Steps to Reproduce:
1. Open any web page
2. Ctrl+F to open FindBar
3. Press ESC key

Actual results:
  Nothing happens

Expected results:
  FindBar should disappear


Regression window:
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a6a335cd2c94
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120503010011
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/de5745bce8bc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120503013602
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a6a335cd2c94&tochange=de5745bce8bc

Regressed by: Bug 166240

Maybe Windows specific problem.
This also affected Edit Bookmarks Panel and any menupopup.

Steps to Reproduce:
1. Popup Edit Bookmarks Panel or any menupopup
2. Press ESC key

Actual results:
  Nothing happens

Expected results:
 Popup should disappear
Summary: Press ESC key does not hide FindBar → Press ESC key does not hide FindBar, Edit Bookmarks Panel and any menupopup
No longer blocks: 166240
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 751881
You need to log in before you can comment on or make changes to this bug.