The default bug view has changed. See this FAQ.

keyCode of keypress event for Tab key and ESC key is broken on Windows

RESOLVED FIXED in mozilla15

Status

()

Core
Widget: Win32
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Ekanan Ketunuti, Assigned: masayuki)

Tracking

({regression})

Trunk
mozilla15
x86
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR
1. use latest m-c or m-i
2. type `m` in urlbar. my first result for `m` is https://mail.google.com/.
3. press `tab` to select first result url autocomplete.

actual result 
- nothing happen, cannot use tab to select url autocomplete.

expected result 
- can use tab to select url autocomplete.

first bad revision is
changeset:   92974:de5745bce8bc
user:        Masayuki Nakano <masayuki@d-toybox.com>
date:        Thu May 03 17:35:02 2012 +0900
files:       content/events/test/test_dom_keyboard_event.html dom/base/nsDOMWindowUtils.cpp dom/interfaces/base/nsIDOMWindowUtils.idl layout/forms/test/test_bug348236.html testing/mochitest/tests/SimpleTest/EventUtils.js
description:
Bug 166240 part.8 Add tests for KeyboardEvent.location (synthesized events) r=smaug, sr=jst

last good revision is 
changeset:   92966:a6a335cd2c94
user:        Jonathan Kew <jkew@mozilla.com>
date:        Thu May 03 08:57:30 2012 +0100
files:       layout/reftests/text-transform/greek-small-caps-1-ref.html layout/reftests/text-transform/greek-small-caps-1.html layout/reftests/text-transform/reftest.list
description:
bug 307039 - reftest for Greek small-caps behavior. r=past

pushlog http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml/?fromchange=a6a335cd2c94&tochange=de5745bce8bc

Updated

5 years ago
Keywords: regression
(Reporter)

Updated

5 years ago
Blocks: 166240
(Reporter)

Updated

5 years ago
Version: unspecified → Trunk
Masayuki-san, could you please check/clarify how that fix affected the locationbar?
Assignee: nobody → masayuki
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

5 years ago
Hmm, I have no idea. In XP level, it shouldn't cause any regression.

The widget part for Windows is a little bit complex. I guess that the cause should be in part.2.
(Assignee)

Comment 3

5 years ago
I'd like someone to test this regression on other platforms.
(Assignee)

Comment 4

5 years ago
Ah, I see. I found a logical bug in the previous code. But the behavior is broken by the new code.
Component: Location Bar → Widget: Win32
Product: Firefox → Core
QA Contact: location.bar → win32
(Reporter)

Comment 5

5 years ago
Cannot reproduce on Linux. Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/15.0 Firefox/15.0a1
(Assignee)

Comment 6

5 years ago
Thanks. I think that the keypress events of ESC key and Tab key do not work.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 751891
(Assignee)

Updated

5 years ago
Duplicate of this bug: 751890
(Assignee)

Updated

5 years ago
Summary: Unable to press tab to select url autocomplete → keyCode of keypress event for Tab key and ESC key is broken on Windows
(Assignee)

Comment 9

5 years ago
Created attachment 621077 [details] [diff] [review]
Patch

testing on tryserver.
https://tbpl.mozilla.org/?tree=Try&usebuildbot=1&rev=1d5540cfcde0
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 10

5 years ago
Comment on attachment 621077 [details] [diff] [review]
Patch

At OnChar(), it sets keycode from wParam of WM_CHAR when charCode is zero. It's logically wrong, but it worked because native virtual keycode and native charcode are same for Tab key and Esc key.

This patch computes DOM keycode from scan code and sets it when keypress event's charCode is 0.
Attachment #621077 - Flags: review?(jmathies)

Updated

5 years ago
Attachment #621077 - Flags: review?(jmathies) → review+
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/mozilla-central/rev/06d669152510
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla15
Blocks: 752109
(Assignee)

Updated

5 years ago
Duplicate of this bug: 752109
(Assignee)

Updated

5 years ago
Duplicate of this bug: 752107

Updated

5 years ago
Blocks: 752048

Updated

5 years ago
Duplicate of this bug: 752165

Updated

5 years ago
Duplicate of this bug: 752717
You need to log in before you can comment on or make changes to this bug.