Last Comment Bug 751955 - Lion fullscreen check should be more versatile
: Lion fullscreen check should be more versatile
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All Mac OS X
: -- normal (vote)
: Firefox 15
Assigned To: Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
:
Mentors:
: 775325 (view as bug list)
Depends on:
Blocks: mountain-lion-compat
  Show dependency treegraph
 
Reported: 2012-05-04 10:54 PDT by Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
Modified: 2012-07-18 16:15 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v0.1 (1.10 KB, patch)
2012-05-04 10:57 PDT, Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
dao+bmo: review+
Details | Diff | Review

Description Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-05-04 10:54:45 PDT
The check that we have in FullScreen.useLionFullScreen is limited to only checking if the user is on Lion. With Mountain Lion coming, that check needs to be expanded.

I think using parseFloat (or even parseInt) on Services.sysinfo.getProperty("version") should be good enough.

10.6.x -> 10.x (Snow Leopard)
10.7.y -> 11.y (Lion)
10.8.z -> 12.z (Mountain Lion)
Comment 1 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-05-04 10:57:59 PDT
Created attachment 621105 [details] [diff] [review]
Patch v0.1
Comment 2 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-05-04 11:36:53 PDT
https://hg.mozilla.org/integration/fx-team/rev/6016301d6d16
Comment 3 Tim Taubert [:ttaubert] 2012-05-04 15:39:11 PDT
https://hg.mozilla.org/mozilla-central/rev/6016301d6d16
Comment 4 Dão Gottwald [:dao] 2012-07-18 16:15:12 PDT
*** Bug 775325 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.