Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 775325 - [10.8] Lion-style fullscreen mode autohides toolbars on OS X Mountain Lion
: [10.8] Lion-style fullscreen mode autohides toolbars on OS X Mountain Lion
Status: RESOLVED DUPLICATE of bug 751955
Product: Core
Classification: Components
Component: Widget: Cocoa (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Markus Stange [:mstange]
Depends on:
Blocks: mountain-lion-compat
  Show dependency treegraph
Reported: 2012-07-18 15:03 PDT by Steven Michaud [:smichaud] (Retired)
Modified: 2012-07-27 09:41 PDT (History)
1 user (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Steven Michaud [:smichaud] (Retired) 2012-07-18 15:03:54 PDT
On OS X 10.7.X, the new Lion-style fullscreen mode (implemented by bug 639705) ignores the browser.fullscreen.autohide setting, and doesn't autohide toolbars.  But on OS X 10.8 it does.  Thus it mixes elements of the "old" presentation mode (which supported autohiding) with elements of the "new" Lion-style fullscreen mode.

Some might say this isn't a bug but a feature.  See bug 740148.
Comment 1 Steven Michaud [:smichaud] (Retired) 2012-07-18 15:28:35 PDT
Oops, this is fixed in current trunk code by the patch for bug 751955.
Comment 2 Dão Gottwald [:dao] 2012-07-18 16:15:12 PDT

*** This bug has been marked as a duplicate of bug 751955 ***
Comment 3 Andre Bach 2012-07-27 09:41:02 PDT
Commenting to express support for this behavior, which as mentioned is the desired mode for many. See bug 740148, bug 639705, and

Note You need to log in before you can comment on or make changes to this bug.