All users were logged out of Bugzilla on October 13th, 2018

Update mfbt/double-conversion/update.sh and file upstream bug for bug 751412

RESOLVED DUPLICATE of bug 806538

Status

()

--
critical
RESOLVED DUPLICATE of bug 806538
7 years ago
6 years ago

People

(Reporter: decoder, Assigned: decoder)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
+++ This bug was initially created as a clone of Bug #751412 +++


In bug 751412 I fixed a memory safety problem in mfbt's double-conversion code. Since the code is imported third party code, we need to file an upstream bug and add the patch to the update.sh file in that directory.
(Assignee)

Comment 2

7 years ago
Created attachment 621282 [details] [diff] [review]
Patch

This patch adds the patch to the mfbt/double-conversion directory and includes it in update.sh as requested.
Assignee: nobody → choller
Status: NEW → ASSIGNED
Attachment #621282 - Flags: review?(jwalden+bmo)

Updated

7 years ago
Attachment #621282 - Flags: review?(jwalden+bmo) → review+

Comment 3

6 years ago
We updated double-conversion in bug 806538, and I double-checked that we have the increased-by-one code in the newly-updated source.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 806538
You need to log in before you can comment on or make changes to this bug.