Closed Bug 75224 Opened 19 years ago Closed 19 years ago

No cut/copy and paste under KDE

Categories

(Core :: XUL, defect, P5, major)

x86
Linux
defect

Tracking

()

RESOLVED WORKSFORME
Future

People

(Reporter: tho, Assigned: dr)

Details

From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; by media access 
GmbH)
BuildID:    0.8.1

There is obviously no way to use the cut/copy and paste function of KDE/X when 
you try to paste something into a Mozilla field.

Reproducible: Always
Steps to Reproduce:
1.Mark and copy a Test in an editor
2.Try to paste it into the url field


Actual Results:  Nothing happens

Expected Results:  The text is shown up in the url field.
1)  How are you marking/copying the text?

2)  How are you pasting the text?

3)  Is either of Mozilla or the application you are pasting from being displayed
    remotely?
Comments from reporter:

>1)  How are you marking/copying the text?

Marking: by means of the ordinary mouse-cursor (sliding it over the text)
and then pressing [Ctrl]+[c] or rightclick and 'copy'- I've tried both.

>2)  How are you pasting the text?

Pasting: by pressing [Ctrl]+[v] or by rightclick and 'paste' - I've tried
both.

>3)  Is either of Mozilla or the application you are pasting from being
>    displayed remotely?

Uuuu, sorry my English is not that good, could you please rewrite the
question?
Questions: what text editor are you using?  Can you paste into Mozilla by
clicking the middle mouse button?

Could you try the following:

1)  Copy in your text editor as you normally do
2)  run 'xclipboard'
3)  See whether what you copied is shown by xclipboard

To rephrase my "remote display" question, are both mozilla and the editor
running on the same computer?  Or are you using the ability of X to run an
application on one computer and show it on a different one?
tho@media-access.net, could you please add comments on the bug page instead of
mailing them to people who comment on the bug?

Comments from reporter:

>Questions: what text editor are you using?  Can you paste into Mozilla by
>clicking the middle mouse button?

I've also tried this way, but it lead to the same result as
stated in the bug report.

>Could you try the following:
>1)  Copy in your text editor as you normally do
>2)  run 'xclipboard'
>3)  See whether what you copied is shown by xclipboard

This may take a while, I've installed it on my sisters Laptop :),
as soon as I've got the result of the test I'll send you a mail.

>To rephrase my "remote display" question, are both mozilla and the editor
>running on the same computer?  Or are you using the ability of X to run an
>application on one computer and show it on a different one?

Ok, this time  I've got it. No, theres no remote technique in use.
Just two apps on one box.
updating component.
Assignee: asa → trudelle
Component: Browser-General → XP Toolkit/Widgets
QA Contact: doronr → jrgm
->pink. could you try a recent nightly build? Can anyone else reproduce this?
Assignee: trudelle → pinkerton
er, "you" meaning the reporter...
linux --> dr to confirmation
Assignee: pinkerton → dr
I *so* can not reproduce this. tho@media-access.net: can you copy/paste into
other apps? I'm more than a little bit tempted to resolve this as WORKSFORME...
@Dan Rosen

For sure can I paste into other appz.
My whole KDE is running well, except
that I can't interact with Mozilla.

@all

I also searched over google an found
nobody else who has this problem, so I'll
install a new build as soon, as my sister is back with
the laptop.

I have seen this...it has to do with the way the cut buffer works..its already
been reported however and there is a patch for it. Will find it later.
confirming. ksosez: when you get a chance, could you find the bug this is a dup
of? thanks!
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P5
Target Milestone: --- → Future
There we go...

*** This bug has been marked as a duplicate of 37057 ***
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
reopening.  bug 37057 is about selecting text in mozilla and it not pasting
correctly into other apps.  This bug is about pasting text _into_ mozilla.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
wfm
Status: REOPENED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.