VERIFIED DUPLICATE of bug 76119

Status

()

Core
ImageLib
VERIFIED DUPLICATE of bug 76119
17 years ago
17 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: Stuart Parmenter)

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

not sure it is reproducable yet.

here's the stack:

NTDLL! 77f7629c()
nsDebug::Assertion(const char * 0x026d1704 
??_C@_0DJ@KMGL@You?5can?8t?5dereference?5a?5NULL?5nsC@, const char * 0x026d1748 
??_C@_0N@NHHF@mRawPtr?5?$CB?$DN?50?$AA@, const char * 0x026d1758 
??_C@_0CB@MCGB@?4?4?2?4?4?2?4?4?2dist?2include?2nsCOMPtr?4h@, int 648) line 286 
+ 13 bytes
nsDebug::PreCondition(const char * 0x026d1704 
??_C@_0DJ@KMGL@You?5can?8t?5dereference?5a?5NULL?5nsC@, const char * 0x026d1748 
??_C@_0N@NHHF@mRawPtr?5?$CB?$DN?50?$AA@, const char * 0x026d1758 
??_C@_0CB@MCGB@?4?4?2?4?4?2?4?4?2dist?2include?2nsCOMPtr?4h@, int 648) line 430 
+ 21 bytes
nsCOMPtr<gfxIImageFrame>::operator->() line 648 + 34 bytes
imgContainer::EndFrameDecode(imgContainer * const 0x0ce4ccc0, unsigned int 7, 
unsigned int 100) line 213 + 12 bytes
EndImageFrame(void * 0x0ccf9280, unsigned int 7, unsigned int 100) line 302
gif_write(gif_struct * 0x0ccf9130, const unsigned char * 0x08836da0, unsigned 
int 4096) line 1469 + 32 bytes
nsGIFDecoder2::ProcessData(nsGIFDecoder2 * const 0x0ccf9280, unsigned char * 
0x08836da0, unsigned int 4096) line 164 + 20 bytes
ReadDataOut(nsIInputStream * 0x0b9948f0, void * 0x0ccf9280, const char * 
0x08836da0, unsigned int 11973, unsigned int 4096, unsigned int * 0x0012f7b8) 
line 151 + 17 bytes
nsInputStreamTee::WriteSegmentFun(nsIInputStream * 0x0b9948f0, void * 
0x0ccf9310, const char * 0x08836da0, unsigned int 11973, unsigned int 4096, 
unsigned int * 0x0012f7b8) line 81 + 33 bytes
nsPipe::nsPipeInputStream::ReadSegments(nsPipe::nsPipeInputStream * const 
0x0b9948f0, unsigned int (nsIInputStream *, void *, const char *, unsigned int, 
unsigned int, unsigned int *)* 0x1004e580 
nsInputStreamTee::WriteSegmentFun(nsIInputStream *, void *, const char *, 
unsigned int, unsigned int, unsigned int *), void * 0x0ccf9310, unsigned int 
19956, unsigned int * ...) line 411 +
nsInputStreamTee::ReadSegments(nsInputStreamTee * const 0x0ccf9310, unsigned int 
(nsIInputStream *, void *, const char *, unsigned int, unsigned int, unsigned 
int *)* 0x02bf1b10 ReadDataOut(nsIInputStream *, void *, const char *, unsigned 
int, unsigned int, unsigned int *), void * 0x0ccf9280, unsigned int 19956, 
unsigned int * 0x0012f8d0) line 138
nsGIFDecoder2::WriteFrom(nsGIFDecoder2 * const 0x0ccf9280, nsIInputStream * 
0x0ccf9310, unsigned int 19956, unsigned int * 0x0012f8d0) line 183
imgRequest::OnDataAvailable(imgRequest * const 0x0ce4cd58, nsIRequest * 
0x0ce49040, nsISupports * 0x00000000, nsIInputStream * 0x0ccf9310, unsigned int 
0, unsigned int 19956) line 749 + 47 bytes
nsHTTPFinalListener::OnDataAvailable(nsHTTPFinalListener * const 0x0ce4def0, 
nsIRequest * 0x0ce49040, nsISupports * 0x00000000, nsIInputStream * 0x0ccf9310, 
unsigned int 0, unsigned int 19956) line 1164 + 46 bytes
nsStreamListenerTee::OnDataAvailable(nsStreamListenerTee * const 0x0ccfa9c0, 
nsIRequest * 0x0ce49040, nsISupports * 0x00000000, nsIInputStream * 0x0b9948f0, 
unsigned int 0, unsigned int 19956) line 56 + 51 bytes
nsHTTPServerListener::OnDataAvailable(nsHTTPServerListener * const 0x0b9949e0, 
nsIRequest * 0x0b996040, nsISupports * 0x0ce49040, nsIInputStream * 0x0b9948f0, 
unsigned int 0, unsigned int 19956) line 541 + 64 bytes
nsOnDataAvailableEvent::HandleEvent(nsOnDataAvailableEvent * const 0x0cd529d0) 
line 161 + 70 bytes
nsStreamObserverEvent::HandlePLEvent(PLEvent * 0x0cd529d4) line 79
PL_HandleEvent(PLEvent * 0x0cd529d4) line 588 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00ae7e10) line 518 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x0058012e, unsigned int 49401, unsigned int 0, 
long 11435536) line 1069 + 9 bytes
USER32! 77e71820()
00ae7e10()
here's the exact url I clicked on
Summary: crash when going to http://www.subdimension.com → crash when going to http://www.subdimension.com/freemail/index.html
that crash is proceeded by this assertion:

NTDLL! 77f7629c()
nsDebug::Assertion(const char * 0x02521c60, const char * 0x02521c54, const char 
* 0x02521c1c, int 352) line 286 + 13 bytes
nsDebug::PreCondition(const char * 0x02521c60, const char * 0x02521c54, const 
char * 0x02521c1c, int 352) line 430 + 21 bytes
nsFrame::AppendFrames(nsFrame * const 0x049bf4dc, nsIPresContext * 0x05356090, 
nsIPresShell & {...}, nsIAtom * 0x00000000 {???}, nsIFrame * 0x049bf518) line 
352 + 35 bytes
FrameManager::AppendFrames(FrameManager * const 0x0538f8b0, nsIPresContext * 
0x05356090, nsIPresShell & {...}, nsIFrame * 0x049bf4dc, nsIAtom * 0x00000000 
{???}, nsIFrame * 0x049bf518) line 779
nsCSSFrameConstructor::AppendFrames(nsIPresContext * 0x05356090, nsIPresShell * 
0x05388d50, nsIFrameManager * 0x0538f8b0, nsIContent * 0x05cbbf10, nsIFrame * 
0x049bf4dc, nsIFrame * 0x049bf518) line 7603 + 30 bytes
nsCSSFrameConstructor::ContentAppended(nsCSSFrameConstructor * const 0x0538e970, 
nsIPresContext * 0x05356090, nsIContent * 0x05cbbf10, int 0) line 8154
StyleSetImpl::ContentAppended(StyleSetImpl * const 0x0538ea30, nsIPresContext * 
0x05356090, nsIContent * 0x05cbbf10, int 0) line 1215
PresShell::ContentAppended(PresShell * const 0x05388d58, nsIDocument * 
0x05396e50, nsIContent * 0x05cbbf10, int 0) line 4444 + 46 bytes
nsDocument::ContentAppended(nsDocument * const 0x05396e50, nsIContent * 
0x05cbbf10, int 0) line 1601
nsHTMLDocument::ContentAppended(nsHTMLDocument * const 0x05396e50, nsIContent * 
0x05cbbf10, int 0) line 1263 + 17 bytes
HTMLContentSink::NotifyAppend(nsIContent * 0x05cbbf10, int 0) line 4556
SinkContext::FlushTags(int 1) line 2049
HTMLContentSink::FlushPendingNotifications(HTMLContentSink * const 0x0459b710) 
line 5278 + 16 bytes
nsHTMLDocument::FlushPendingNotifications(nsHTMLDocument * const 0x05396e50, int 
0) line 1402 + 23 bytes
nsHTMLDocument::ResolveName(nsHTMLDocument * const 0x05396f34, const nsAString & 
{...}, nsIDOMHTMLFormElement * 0x00000000, nsISupports * * 0x0012de50) line 3334
nsHTMLDocument::NamedItem(nsHTMLDocument * const 0x05396f3c, JSContext * 
0x040ac5b0, long * 0x0012de94, unsigned int 1, long * 0x0012de80) line 3468 + 70 
bytes
nsHTMLDocument::Resolve(JSContext * 0x040ac5b0, JSObject * 0x00e0fe08, long 
13939116, int * 0x0012ded0) line 3568 + 36 bytes
nsJSUtils::nsGenericResolve(JSContext * 0x040ac5b0, JSObject * 0x00e0fe08, long 
13939116, JSPropertySpec * 0x00000000) line 619 + 38 bytes
ResolveHTMLDocument(JSContext * 0x040ac5b0, JSObject * 0x00e0fe08, long 
13939116) line 687 + 19 bytes
_js_LookupProperty(JSContext * 0x040ac5b0, JSObject * 0x00e0fe08, long 36312576, 
JSObject * * 0x0012e098, JSProperty * * 0x0012e08c, const char * 0x00332740, 
unsigned int 2178) line 2042 + 24 bytes
js_GetProperty(JSContext * 0x040ac5b0, JSObject * 0x00e0fe08, long 36312576, 
long * 0x0012ec04) line 2178 + 35 bytes
js_Interpret(JSContext * 0x040ac5b0, long * 0x0012ee30) line 2513 + 1998 bytes
js_Execute(JSContext * 0x040ac5b0, JSObject * 0x00de6eb0, JSScript * 0x053d68b0, 
JSStackFrame * 0x00000000, unsigned int 0, long * 0x0012ee30) line 965 + 13 
bytes
JS_EvaluateUCScriptForPrincipals(JSContext * 0x040ac5b0, JSObject * 0x00de6eb0, 
JSPrincipals * 0x03f5b150, const unsigned short * 0x00de3c18, unsigned int 591, 
const char * 0x053d6dc0, unsigned int 403, long * 0x0012ee30) line 3293 + 25 
bytes
nsJSContext::EvaluateString(nsJSContext * const 0x040d7180, const nsAString & 
{...}, void * 0x00de6eb0, nsIPrincipal * 0x03f5b14c, const char * 0x053d6dc0, 
unsigned int 403, const char * 0x003165f8, nsAString & {...}, int * 0x0012ee8c) 
line 609 + 85 bytes
HTMLContentSink::EvaluateScript(const nsAString & {...}, nsIURI * 0x04586e00, 
int 403, const char * 0x003165f8) line 4726
HTMLContentSink::ProcessSCRIPTTag(const nsIParserNode & {...}) line 5092
HTMLContentSink::AddLeaf(HTMLContentSink * const 0x0459b710, const nsIParserNode 
& {...}) line 3215 + 12 bytes
CNavDTD::AddLeaf(const nsIParserNode * 0x00d68710) line 3801 + 22 bytes
CNavDTD::HandleScriptToken(const nsIParserNode * 0x00d68710) line 2229 + 12 
bytes
CNavDTD::OpenContainer(const nsCParserNode * 0x00d68710, nsHTMLTag 
eHTMLTag_script, int 1, nsEntryStack * 0x00000000) line 3471 + 12 bytes
CNavDTD::HandleDefaultStartToken(CToken * 0x049a64d0, nsHTMLTag eHTMLTag_script, 
nsCParserNode * 0x00d68710) line 1298 + 20 bytes
CNavDTD::HandleStartToken(CToken * 0x049a64d0) line 1712 + 22 bytes
CNavDTD::HandleToken(CNavDTD * const 0x05396ab0, CToken * 0x00000000, nsIParser 
* 0x0459c0f0) line 864 + 12 bytes
CNavDTD::BuildModel(CNavDTD * const 0x05396ab0, nsIParser * 0x0459c0f0, 
nsITokenizer * 0x05395a20, nsITokenObserver * 0x00000000, nsIContentSink * 
0x0459b710) line 516 + 20 bytes
nsParser::BuildModel() line 2028 + 34 bytes
nsParser::ResumeParse(int 1, int 0) line 1909 + 11 bytes
nsParser::ContinueParsing() line 1521 + 17 bytes
HTMLContentSink::OnStreamComplete(HTMLContentSink * const 0x0459b714, 
nsIStreamLoader * 0x0453c2a0, nsISupports * 0x00000000, unsigned int 0, unsigned 
int 421, const char * 0x053a58d0) line 4875 + 17 bytes
nsStreamLoader::OnStopRequest(nsStreamLoader * const 0x0453c2a4, nsIRequest * 
0x0453a1c0, nsISupports * 0x00000000, unsigned int 0, const unsigned short * 
0x100b60e0 gCommonEmptyBuffer) line 120 + 81 bytes
nsHTTPFinalListener::OnStopRequest(nsHTTPFinalListener * const 0x0453af30, 
nsIRequest * 0x0453a1c0, nsISupports * 0x00000000, unsigned int 0, const 
unsigned short * 0x100b60e0 gCommonEmptyBuffer) line 1131 + 42 bytes
nsHTTPChannel::ResponseCompleted(nsIStreamListener * 0x0453af30, unsigned int 0, 
const unsigned short * 0x100b60e0 gCommonEmptyBuffer) line 2429 + 36 bytes
nsHTTPServerListener::OnStopRequest(nsHTTPServerListener * const 0x053a6750, 
nsIRequest * 0x053a6b60, nsISupports * 0x0453a1c0, unsigned int 0, const 
unsigned short * 0x100b60e0 gCommonEmptyBuffer) line 705
nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 0x0538c190) line 
183 + 67 bytes
nsStreamObserverEvent::HandlePLEvent(PLEvent * 0x0538c194) line 79
PL_HandleEvent(PLEvent * 0x0538c194) line 588 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00ae7e10) line 518 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x0051020c, unsigned int 49401, unsigned int 0, 
long 11435536) line 1069 + 9 bytes
USER32! 77e71820()
00ae7e10()
this is reproducable.

here comes a bulletproofing patch to libpr0n
yikes, after this disk crash my cache seems corrupted.

after I crash, I'm unable to go to 
http://www.subdimension.com/freemail/index.html.

I get this on the console:

"Error Loading URL http://www.subdimension.com/freemail/index.html: 8000ffff"

if I exit and remove *ache* from my profile directory, it works fine again.
I shouldn't have said "fixes crash".

it just prevents it.

the assertion in nsFrame::AppendFrames() should be investigated first.
cc'ing jst, hyatt and shaver for that.  I'll log a new bug on layout for that.

gordon, can you investigate the disk cache corruption?  I'll log another bug on 
that for you.

Comment 7

17 years ago
Seth, when is your build from?  End of last week, patrick put in code that 
deletes the disk cache folder (NewCache) if it wasn't able to update it 
coherently (for example, after a crash).
gordon:  my build is from sunday night.
(Assignee)

Comment 9

17 years ago
i've fixed the crash, now you'll just get lots of assertions.  duping on to 
76119 which is that the gif decoder is doing bad stuff.

*** This bug has been marked as a duplicate of 76119 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Keywords: crash
Resolution: --- → DUPLICATE

Comment 10

17 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.