Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Upgrade pywebsocket to v631

RESOLVED FIXED in mozilla14

Status

()

Core
Networking: WebSockets
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jduell, Assigned: jduell)

Tracking

unspecified
mozilla14
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

Created attachment 621840 [details] [diff] [review]
diff of pywebsocket v606->v630.

This mainly gets us the newer close code definitions in the spec.

First attachment is just a straight diff of the canonical pywebsocket repo v606->v630, so nothing really to review.
Attachment #621840 - Flags: review?(mcmanus)
(Assignee)

Comment 1

5 years ago
Created attachment 621841 [details] [diff] [review]
Mozilla-specific tweaks to pywebsocket

The usual HSTS patch.
Assignee: nobody → jduell.mcbugs
Status: NEW → ASSIGNED
Attachment #621841 - Flags: review?(mcmanus)
Comment on attachment 621840 [details] [diff] [review]
diff of pywebsocket v606->v630.

this is a rubberstamp
Attachment #621840 - Flags: review?(mcmanus) → review+
Comment on attachment 621841 [details] [diff] [review]
Mozilla-specific tweaks to pywebsocket

Review of attachment 621841 [details] [diff] [review]:
-----------------------------------------------------------------

::: testing/mochitest/pywebsocket/README-MOZILLA
@@ +43,3 @@
>    $OBJDIR/_tests/testing/mochitest/websock.log
>  
>  - Upgrade the svnversion number at top of this file to whatever version we're

why?
Attachment #621841 - Flags: review?(mcmanus) → review+
(Assignee)

Comment 4

5 years ago
> Upgrade the svnversion number

Oh, just because the version # isn't in the pywebsocket code anywhere.  We could always figure it out with hg + bugzilla archeology.  Seemed simpler to just store it in the README.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 752778
(Assignee)

Comment 6

5 years ago
Created attachment 623789 [details] [diff] [review]
pywebsocket, v631

pywebsocket 631, which contains my fixes for empty close frames.

Patrick: just needs rubberstamp as usual.
Attachment #621840 - Attachment is obsolete: true
Attachment #623789 - Flags: review?(mcmanus)
(Assignee)

Comment 7

5 years ago
Created attachment 623790 [details] [diff] [review]
Mozilla-specific tweaks to pywebsocket v631
Attachment #621841 - Attachment is obsolete: true
Attachment #623790 - Flags: review?(mcmanus)
(Assignee)

Updated

5 years ago
Summary: Upgrade pywebsocket to v630 → Upgrade pywebsocket to v631
Attachment #623790 - Flags: review?(mcmanus) → review+
Comment on attachment 623789 [details] [diff] [review]
pywebsocket, v631

this is a rubberstamp. glad to hear code got upstream!
Attachment #623789 - Flags: review?(mcmanus) → review+
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/deb1fd74e10b
https://hg.mozilla.org/integration/mozilla-inbound/rev/6aa80954981c
https://hg.mozilla.org/mozilla-central/rev/6aa80954981c
https://hg.mozilla.org/mozilla-central/rev/deb1fd74e10b
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla15
(Assignee)

Updated

5 years ago
Blocks: 748580
(Assignee)

Comment 11

5 years ago
Comment on attachment 623789 [details] [diff] [review]
pywebsocket, v631

Test infrastructure-only change to support landing bug 748580 on aurora
Attachment #623789 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 12

5 years ago
Comment on attachment 623790 [details] [diff] [review]
Mozilla-specific tweaks to pywebsocket v631

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch:
Attachment #623790 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #623789 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

5 years ago
Attachment #623790 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 13

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/031abdd1b0a0
https://hg.mozilla.org/releases/mozilla-aurora/rev/b6a7abca23b5
(Assignee)

Updated

5 years ago
Target Milestone: mozilla15 → mozilla14
You need to log in before you can comment on or make changes to this bug.