Last Comment Bug 752834 - UI tweaks for the property view
: UI tweaks for the property view
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: 12 Branch
: All All
: P2 normal (vote)
: Firefox 15
Assigned To: Victor Porof [:vporof][:vp]
:
: James Long (:jlongster)
Mentors:
Depends on: 753313
Blocks: 753332 759135
  Show dependency treegraph
 
Reported: 2012-05-08 01:43 PDT by Victor Porof [:vporof][:vp]
Modified: 2012-06-01 05:56 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (12.45 KB, patch)
2012-05-10 11:14 PDT, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review
v1 (12.45 KB, patch)
2012-05-10 11:56 PDT, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review
v1.1 (13.01 KB, patch)
2012-05-20 13:59 PDT, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review
v2 (7.12 KB, patch)
2012-05-28 09:12 PDT, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review
v2 (7.47 KB, patch)
2012-05-28 09:14 PDT, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review
v3 (7.51 KB, patch)
2012-05-29 06:15 PDT, Victor Porof [:vporof][:vp]
past: review+
Details | Diff | Splinter Review

Description Victor Porof [:vporof][:vp] 2012-05-08 01:43:28 PDT
It's bad to assume someone is interested in EVERYTHING that's shown in the property view. For example, we probably never really need to look at __proto__, but now it's the first element shown and it even has the same colors.

Let's reduce visual clutter, by playing with ordering and css a bit.
Comment 1 Victor Porof [:vporof][:vp] 2012-05-08 01:52:24 PDT
Also, we're displaying [object Constructor] for everything except primitives (or strings and null). Again, clutter. I think the Constructor information is more than enough.
Comment 2 Victor Porof [:vporof][:vp] 2012-05-09 07:49:13 PDT
We should also have nicer property name displays for Arguments, Array and Object types, like Firebug does. Followup bug for this.
Comment 3 Victor Porof [:vporof][:vp] 2012-05-09 07:57:30 PDT
Filed bug 753332 addressing comment #1 and #2.
Comment 4 Victor Porof [:vporof][:vp] 2012-05-10 11:14:18 PDT
Created attachment 622800 [details] [diff] [review]
v1

Also fixed some bad indents in DVF_updateState from the debugger xulification.
Comment 5 Victor Porof [:vporof][:vp] 2012-05-10 11:56:09 PDT
Created attachment 622824 [details] [diff] [review]
v1

Had to rebase, since bug 753313 is trending right now.
Comment 6 Victor Porof [:vporof][:vp] 2012-05-11 01:51:42 PDT
Somewhat dependent on bug 752770. Please postpone review until that settles.
Comment 7 Rob Campbell [:rc] (:robcee) 2012-05-17 16:54:41 PDT
Comment on attachment 622824 [details] [diff] [review]
v1

+      aCallback && aCallback(prop, value);

are we doing this now? I guess that's ok.
Comment 8 Rob Campbell [:rc] (:robcee) 2012-05-17 17:08:08 PDT
I'd like to try this out, I would. But the patch depth is too deep.
Comment 9 Victor Porof [:vporof][:vp] 2012-05-20 13:59:49 PDT
Created attachment 625517 [details] [diff] [review]
v1.1

Rebased.
Comment 10 Victor Porof [:vporof][:vp] 2012-05-28 09:12:53 PDT
Created attachment 627727 [details] [diff] [review]
v2

Rebased.
Comment 11 Victor Porof [:vporof][:vp] 2012-05-28 09:14:40 PDT
Created attachment 627728 [details] [diff] [review]
v2

Achievement unlocked: forgot to qref.
Comment 12 Victor Porof [:vporof][:vp] 2012-05-29 06:15:58 PDT
Created attachment 627935 [details] [diff] [review]
v3

Bug 755346 generated a lot of fuzz, qrefreshed.
Comment 13 Rob Campbell [:rc] (:robcee) 2012-05-29 06:26:24 PDT
Comment on attachment 627935 [details] [diff] [review]
v3

ok. Let me try this.
Comment 14 Panos Astithas [:past] 2012-05-31 02:23:24 PDT
Comment on attachment 627935 [details] [diff] [review]
v3

Review of attachment 627935 [details] [diff] [review]:
-----------------------------------------------------------------

Got a call from the Homeowners Association that I should help the homeless, so I'm stealing this.

Looks good.
Comment 15 Rob Campbell [:rc] (:robcee) 2012-05-31 16:26:55 PDT
https://hg.mozilla.org/integration/fx-team/rev/71f26fd0bdc5
Comment 16 Rob Campbell [:rc] (:robcee) 2012-06-01 05:56:25 PDT
https://hg.mozilla.org/mozilla-central/rev/71f26fd0bdc5

Note You need to log in before you can comment on or make changes to this bug.