Closed Bug 752939 Opened 9 years ago Closed 9 years ago

Links can't be clicked after switching between tabs

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(firefox14 verified, firefox15 verified, blocking-fennec1.0 beta+)

VERIFIED FIXED
Firefox 15
Tracking Status
firefox14 --- verified
firefox15 --- verified
blocking-fennec1.0 --- beta+

People

(Reporter: jpr, Assigned: kats)

References

Details

Attachments

(1 file)

1. Open Aurora
2. Search for sway bar in the url area
3. Tap on images
4. Tap on an image
5. Open a new tab with CNN
6. Double tap to zoom on CNN
7. Switch back to google tab
8. Try to click "Back to results"

Fails to register the click. If you pinch zoom, the link should become clickable again.
Assignee: nobody → bugmail.mozilla
Status: NEW → ASSIGNED
Attached patch PatchSplinter Review
We weren't updating mGeckoViewport right on tab switch. This meant that touch event coordinates were getting mis-translated until the first call to adjustViewport on the new tab.
Attachment #622021 - Flags: review?(chrislord.net)
Slightly simpler STR:

1. Start Fennec
2. Load http://people.mozilla.org/~kgupta/bug/752939.html
3. Open a new tab with CNN
4. Double-tap on CNN, or scroll way down
5. Switch back to the first tab (be careful not to scroll/zoom the page)
6. Try to click on the link

The test page in step 2 is nothing special, it's just guaranteed to be simple enough that we shouldn't be triggering draws on it that might make the condition hard to repro.
Comment on attachment 622021 [details] [diff] [review]
Patch

Review of attachment 622021 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.

::: mobile/android/base/gfx/GeckoLayerClient.java
@@ +340,4 @@
>              currentMetrics.setOrigin(new PointF(offsetX, offsetY));
>              currentMetrics.setZoomFactor(zoom);
>              currentMetrics.setPageSize(new FloatSize(pageWidth, pageHeight), new FloatSize(cssPageWidth, cssPageHeight));
> +            mLayerController.post(new Runnable() {

Might be worth adding a comment here? Something about how viewports are usually communicated via handleViewportMessage, except in this case?
Attachment #622021 - Flags: review?(chrislord.net) → review+
Comment on attachment 622021 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: occasionally clicking on a link doesn't work, or the click is sent to the wrong spot
Testing completed (on m-c, etc.): locally (ideally i would bake on m-c for a day but we're short on time; this should go into the beta build)
Risk to taking this patch (and alternatives if risky): mobile only
String changes made by this patch: none
Attachment #622021 - Flags: approval-mozilla-aurora?
blocking-fennec1.0: ? → beta+
Attachment #622021 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/e6e6f5bc3561
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Note to self, see if this fixes bug 740005.
Unable to reproduce on on Nightly 15.0a1 (2012-05-14)
                          Aurora 14.0a2  (2012-05-14)
                          Beta           (14.0b1 build3)
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.