Closed Bug 753028 Opened 8 years ago Closed 8 years ago

Extremely slow painting on http://lrvick.net/blog/arch_linux_terminals_in_android/ in portrait mode

Categories

(Firefox for Android :: General, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 757039
Tracking Status
blocking-fennec1.0 --- +

People

(Reporter: ehsan, Assigned: jrmuizel)

References

Details

(Keywords: testcase)

Attachments

(1 file)

http://lrvick.net/blog/arch_linux_terminals_in_android/

The paint seems to never be finished.
Not sure exactly what's happening here but it seems were at least partially slowed by box-shadow
I believe that this is a duplicate of bug 753003.  This seems to be the aurora behavior of the checkerboarding (low res image)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 753003
This bug is specifically about paint performance on that page. I believe the other bug is about something else.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
The title was "never finish" the paints, do they actually finish?
Not according to my testing.
(In reply to Ehsan Akhgari [:ehsan] from comment #6)
> Not according to my testing.

Ok, why is this not a dupe of 753003 then?
(In reply to JP Rosevear [:jpr] from comment #7)
> (In reply to Ehsan Akhgari [:ehsan] from comment #6)
> > Not according to my testing.
> 
> Ok, why is this not a dupe of 753003 then?

Because that bug covers more than just slow painting.  When panning this site, it seems like sometimes we get the wrong offset for the painted sections, which causes them to move incorrectly as a result of panning.
Let's see if this is fixed on nightly. If not, we can address.
Keywords: qawanted
OK.  It's not fixed on the nightly in portrait mode.  landscape mode will load correctly.  It's still slow to paint in portrait.

Tested Samsung Galaxy S II 5/10/2012 Multi locale
martijn, could you break down this page some to figure out what's causing the issue in portrait mode?  [note it doesn't have to be martijn to do this...qawanted to break down web page]
Keywords: qawanted
Summary: Extremely slow painting on a page causes the low-resolution paints to never finish → Extremely slow painting on http://lrvick.net/blog/arch_linux_terminals_in_android/ in portrait mode
Duplicate of this bug: 752029
Depends on: 754985
Duplicate of this bug: 755259
Attached file testcase
The testcase seems large, but I had to add a lot of strings in a comment node, otherwise, it wouldn't reproduce this bug.
Keywords: qawantedtestcase
Dupe of existing bug Vlad?
Assignee: nobody → vladimir
blocking-fennec1.0: ? → +
Whiteboard: dupeme
This seems to work fine for me on a Galaxy Nexus with a build with the patch from bug 753742 applied (that fixes overflow:hidden).
Depends on: 753742
Depends on: 757039
This bug is getting messy; the testcase and rendering issues are fixed, the remaining slowness seems to be due to box-shadow, which is bug 757039.  Bouncing to jeff to close when he closes that bug.
Assignee: vladimir → jmuizelaar
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 757039
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.