Last Comment Bug 757039 - Handle non-uniform scales when doing device space blurs
: Handle non-uniform scales when doing device space blurs
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Jeff Muizelaar [:jrmuizel]
:
Mentors:
: 753028 (view as bug list)
Depends on: 759457
Blocks: 753028
  Show dependency treegraph
 
Reported: 2012-05-21 07:26 PDT by Jeff Muizelaar [:jrmuizel]
Modified: 2012-08-14 08:14 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
soft


Attachments
Handle non-uniform scales when doing device space blurs (3.71 KB, patch)
2012-05-21 07:37 PDT, Jeff Muizelaar [:jrmuizel]
roc: review+
blassey.bugs: approval‑mozilla‑beta+
Details | Diff | Review

Description Jeff Muizelaar [:jrmuizel] 2012-05-21 07:26:33 PDT
The Java screenshoting code draws pages at non-uniform scales. It's not much work to handle these so let's do it.
Comment 1 Jeff Muizelaar [:jrmuizel] 2012-05-21 07:37:52 PDT
Created attachment 625639 [details] [diff] [review]
Handle non-uniform scales when doing device space blurs
Comment 2 Jeff Muizelaar [:jrmuizel] 2012-05-23 07:23:35 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/dc8bae2d72e7
Comment 3 Ed Morley [:emorley] 2012-05-23 08:02:58 PDT
https://hg.mozilla.org/mozilla-central/rev/dc8bae2d72e7
Comment 4 Joe Drew (not getting mail) 2012-05-24 12:15:38 PDT
*** Bug 753028 has been marked as a duplicate of this bug. ***
Comment 5 Jeff Muizelaar [:jrmuizel] 2012-05-25 19:19:08 PDT
Comment on attachment 625639 [details] [diff] [review]
Handle non-uniform scales when doing device space blurs

[Approval Request Comment]
User impact if declined: Very slow box-shadow in java screenshotting code and potential OOM. This is needed to make nonnompaelo.com usable.
Testing completed (on m-c, etc.): been on m-c for a while
Risk to taking this patch (and alternatives if risky): Some risk because it impacts desktop as well as mobile. Passes all our tests
String or UUID changes made by this patch: None
Comment 6 Alex Keybl [:akeybl] 2012-05-29 10:58:41 PDT
(In reply to Jeff Muizelaar [:jrmuizel] from comment #5)
> Risk to taking this patch (and alternatives if risky): Some risk because it
> impacts desktop as well as mobile. Passes all our tests

How should we be on the lookout for regressions here (both mobile and desktop) if approved?
Comment 7 Alex Keybl [:akeybl] 2012-05-29 10:59:36 PDT
rather, the question should be "where" can we expect to find regressions if they do occur?
Comment 8 Jeff Muizelaar [:jrmuizel] 2012-05-29 11:05:38 PDT
(In reply to Alex Keybl [:akeybl] from comment #7)
> rather, the question should be "where" can we expect to find regressions if
> they do occur?

Shadow drawing
Comment 9 Frank Yan (:fryn) 2012-05-29 21:42:23 PDT
Comment on attachment 625639 [details] [diff] [review]
Handle non-uniform scales when doing device space blurs

This caused a regression: bug 759457.
Comment 10 Jeff Muizelaar [:jrmuizel] 2012-05-31 20:42:16 PDT
Comment on attachment 625639 [details] [diff] [review]
Handle non-uniform scales when doing device space blurs

Rerequesting aurora approval now that the regression fix has landed on inbound.
Comment 11 Alex Keybl [:akeybl] 2012-06-01 15:15:59 PDT
Dupe bug 753028 was marked as blocking-fennec1.0+, so setting it to ? here (I don't have access to + for some reason). Given the regression we found previously, let's give this some more bake time on m-c.
Comment 12 Brad Lassey [:blassey] (use needinfo?) 2012-06-04 14:03:26 PDT
Comment on attachment 625639 [details] [diff] [review]
Handle non-uniform scales when doing device space blurs

[Triage Comment]
approval to land on where ever 14 is now
Comment 13 Joe Drew (not getting mail) 2012-06-05 11:39:09 PDT
We're opportunistically taking this, but we wouldn't block on it.
Comment 14 Joe Drew (not getting mail) 2012-06-05 13:41:51 PDT
Ah, turns out this is already on beta: http://hg.mozilla.org/releases/mozilla-beta/rev/74f5e0d677f2

Note You need to log in before you can comment on or make changes to this bug.