Closed Bug 753214 Opened 8 years ago Closed 8 years ago

Graphical/rendering error in landscape mode when visiting the website "http://cbe002.chat.mibbit.com/"

Categories

(Firefox for Android :: General, defect, minor)

14 Branch
ARM
Android
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 753742
Tracking Status
blocking-fennec1.0 --- +

People

(Reporter: metafruit, Assigned: cwiiis)

References

Details

(Whiteboard: [testday-20120518])

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120501201020

Steps to reproduce:

I opened Firefox aurora on my Droid Razr with android 2.3.6. 
I opened a book mark with the address "http://cbe002.chat.mibbit.com/"
I turned the phone into on it side into landscape mode.


Actual results:

There was a strange graphical or rendering error.
Here is a poorly taken screen shot.
http://i.imgur.com/UUIUw.jpg


Expected results:

It shouldn't do that.
Here is what it looks like in the desktop firefox:
http://i.imgur.com/tMsg9.png
Severity: normal → minor
OS: Windows 7 → Android
Hardware: x86 → ARM
I was able to reproduce some graphics tearing on my Galaxy Note. This page has Flash, which may be a contributing factor.

This site randomly crashed a couple times for me with error messages that may be related:

I/        ( 3062): MALI_ERR_OUT_OF_MEMORY in function split_mem when calling the descriptor_pool_get 1
I/        ( 3062): MALI_NO_HANDLE in function _mali_base_common_mem_alloc because the requested_size is 0
I/Launcher( 3062): onWindowFocusChanged(true)
W/InputManagerService( 2784): Got RemoteException sending setActive(false) notification to pid 22031 uid 10123
I/        ( 3062): MALI_NO_HANDLE in function _mali_base_common_mem_alloc because the requested_size is 0
I/        ( 3062): MALI_NO_HANDLE in function _mali_base_common_mem_alloc because the requested_size is 0
I/        ( 3062): MALI_NO_HANDLE in function _mali_base_common_mem_alloc because the requested_size is 0
I/        ( 3062): MALI_NO_HANDLE in function _mali_base_common_mem_alloc because the requested_size is 0
Cc'ing snorp and joe for the flash and gfx issues, respectively. Not sure who should own this.
blocking-fennec1.0: --- → ?
The Flash part is working fine here with m-c. Brad merged the relevant patches to Aurora last night so it should be working there soon too.
This WFM on Nightly (05/09) Galaxy Nexus (4.0.4)
Can we test this on other phones?
Galaxy SII works for me. Should test on lower end phones.
The most aurora build is giving me a worse result! :(
I have the razr with the most up to date everything.
Here is a low quality picture 

http://i.imgur.com/D7Ndh.jpg
Issue is reproducible on Nightly (2012-05-14) on HTC Desire Z running Android 2.3.3 and on Galaxy Nexus running Android 4.0.2. Here is a video http://youtu.be/G7vmQzqXjsk.

I am seeing a few issues with the page:
1. In portrait the viewport is fixed and the user can't scroll the page.
2. When zooming only the content from the original viewport is available. 
3. When rotating any scrolling produces the tearing described in this bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
Yeah this is looking pretty bad on central. It seems like a combination of layer scaling and screenshotting rendering in the wrong spot. Probably dupe of the hotmail bug (bug 753742).
Chris, the thought is this is a dupe of bug 753214
Assignee: nobody → chrislord.net
blocking-fennec1.0: ? → +
(In reply to Brad Lassey [:blassey] from comment #10)
> Chris, the thought is this is a dupe of bug 753214

err... bug 753742, the hotmail bug
This works for me on my device with the patch from bug 753742 applied, but I'd like to have someone else confirm before marking it as a duplicate.
Works for me as well with the patch applied. Marking as dupe.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 753742
Verify that this bug is fixed on nightly (v15 - 18 May).

The bug still affects beta (v14.0b2)

Tested on sgs2 cyanogenmod 9 (ics)

Tested url: http://cbe002.chat.mibbit.com/
Whiteboard: [testday-20120518]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.