Last Comment Bug 753458 - Unnecessary fields added in bug 746633
: Unnecessary fields added in bug 746633
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All Android
: -- normal (vote)
: Firefox 15
Assigned To: James Willcox (:snorp) (jwillcox@mozilla.com)
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 11:45 PDT by Kartikaya Gupta (email:kats@mozilla.com)
Modified: 2012-06-18 12:16 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Remove unnecessary fields in RenderContext (5.52 KB, patch)
2012-05-23 12:16 PDT, James Willcox (:snorp) (jwillcox@mozilla.com)
bugmail: review+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Kartikaya Gupta (email:kats@mozilla.com) 2012-05-09 11:45:24 PDT
The patch at https://bug746633.bugzilla.mozilla.org/attachment.cgi?id=621178 introduces a new screenSize and mSurfaceWidth/mSurfaceHeight fields, which I believe are redundant. The viewport width and height (as obtained by viewport.width() and viewport.height()) should be identical to these values, as they will always be the screen width/height in device pixels.

The extra fields added should be removed, or if in fact there is some reason they are needed, they should be commented as such.
Comment 1 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-05-23 12:16:16 PDT
Created attachment 626545 [details] [diff] [review]
Remove unnecessary fields in RenderContext
Comment 2 Kartikaya Gupta (email:kats@mozilla.com) 2012-05-23 19:04:18 PDT
Comment on attachment 626545 [details] [diff] [review]
Remove unnecessary fields in RenderContext

Review of attachment 626545 [details] [diff] [review]:
-----------------------------------------------------------------

A very enthusiastic r+ from me :)
Comment 3 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-05-24 08:12:19 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/2c51ac146815
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2012-05-25 08:29:23 PDT
https://hg.mozilla.org/mozilla-central/rev/2c51ac146815
Comment 5 Kartikaya Gupta (email:kats@mozilla.com) 2012-06-18 11:59:05 PDT
Comment on attachment 626545 [details] [diff] [review]
Remove unnecessary fields in RenderContext

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: none
Testing completed (on m-c, etc.): on m-c for a while
Risk to taking this patch (and alternatives if risky): need this patch in order for the patches from bug 758635 to apply properly. (this patch also currently doesn't apply cleanly on beta but the rebase seems straightforward enough)
String or UUID changes made by this patch: none
Comment 6 Lukas Blakk [:lsblakk] use ?needinfo 2012-06-18 12:07:50 PDT
Comment on attachment 626545 [details] [diff] [review]
Remove unnecessary fields in RenderContext

[Triage Comment]
As in bug 758635, please go ahead and land this to mozilla-beta tip only.
Comment 7 Kartikaya Gupta (email:kats@mozilla.com) 2012-06-18 12:16:28 PDT
Landed on default branch of mozilla-beta:

https://hg.mozilla.org/releases/mozilla-beta/rev/6333f82c041e

Note You need to log in before you can comment on or make changes to this bug.