unable to download from TPR download depot

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: 1robin.hoods, Unassigned)

Tracking

12 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 622568 [details]
This will show you what I see

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

I have a problem when I go to TPR link = http://trainzproroutes.org/tprdownloads/index.php
I log in and select a file in the form of a CDP to download I click on the download button .
At this point I should get a download box asking me if I want to run or save the file.
Instead I get a page of gobbledegook see link provided.
http://img822.imageshack.us/img822/2873/cdpo.jpg
I am unable to use Firefox to download a file from this site.
If I use IE or Google Chrome then I can download any file from the site.
To reproduce this bug you first need to register on the site.
Once you are registered you then log in to the Depot then chose a file
to download using Firefox.
I am not the only one getting this problem is has also been reported on the Auran Forum for Trainz users.




Actual results:

As stated Instead of getting a download box asking me if I wanted to run or save the file.
I got a page of gobbledegook and I am unable to download any file from the site



Expected results:

I should have got a download box asking me if I wanted to run or save the file
(Reporter)

Updated

7 years ago
OS: Windows Vista → All
Hardware: x86 → All
That just looks like a website problem - they serve the files as text/plain or similar.
IE and Chrome are violating the http RFC and will offer to download the document while they should render the file.
(Reporter)

Comment 2

7 years ago
No they do not serve files as text/plain or similar.
it should download a file as a CDP content dispatcher protocol.
These are files that have to be extracted into a Trainz simulator, they can be Locos or bogeys or parts of that loco needs to show up and work in the simulator.
The fact is that Firefox did download them as CDPs up to about two months ago.
Something got broke or changed with FF with the updated browser I am now using FF 12.
(Reporter)

Comment 3

7 years ago
I also get this problem using FF12 on my main PC which has XP as its OS
>No they do not serve files as text/plain or similar.
Which content-type are they using ?
Please post a wireshark a livehttpheaders log.

This is an example:
http://mversen.de/mozilla/text/mozilla.rar
The binary chars _should_ render in the browser. Every browser that tries to save this file is broken.

I tried your page now after registering:

GET /tprdownloads/uploads/TPR_RSP.cdp HTTP/1.1[CRLF]
Host: trainzproroutes.org[CRLF]
Connection: close[CRLF]
User-Agent: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/15.0 Firefox/15.0a1 SeaMonkey/2.12a1[CRLF]
Accept-Charset: ISO-8859-1,UTF-8;q=0.7,*;q=0.7[CRLF]
Cache-Control: no-cache[CRLF]
Accept-Language: de,en;q=0.7,en-us;q=0.3[CRLF]
Referer: http://web-sniffer.net/[CRLF]


Status: HTTP/1.1 200 OK
Date:	Thu, 10 May 2012 14:59:40 GMT	
Server:	Apache	
Last-Modified:	Tue, 11 Oct 2011 01:04:23 GMT	
ETag:	"a45c011-150e6b3-4aefb7cf073c0"	
Accept-Ranges:	bytes	
Content-Length:	22079155	
Vary:	Accept-Encoding	
Connection:	close	
Content-Type:	text/plain

As expected, the server sends the file as text/plain (see the content-type http header sent by the server).
Please ask the server administrator to fix the content-type.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

7 years ago
If you download a file = CDP from TPR using either IE or Goggle Chrome then you do get a CDP download so you should also be able to get a CDP using FF.
when I was using an old version of FF I could download a CDP but since I have been using FF12 I have not been able to?????
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
>If you download a file = CDP from TPR using either IE or Goggle Chrome then you do 
>get a CDP download so you should also be able to get a CDP using FF

No, what a software in the internet should do is specified by the rfc.
-> http://en.wikipedia.org/wiki/Request_for_Comments
It's wrong to _not_ render the file.

Did you clicked the link (http://mversen.de/mozilla/text/mozilla.rar) and tried it with IE and Firefox ?
I'm owner of that domain and the right thing is that the browser displays the binary chars as text. A browser that doesn't do that is broken.

>when I was using an old version of FF I could download a CDP but since I have been 
>using FF12 I have not been able to

Then either the server configuration changed between the Firefox updates or the server deliverers different content-types with different user Agent strings.
The behavior of Gecko didn't change as you can see by a similar report here: bug 173175 (not the date)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

7 years ago
I have now found a way round this problem
Once you have the gobbledegook page displayed you right click on it and select save page as.
You do have to change things in the save as page once it has opened.
For demonstration I will use one of the files from TPR = Kings_School1 you have to change this to Kings_School1.cdp in the top box.
The bottom box also has to be changed from default = save as type text document to 
save as All files this is done by selecting the small dropdown arrow and selecting All files.
You can then click onto save and the CDP file will download as a CDP
(Reporter)

Comment 8

7 years ago
I have now found that you dont need to change anything.
Once the gobbledygook page is displayed you can just select save page as and then click onto save and it will still save the file as a CDP
You need to log in before you can comment on or make changes to this bug.