Last Comment Bug 753618 - Remove outdated default theme icons and previews from Add-ons Manager
: Remove outdated default theme icons and previews from Add-ons Manager
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 15
Assigned To: Frank Yan (:fryn)
:
: Dão Gottwald [:dao]
Mentors:
Depends on:
Blocks: 783241 783522
  Show dependency treegraph
 
Reported: 2012-05-09 18:32 PDT by Frank Yan (:fryn)
Modified: 2012-08-17 04:53 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (3.52 KB, patch)
2012-05-09 18:32 PDT, Frank Yan (:fryn)
no flags Details | Diff | Splinter Review
patch v2 (8.72 KB, patch)
2012-05-09 18:52 PDT, Frank Yan (:fryn)
no flags Details | Diff | Splinter Review
patch v3 (9.53 KB, patch)
2012-05-09 19:01 PDT, Frank Yan (:fryn)
blair: review+
Details | Diff | Splinter Review

Description Frank Yan (:fryn) 2012-05-09 18:32:21 PDT
Created attachment 622601 [details] [diff] [review]
patch

Jared reminded me that the icons and preview images for the default themes in the Add-ons Manager are long outdated.
I removed the preview images and replaced the icons with 11-byte transparent 1x1 PNGs to avoid having to change any JS for now.
We can revamp the Add-ons Manager UI at a later time.
Comment 1 Frank Yan (:fryn) 2012-05-09 18:52:45 PDT
Created attachment 622602 [details] [diff] [review]
patch v2

Now using the generic theme icon as the default theme icon for all 3 platforms.
Comment 2 bogas04 2012-05-09 18:57:33 PDT
Is it true Default theme would be removed from the list ? If so then how would a user return to default theme when using some other theme. Though australis mockups show a new customisation page.
Comment 3 Frank Yan (:fryn) 2012-05-09 19:01:10 PDT
Created attachment 622605 [details] [diff] [review]
patch v3

Forgot to edit browser/installer/package-manifest.in.
Pushing to try and locally testing to make sure everything works.
Comment 4 Blair McBride [:Unfocused] (UNAVAILABLE) 2012-05-09 20:22:55 PDT
(In reply to bogas04 from comment #2)
> Is it true Default theme would be removed from the list ? If so then how
> would a user return to default theme when using some other theme.

As part of the revamp of the Add-on Manager's appearance pane (bug 520124), I've been planning to only show the default theme when there are other heavyweight themes installed. So by default, the default theme will be hidden.
Comment 5 Blair McBride [:Unfocused] (UNAVAILABLE) 2012-05-09 20:31:33 PDT
Though I'm a bit confused by this bug. Why did you initially want to remove the icons now? The preview is indeed very outdated, but why not replace it with an updated one?

Note that once bug 520124 eventually lands the icon won't be used, but the preview image will. See attachment 464426 [details] for a rough idea.
Comment 6 Blair McBride [:Unfocused] (UNAVAILABLE) 2012-05-09 20:33:33 PDT
Comment on attachment 622605 [details] [diff] [review]
patch v3

(Pretty sure I should review this, given it exclusively affects the Addons Manager.)
Comment 7 Frank Yan (:fryn) 2012-05-09 20:50:12 PDT
(In reply to Blair McBride (:Unfocused) from comment #5)
> Though I'm a bit confused by this bug. Why did you initially want to remove
> the icons now? The preview is indeed very outdated, but why not replace it
> with an updated one?

Because the theme is continually changing and will continue to do so for the foreseeable future, so the image will almost always be out-of-date.
It's also not especially useful to display the preview of the default theme which the user already knows it looks like.

> Note that once bug 520124 eventually lands the icon won't be used, but the
> preview image will. See attachment 464426 [details] for a rough idea.

It looks good. Like we currently do, we should be able to fall back to displaying something generic if a preview is not required.

For the longer-term future, the architecture of non-lightweight themes requiring a replacement for every single image that we have in the default theme inherently makes it difficult for potential theme authors to learn how to make a theme and be able to make one quickly. Also, compatibility has been and will be very difficult to maintain. Rather, I think we should make it easy to build restartless extensions that solely apply stylesheets to the browser and replace images.

If/as we move to the model that I just described, it will make less and less sense for the default theme to be displayed in the themes tab, since non-lightweight themes will be superseded by restartless extensions using theming modules, and they will be applied on top of the default theme, not replacing the default theme.
Comment 8 Blair McBride [:Unfocused] (UNAVAILABLE) 2012-05-10 19:36:45 PDT
(In reply to Frank Yan (:fryn) from comment #7)
> Because the theme is continually changing and will continue to do so for the
> foreseeable future, so the image will almost always be out-of-date.

Fair enough.

> If/as we move to the model that I just described, it will make less and less
> sense for the default theme to be displayed in the themes tab, since
> non-lightweight themes will be superseded by restartless extensions using
> theming modules, and they will be applied on top of the default theme, not
> replacing the default theme.

Yep, I've been thinking the same thing. The Add-ons Manager won't be dropping support for heavyweight themes though, just deemphasising them - so there will still be cases when the default theme is shown.
Comment 10 Rob Campbell [:rc] (:robcee) 2012-05-11 11:26:53 PDT
https://hg.mozilla.org/mozilla-central/rev/53665792bf24

Note You need to log in before you can comment on or make changes to this bug.