Last Comment Bug 783241 - add extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/preview.png to removed-files.in
: add extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/preview.png to removed-...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 17
Assigned To: Ben Hearsum (:bhearsum)
:
Mentors:
Depends on: 753618
Blocks: 783522
  Show dependency treegraph
 
Reported: 2012-08-16 06:10 PDT by Ben Hearsum (:bhearsum)
Modified: 2013-11-12 00:56 PST (History)
2 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wontfix
fixed


Attachments
add preview.png to removed-files.in (671 bytes, patch)
2012-08-16 06:10 PDT, Ben Hearsum (:bhearsum)
bmcbride: review+
ted: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta-
bhearsum: checkin+
Details | Diff | Splinter Review

Description Ben Hearsum (:bhearsum) 2012-08-16 06:10:57 PDT
Created attachment 652418 [details] [diff] [review]
add preview.png to removed-files.in

bug 753618 removed preview.png from the default theme from the package but didn't add it to removed-files.in. This ends up showing up as a warning in our update verification tests, because it exists in an older firefox that has been updated to the latest beta, but not in the latest beta's installer.

Unless there's a reason we want this it to exist for updated users only, we should add it there.
Comment 1 Ben Hearsum (:bhearsum) 2012-08-16 07:02:44 PDT
Comment on attachment 652418 [details] [diff] [review]
add preview.png to removed-files.in

I'd like to land this on Aurora and Beta. This patch will cause updates to 15 to remove extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/preview.png at update time, which will make them consistent with the Firefox 15.0 installer. I don't think there's any risk to us taking this.
Comment 2 Ben Hearsum (:bhearsum) 2012-08-16 07:03:42 PDT
Comment on attachment 652418 [details] [diff] [review]
add preview.png to removed-files.in

Landed on m-c: https://hg.mozilla.org/mozilla-central/rev/ea85bbaa681e
Comment 3 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-16 11:08:36 PDT
Comment on attachment 652418 [details] [diff] [review]
add preview.png to removed-files.in

Looks like a simple clean up, thanks for doing this. Approving for Aurora, but not Beta since we're too close to the end of cycle there.
Comment 4 Ben Hearsum (:bhearsum) 2012-08-16 11:58:25 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/856b6b5bf31c

Note You need to log in before you can comment on or make changes to this bug.