No way to start Mozilla after cancelling migration. Ever.

VERIFIED WORKSFORME

Status

Core Graveyard
Profile: Migration
--
major
VERIFIED WORKSFORME
17 years ago
2 years ago

People

(Reporter: gerv, Assigned: racham)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

1. Delete profile
2. Run Mozilla when you have a copy of 4.x running around. It asks if you want 
to migrate. Click Cancel.
3. You get the Profile Manager dialog box, with one profile, named "default".
4. Select this profile and click "Run Mozilla." 
5. Nothing happens.

In addition, do 1-3 above, then:
4. Click Exit.
5. Run Mozilla again. You are again asked if you want to migrate your profile. 
Click OK this time.
6. Crash in XPCOM.DLL.

So someone starts Mozilla for the first time, says "take my profile? Oh no!" and 
clicks cancel, and exits. Then they have a think, and go "OK, it can take a 
copy", run it again, and boom. They have no way of starting Mozilla - these two 
bugs mean that going via the Profile Manager won't work, and migrating won't 
work either. Reinstall time (or delete profile time, but they wouldn't know 
that.) Bad.

This could be related to bug 63842.

2001-04-09 Win95.

Gerv

Comment 1

17 years ago
Using build 2001091303 and steps listed above, not able to reproduce,
marking worksforme

please reopen if this recurs.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 2

17 years ago
verified
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.